Plex bought not showing up in account

Hi,

How long does it take for plex to show up in your account after purchase? I bought some yesterday from eveonline website and it is not showing in my account.

Thanks

It should be instantly as far as I know. Are you sure you finished the purchase correctly?

1 Like

Yes the transaction is showing as paid in my account history.

If you haven’t bought from them before I think it can be an hour or so as some security measure or something.

PLEX is automatically added to the PLEX Vault in the Pilot’s Services tab of your Character Sheet.

PLEX contained within the Vault is available to all characters on that account. To transfer PLEX from a character on that account to another character on a different account, use the in-station Trade option or set up a Personal Contract.

There is nothing in the plex vault. I bought the plex two days ago. I am going to contact my credit card company to get my money back. This is just unbelievable.

Have you tried filing a ticket, which you should have done instead of posting on the forums as if you were trying to make them look bad? That’s the only part here that’s unbelievable so far: How you didn’t do what every other sane person would do, which is filing a support ticket.

1 Like

Instead of that, first contact CCP Customer Support about the issue.

https://support.eveonline.com/hc/en-us/requests/new

Of course I have opened a ticket. I have only posted here because nobody responded to the ticket. And that was 2 days ago. It doesn’t take 2 days for a digital item to be delivered. In any game in this world.

1 Like

Okay, well, then good luck. It’s not that I don’t agree with the waiting time being bad, but I also don’t agree with your approach. Please, in the future, remember to mention you’ve filed a ticket. What’s a bit odd about the situation is that billing related tickets should be of priority, due to their nature.

Hm. Let’s try this: @CCP_Aurora This man wants to give CCP money!

Are you using Steam version?

Yes I am.

That’s the most important thing which you left out. If you google the term “PLEX EvE steam”, you will find few results which describe the same problem you have.

And here you can find the discussion which has happened two years ago: https://www.reddit.com/r/Eve/comments/7mb3vw/bought_plex_via_steam_have_yet_to_receive_said/.

You might consider creating the EvE account if you haven’t already.

Good luck with resolving your issue. I am with you that the digital goods should appear instantly and it’s really annoying when that does not happen. But please try to understand that there are several things happening in background and that human interaction is most likely required.

4 Likes

Why are you using steam?
Why not just download and play from the launcher/client directly?
I never understood this way…

@Brigitte_Schmidt
Very interesting but there was no way I could have known this. Also the transaction is showing as completed on both my steam account and my eve account.

@xDeadMasterx
I have used steam all my life and never had a problem with it. I mean I can uninstall eve from steam and reinstall it without it if that will solve the problem.

I don’t think new installation will help you out. Maybe you got to redeem it from Steam first? I’m sorry, but that’s all I can do for you - give you a tip regarding steam issues and from there on, you can either wait for the response and/or do what you wanted to do - get a refund.

P.S. Few other MMO’s have issues with steam as well. Let’s take ESO as an example. Whenever the new patch comes, Steam users are not able to play the game for several hours/days.

2 Likes

That’s why I download the games exe file directly and install the launcher that way.
No 3rd party bs/hassles/issues etc.

Except for googling the issue…

1 Like

Not only that.

Even in Steam it says…

STEAM CREATED ACCOUNTS ONLY

This content can only be accessed with EVE Online accounts created through Steam. Existing EVE Online accounts not created through Steam cannot benefit from it.

I don’t understand why people don’t read.

This means he needs to add the account by signing in via the eve launcher using his steam credentials. create the char, and then just move the plex to the char he needs it for.

1 Like

@Solonius Rex
It is a bit difficult googling for an issue you don’t even know it exists…

@Commander Kane
I do not know where you have found that information but it does not work.
I have tried logging in to the eve launcher with my steam credentials and it showed that the account does not exist.

But fear not. The plex has been assigned to my account by one of the admins so no need to worry any more.
Many thanks to the ones who have tried to help me.
This case may be closed now.

2 Likes