Random crashes

I spend most of my time belt mining in orcas, every once in a while I’ll find that one account has disappeared. Is there any way of tracking down why the client closed itself (there’s no error message popup)?

It only happens 1-2 times per week and I’m usually online for ~12 hours a day (while working) so it’s not a major problem, but I’d like to track down the cause if possible.

I’m running through Lutris, 4.8 staging wine, dxvk 1.2 enabled. The wine logs show a few things that might help:

AL lib: (EE) ReleaseThreadCtx: Context 0xf3517aa0 current for thread being destroyed, possible leak!
wine: Unhandled page fault on write access to 0x00000000 at address 0xf7d21c61 (thread 01c9), starting debugger…

Lots of:

02f1:fixme:dbghelp:elf_search_auxv can’t find symbol in module
2019-05-31 15:21:56,911: Unable to read stat for process 13262
(process ID changes)

have had problems with eve 2 times in 17 years. both times I delete eve completely from the pc and retrieve it again, it helped :slight_smile: Fast fix

In the old days you could enter the eve folder and press repair.exe is help for some people,
Can’t find the repair.exe now it may have been removed

Are you leaving the launcher running ? I found that an individual client would crash every so often, and the launcher would freeze at the same time, but other clients were unaffected. I now kill the launcher as soon as the client screen appears, and haven’t had a crash since. This is under Mint 17.3.

Can you completely kill the launcher after you have the clients working? I remember once trying and having them clients become unresponsive, so I never tried again. I now have the minimize to ‘system tray’ option and it just hides it, but is still there.

I had the opposite trouble, where the launcher and one of the clients would both become unresponsive at the same time, whilst the other client(s) kept working. Since I started killing the launcher as soon as the client window appeared I haven’t had an unresponsive client.

2 days and no problems now that I’m killing the launcher. I’ll let you know if the good times continue :slight_smile:

1 Like

In my case, I tried again, if I close the launcher, the clients go unresponsive lol.

What’s your operating system ?

Ubuntu Mate 16.04.6 Wine 4.9
Amd APU A8-5600K, 8GB
RX460 4GB

Sorry, no idea why your setup should behave opposite to mine - I’m on Mint 17.3.

Just had a client disappear with the launcher closed, guess I’m back to the drawing board.

I saw a report elsewhere in these forums that recent versions of the launcher looks as if they close normally, but in fact leave a process running that has to be killed by the task manager - it might be worth checking to see if that’s happening next time.

I know you can check where it exits the launcher but leaves it on the ‘system tray’. So I can close the launcher but in reality is just minimized. If I close the icon on the ‘systray’ then my clients go unresponsive.

PS: Is not really a big deal to me, I was able to run 4 clients with the launcher minimized before, and after the pre64bit update, now I can barely do 2 (with launcher).

PS2: I still wonder, since I tried with the old wine I had 3.0.4 and 4.9… what did CCP do to trash the CPU usage…

PS3: I currently have checked use dev versions and latest, but the pull down menu shows two more options, which I have not tried yet, winehq-binary-224 and winehq-binary-225, which I don’t know what they do. (Update: Checked them, no difference in CPU usage, also shows as 4.9 anyways)

PS4: And what is that Use custom wine used for?

I have much the same, I used to be able to run 3 clients simultaneously but now the maximum is 2 - and even then the FPS for both drops after a few re-logs and I have to re-boot my PC to get it back. Problems requiring a reboot had been almost non-existent on my linux PC in the past, so someone has to have screwed up big-time to have produced this situation.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.