[RESOLVED] 20211116 - Issue with Avast Antivirus and the EVE launcher

Haven’t had any issue today following the update, yet, but I had popups from Avast after the patch on Singularity on (Edit November 3rd), mainly anytime I would log off and quit for an account. It was about Exefile.exe.
Edit: I currently see Exefile.exe in the quarantine with menace “IDP.Generic”
I confirm it is currently only for the exefile.exe in the SharedCache\sisi\bin64

I did not restart the launcher since the live updtate today. Hopefully it doesn’t break my install.

Removed offtopic postings. Please limit posts to details of AVAST issues you are experiencing

1 Like

Hi everyone,
I’ve had the same issue with Avast, having the Qtwebengineprocess.exe file moved to the quarantine vault. After having tried to scan it with other programs - and unable to - I decided to do a fresh install of the game.
I’ve tried it now to install the game two times in a row, a complete, fresh installation, but I can’t get it to work, the launcher simply won’t start… I’ve added a couple of exceptions to Avast, in order to facilitate the launcher to work but no luck so far. As such, I’m not sure what to do next… Any ideas? I’m running win10.
Hope this issue gets resolved soon :wink:

NM …

–Correcting Gadget

Same problem here - Avast quarantined the QtWebEngineProcess.exe file and would not let me restore it.

I uninstalled Avast, uninstalled Eve, re-installed Eve and all is fine.

The affected files are

Qtwebengineprocess.exe & crashpad_handler.exe

typically located in the EVE Launcher directory. Our tech team is working with Avast to determine what the issue is that’s flagging the false negative, and hope to have an answer soon!

In the meantime, you can find a previous version of the launcher here: https://www.eveonline.com/EveLauncher-1952584.exe

1 Like

Thanks for the quick reply CCP Swift!
I did try and restore the file on another pc (that was having the same problem) but Avast prevented it.
After wiping the game and reinstalling the launcher - and being unable to get it to work -, I went here:

followed every step of the instructions and clearing the cache enabled the launcher to work again.
The game is now downloading. I will post another reply here to let you know if it worked or not :wink:
Thanks again!

Hi,
Just to let you know that the game is now working :wink: And, just in case, I have added exclusions in avast for:
C:\EVE\Launcher\evelauncher.exe
and
C:\EVE\eve.exe

To add exclusions in Avast go to:
Menu
Settings
Exclusions
and browse path to relevant file

Hope this helps other players experiencing similar problems :wink:
Thanks!

Hello all

Issue happended this afternoon where the launcher just disappeared.

Tried to restart it, would try and open. CCP would show but not the launcher. (icon on the bottom right of windows 10) but when hovering the mouse over it, it just disappeared.

Did the usual Google and found this…

Which worked.

Finally, I did disable Avast to see if that helped, but no luck.

Almost a boot.ini! :wink:

Shame for the people affected and good to see there’s workarounds. I hope you will keep us updated when more details emerge on why it was flagged, from a nerd perspective that would be an interesting read - assuming that it IS a false/positive and not some actual malicious code that made its way in…

According to the Avast Customer Care Team then this issue has been resolved. Please update your Avast or AVG software to the latest virus definition files.

If you have any issues restoring the EVE Launcher then please send us a technical support request, or file a technical support request with Avast or AVG, or consult the documentation with your antivirus product.

5 Likes

Not quite. This time this is not a self-created issue.

Imagine not having your game folders added as an exclusion in your AV software to entirely negate this

What is this, 2004?

2 Likes

In 2004 I bought a Powerbook G4, so I cannot imagine runnning an operating system that needs anti virus in the first place.

No need when the operating system is the virus.

1 Like

So… Eve has finally gone viral marketing :smirk:

Avast Anti Virus mis-detected EVE Launcher.
The problem then occurred that EVE Launcher would not launch.
Deleting the following folder solved the problem.

C:\Users{windows user}\AppData\Local\CCP

Sorry if this is a known solution.

I’ve had the very same issue, but with Kaspersky Internet Security. I have contacted Support and they told me it’s not their problem. In my case, I was in an Abyssal when it happened and lost a 7 bil Gila and I was told to get lost.

If only I saw this yesterday. This happened to me yesterday afternoon and I just got mad, formatted my whole PC and reinstalled EVE because I had no clue what happened. I was actively playing one minute and just watched it get removed from my desktop and launcer infront of my eyes.

Ah well, I got fresh PC out of it at anyway! Good to see it fixed!

In all honesty, this is really not CCP’s problem that some 3rd party software do something to your system that somehow affected your installation of game client.
The fact they are working on a solution is their generosity, not obligation.