September Release - Known Issues & Feedback (Mac)

Great to know that the issue is being worked on.

Since 2 or 3 days ago (until then it was working fine) the Alt key stopped working for me.
instead the command(⌘) key has become the Alt key.
For example, I now have to press command(⌘)-w to open wallet window instead of Alt-w.
when setting shortcuts, when I press Alt it does not respond, and when I press command(⌘) it displays as Alt on settings window.

Re-installed, tried 32bit, 64bit, changed a bunch of settings and nothing has worked.
And my keyboard isn’t broken. Both command and alt keys work fine on other applications.

Hey Ken, If I understand what you’re describing correctly, this is part of the change to standard (upstream wine). The previous Wine version had bespoke keybindings that are no longer present.

Thank you for the reply!

I was a bit confused as it displayed the command(⌘) key as Alt ingame .
I’ve just found out by pressing ctrl-c and ctrl-v you can copy / paste.
My problem is solved.
Thank you.

Sorry, it was not a bug-report, but a support ticket. (#961054)

GM Zephyr is on it. No complaints!

By the way, fun fact:
When I check in-game my bug-reports, and I get the pop-up “you will now be redirected to your default browser”, it opens a new window: the “Wine Internet Explorer” browser… (which doesn’t load)
My default browser is Safari.
I’ve never had this happening before either.


UPDATE: This time to crash is inconsistent, but my poor alt lost a shuttle to some unknown npc.
Let’s call this one that. There seem to be multiple problems. This one crashes the entire client after 2 to 10 seconds after undock. This problem exists regardless of graphics mode being used (per my attempts below). This is not only unplayable but dangerous to undock. My poor alt is now sitting at a sun getting a tan.


This seems to be the entire game graphic window is black but the UI is still visible.


I was able to fix the black death windows by using a ‘Performance Mode’ graphics, but while I can see the ships and station interior (as per my previous post) now the sub-windows like ship info, ship skins viewer is full black.

IMAC 4GHz i7
16 GB Radeon R9 M290X 2048 MB
IOS 10.13.6 ‘High Sierra’

Yep latest wine version for me.

Ok I shall raise an ingame bug report. Only thing is, my guy is undocked so the client doesn’t last long enough to file a report. I suppose I’ll file it from a docked alt :wink:

(Or go through 4 or 5 crashes to get him docked up) haha

Thanks, Pope. Using your nomenclature:

“UNDOCK CRASH” - so far we see this almost exclusively on 64-bit Mac clients and are investigating further with that it mind.

“BLACK DEATH WINDOW” - this is not Mac specific, but seems related to post processing (the reason Performance Mode works around it is by disabling some elements of the feature) a fix is underway.

“BLACK SUB WINDOWS” - this is the first report I’ve seen of that, and I haven’t seen it on my own High Sierra machine (significantly older and less beefy that your machine). Will look for additional info in existing bug reports.

FWIW, the client just froze on me while running in 32-bit mode, but I didn’t force quit it this time and it unfroze itself after a couple mins. These don’t seem to be the same kind of freezes that happen in 64-bit mode, so the (temporary) freezes I’m experiencing in 32-bit mode may be unrelated and be caused by the 32-bit limitations instead. Can’t say for sure because I’m playing on a new iMac now and never played in 32-bit mode on it before, nor did I play on the old iMac (which cannot play EvE anymore) with the settings I’m using now.

iMac 5K, 40 GB RAM, Radeon Pro 580X, macOS 10.14.6, playing in windowed mode at 2560x1395 (unsupported in 32-bit, I know) with max quality settings.

EDIT: And right after having posted the above, while cloaked in space but without having done anything, it finally crashed saying this (again, in 32-bit mode):

Runtime error!
Program: C:\tq\bin\exefile.exe
abnormal program termination

On my end I can confirm that I can fix the “black death window” by setting anti-aliasing to disabled and post-processing to None. Changing either of these settings result in a black windows with UI still visible.
Note that don’t seem to have any issue on my MacBook Pro 2014, but have all of the above issues on my iMac Pro 2017.

I’m no longer able to CMD+ on any of my key binds. I’ve tried other combinations, seems like Control+A, Control+C, Control+V will work as intended, but nothing else.

Didn’t realize how much I used CMD+Mouse click to navigate…

Anyone else with this issue? Any known fix yet?

They depricated the CMD+ key combos a few versions of Wine ago when they made 64bit optional-- there is a modification you can make to a file to get them working again. That did not come in on this latest version 9/10/2019 patch.

Serious issues for me

Client completely freezes when trying to warp
When quitting client actually black screens then logs my mac off!

Macbook pro 2016 8gb i5

I am wondering if the Wine testers were testing too much wine. These issues should had been pretty easy to catch. I have no issues in 32-bit mode, though I am only running in medium graphics mode on my older iMac. I have the shaders, etc. turned off.
If you do not close the launcher… when you log back in, the launcher does use the previous settings.

I’ve been using the 64-bit client for months and haven’t had issues this bad until DT 2 days ago.

I’ve been running the 64-bit client ever since the beta became available, and found it to be much more stable and an overall smoother experience. It’s strange that suddenly the 64-bit client no longer works now that the beta period is complete. What changed on the backend?

1 Like

I also need to say that I have Problems with Sept Release.
First All Spacegfx was blacked out… only Menu worked well.
Then drilling down to Minecraft GFX style game works… But Fitting screen does not show a ship model, and game clients crash after some minutes constantly.

1 Like

Yep so best thing to do if you’re getting the ‘in space freeze’ or warp freeze, is to run the log lite application and then log in and undock (use an alt maybe) - then save the log file down after the crash and raise a bug report, attaching the file.

The more people send the log files the better. It seems the 64bit freezing is only affecting some people.

Why is logging out of eve also logging me out of my mac as well!! Happens every time. Coupled with warp issue eve is literally unplayable for me

Yeah, experiencing the same issues as many others. All in space elements (excluding user interface) is a black screen. Changing too ‘Performance Mode’ will induce space elements to be rendered in the viewport. Running this on a 10 Core Xeon iMac Pro.

If I’ve submitted multiple bug reports with logs etc on these freeze issues, do I need to explicitly ask for compensation within the big report ?