[SOLVED] Launcher suddenly broke; "Installer Error" on reinstall attempt

I’ve been playing EVE Online on my PC for several years with no issue. I am not infected with malware and have not done any software or hardware changes or new Windows Updates.

A couple of days ago I tried to launch EVE as normal. Nothing happened. Task manager showed the evelauncher.exe process, but nothing was happening at all. This seemed to be completely out of nowhere.

I tried clearing the cache and it didn’t help, so I uninstalled the game. When I tried to reinstall, the installation failed. I get this:

Installer Error
Error during installation process (com.ccpgames.eveonline): Execution failed (Unexpected exit code: 2359302): “comd /C wusa.exe C:\EVE\Windows6.1-KB3118401-x64.msu /quiet /norestart /log:wusalog.log”
Retry Ignore Cancel

Noticing KB3118401, I made sure I had that Windows Update. I even uninstalled and reinstalled KB3118401. Still getting the same error.

If I ignore the error, the game appears to install, but I end up in the same situation. I double click to open the launcher and nothing happens - the process just hangs in task manager, but nothing ever opens.

Any fixes or ideas would be great, because I’d really like to play EVE again without having to format my hard disk.

========

UPDATE: I suspect this is caused by my computer lacking some critical Windows update. I thought I had everything up to date but I don’t. I will keep trying to update my Windows installation; I hope that will fix the problem.

========

UPDATE 2: I have now installed all Windows Updates that the Windows Update utility offers to me and I’m still getting the same situation: The installer does install the KB3118401 update if my computer lacks it and goes through to 100% with no problem; if I already have KB3118401, that’s when it returns the error I transcribed above; in either case, once the installation is complete, the launcher will not open.

Very odd to me that the game used to work and then one day it just stopped. I believe I last launched it about two months ago.

========

UPDATE 3: I fixed the problem by removing KB3118401 which came with the launcher and any other updates which I had suspicion about, running Windows Update over and over, reinstalling Update packs and rollups, etc…eventually the game launched. I see that the launcher looks different compared to the last time I saw it, so that makes sense.

Here’s the fix, if anyone else is having this problem - (which I doubt, in the year 2021) - it’s caused by an out of date Windows 7 installation with updates which are incorrectly installed, or some other missing dependency. No telling exactly which update EVE needs to run now.

If you think you have all Windows Updates and can’t finesse it manually like I did, the only fix would be to reinstall Windows and carefully install all updates before installing EVE.

1 Like

Thanks for updating your post. Might help the next guy with the same problem.

Anyway, I’ll check back in later today and try to help you out if you’re still having problems.

No problem, I have just posted a second update. Unfortunately the situation is unchanged: EVE launcher still won’t open. No error message or anything. Any suggestion you have would be greatly appreciated, as I feel like I’m running out of ideas.

Maybe I could try installing an older launcher version, or looking for any lingering files on my PC that didn’t uninstall.

I tried installing the game through Steam - same result, hit Play and nothing happens - evelauncher.exe process running in task manager, Steam thinks the game is open, but it’s not.

Well, I can’t really find anything online, so here’s some generic troubleshooting steps.

  • First, file a support ticket in order to get in line.
  • Second, use the free version of revo uninstaller to uninstall Eve (it will search for leftover files and registry keys), and then try reinstalling again.
  • Third, do a repair install of windows, in case there are any window related problems.
  • You can also do a fresh install of windows, but that’s the nuclear option (you’ll have to back up all your files and reinstall everything). So, you should probably only go that route if you are desperate, or sure that your windows installation is fubar’ed.

Not sure if this helps… I seem to have had a major launcher update after I got home from work. Nothing this morning for it. Maybe try it again and see if the launcher update kicks in?

Best of luck with the problem!

  • I re-downloaded the launcher and the outcome was the same

  • I tried downloading an old, 2018 version of the launcher. That one opened, and it detected an update, which it installed. After the launcher update went through, the launcher stopped opening again.

  • I tried downloading the 10 GB EVEResources.7z file and installing with those present. Installation completed but then the launcher wouldn’t open.

  • After running Revo Uninstaller, I found two installations of EVE: one dated 5/31/21, version 2.9.2, and the other 6/17/21, version 1.0.0. And I checked Add/Remove programs and found 10 copies of EVE listed.

  • So I used Revo’s deep scan option and fully removed all traces of EVE. Reinstalled…same problem. At least now, evelauncher.exe didn’t hang in task manager, the process just closed itself immediately.

  • I can’t do a repair install of windows because I’m still on Windows 7.

Support ticket, nuclear option, or play on a different PC seem like the only choices left. My best guess is that something is busted with my Windows install, something related to Windows Updates.

UPDATE: My hunch was correct. I uninstalled any Windows Updates that I had suspicion about, including the KB3118401 that came with the launcher, re-scanned for available updates, and repeated ad nauseam until the game launched.

No telling which update or update pack/rollup did the trick, but it works now. See you all in New Eden!

2 Likes