The Asteroid Distance Debacle

I doubt I am the first, or indeed the only, person to have noticed this bug since the ‘changes’.

So, I move my Proc up to an asteroid. The range thingy says the asteroid is at 11km. I start mining. I have my ‘escape’ destination in sight, and a little later I decide to ‘align’ to it. But what’s this ? I cannot align at all…because all of a sudden the ‘distance’ to the asteroid says 0 meters. And that is despite the fact that visually my distance from this 11km wide asteroid is the same as its width !

I had to point my Proc away from the asteroid and have full thrusters on for several minutes to escape this distance nonsense and for the distance to finally rise above zero. Even though I was far from the asteroid surface. I have noticed the same thing even mining with a Venture.

Oh…and the same issue occurs with mining drones on larger asteroids. They get stuck if they wander round the other side of the asteroid, and take ages to return.

This is clearly a bug in the system. Is anyone doing anything about it ?

This has been a bug since the beginning. So common that CCP made a specific section in the drop down menu for stuck things when you are filing a ticket to rage because you died due to getting hung up on an asteroid. Or you are just stuck and can’t do anything. Or whatever.

Mr Epeen :sunglasses:

I’m aware of the long-standing “stuck on things you’re visually 5km away from” issues in certain areas. However in the past week or so I’ve gotten hung up on asteroids in missions that I’ve done in the past and pretty sure they didn’t catch me at that range before.

It may just be that I was approaching from a different angle or something but the models definitely appeared to have a much larger “collision range” than I recall.

Have the asteroid models or collision geometry changed with any of the recent updates?

1 Like

Not really. Maybe at very close range before, but I’m talking about being at several km from the asteroid when it suddenly starts saying 0km. This was the very first thing I noticed when the ‘changes’ came in.

In today’s example, I moved my Proc to 11km from the asteroid, which was about equal to the actual diameter of the asteroid…so we’re talking about some distance. It wasn’t till I tried to align with a station that it just would not do so, and the distance was saying 0km even though I was far from the asteroid.

Thank you, I’ve read the patch notes previously.

Unless I’ve missed something, there’s nothing in there about changing the collision geometry or detection around asteroids. If someone can point me towards that section I’d appreciate it.

If not, well, this wouldn’t be the first time CCP didn’t include changes in the patch notes, or completely didn’t even notice that their changes to one system affected something else.

this is the first of three waves of expanding the collision/invisible barrier around asteroids so miners do not have risk free and unrealistic direct line travel through an asteroid belt

Well in that case it’s a complete joke. It can’t go telling you one minute, when you are approaching the asteroid and firing the laser and stopping, that you are 11km away from it…and then after you’ve been mining a few minutes suddenly decide that you are 0km away even though nothing has changed.

I had a direct line of sight to the station I wanted to warp to. I was the same distance from the asteroid as its huge width ( about 11km )…yet when i tried to align it said 0km, and refused to let me align. I literally had to point the ship away from the asteroid and fire thrusters for over a minute for 0km to even start saying above 0km. Utterly absurd. It’s bad enough that the Proc now takes 50 years to get to warp…without having to add another 5000 years just trying to escape some invisible force field miles from the asteroids.

I believe he was joking.

This had always to my knowledge been the case when trying to warp out through a belt. Some people might say never sit under or above the belt line so I like to start on either left or right side and go mow the lawn.

1 Like

You’re the 2nd miner to post this. I can only believe ya’ll are incompetent miners ROFL.

I mined for like 7 hours today. Never once had an issue.

I’m guessing you guys get real close with your roids huh?

Miners and their rocks I tell you.


What part of ’ I was 11km away’ was too difficult to comprehend ? I was the same distance from the asteroid as its actual diameter. That is hardly ‘close’.

And the issue is not how close one is, but that the displayed distance changes after one has started the lasers. One minute it can be nicely showing 11km…next minute it suddenly shows zero.

It is primarily only an issue with larger asteroids, 10km or more in size. I suspect because being 10km away from the surface a 10km wide asteroid confuses the system more than being 5km away from a 1km wide asteroid.

Ah so ya’ll are fail pilots. Got it :smiley:

Been mining for hours, no problems big or small.

I guess miners can’t even mine right?


Well, there is something.

We warped a large gank fleet to an asteroid belt, half the fleet got stuck in the rocks for several minutes - faction police did not show up, until after we became unstuck (most of the fleet escaped, despite being static in space for several minutes). I would report it to CCP, but they never responded to my previous emails.

I just checked, and you’re listed as a “Large Collidable Object” in our support database.

1 Like

I mean CCP checked, and I wouldn’t know anything about it.




I did the thing again, and I need you to fix it…

If I was looking to mine smug, self-satisfied, narcissistic, ‘I know absolutely everything and more’…I’d mine in the Gix system every time :slight_smile:


Everyone exhobits narcissistic traits at different points. It doesn’t mean in any way that someone has narcissistic personality disorder and considering the context of this game, it’s not surprising people exhibit those traits more.