The game just wont start

I often play on my mac from steam, but lately the game hasn’t been letting me into the actual world and just keeping me at the loading menu. I tried redownloading and now it wont start at all because its damaged/incomplete or something. How can I fix this?

Okay, I don’t crap about macs. However, if this was a windows PC, I would tell you:

If you get desperate, and live in the states, you can use Eve Anywhere.

Finally, come back and tell us how managed to solve this issue. Might help the next guy with the same problem.

No P2W

so now i think it has something to do with the launcher itself, i tried bypassing steam and the launcher did the same thing as the steam one. also, apparently eve anywhere requires omega :frowning:

lol i just play on my mac because sometimes its more accessible and portable. it works fine on pc.

cache cleared, game deleted and reinstalled, the problem has persisted.

Screen Shot 2021-07-06 at 2.14.27 PM
having bypassed steam again, i am able to open the launcher, but this happens when i try to start the game.

Um… try this.

  • Go into the launcher settings and select an older wine version (sorry, I don’t have directions for how to do this. You can try doing your own google search, or just try poking around).
  • Turn on “Prevent App Nap”.
  • Try starting the client without starting any particular account, and then logging in through the client (as apposed to the launcher).

Posts that might help:

No P2W

i think i tried just starting the client, however i dont remember seeing that screen, where is that?

That’s the standalone launcher. Click the gear icon in the top right corner to get to settings.

sigh
“game client has closed unexpectedly.”

Well, you can run windows in a virtual machine, or you can set up dual boot. Personally, if I had a mac, I’d set up dual boot so that I could game with as few headaches as possible while getting the best performance that I could get. I know it’s a lot of work, but it would give you the best of both worlds once you do get it set up. Other than that, all I can say is that you should file a support ticket if you haven’t done so already.

Sorry I couldn’t have been more help.
No P2W

I’m having the same issue right now and I’m on a Windows machine so it’s not Mac specific. “Game client has closed unexpectedly” whether I try to enter Tranquility of Singularity. I’m using the regular launcher, not Steam. I’ll post an update if something works but so far no luck.

Well, according to eve tech support, the game isn’t supported on apples M1 chip, and I can’t play it until the new Native MacOS client is released. I think I could play it on the singularity test server, but I would need a whole new account, so nah.

As long as you are not using the new macOS beta, and you use wine 4.17 EVE runs just fine on M1 machines. there are hiccups but that can get worked around. or if you are omega. just use the beta web client.