Why does this game never work on Mac?

I press “Play Now” and it just says “Client Assigned to has Closed Unexpectedly”

Tried uninstalling and downloading again, the same problem, and I remember trying years ago and had the same issue too.

What is up with the EVE Client these days?

Well, have you tried running it on a PC? :slight_smile:

3 Likes

Nothing…Mac sucks. It plays fine on Windows. Maybe if Apple owned a piece of it, it would work better for you. :wink:

1 Like

Unless you’re going to reply with something helpful, I’m not interested in your replies. Saying “Don’t use a Mac” isn’t helpful, if it doesn’t work on Mac, there shouldn’t be a client.

8 Likes

I’m messing with you dog. I mean, macs aren’t the best gaming platforms, but I was just trying to have some fun with you.

Anyway, I found this thread, so check that out and see if any of that might help you. And, if push comes to shove, file a ticket with CCP.

same issue here… looks like latest mac launcher has issues.

Notes: I was also unable to exit the launcher correctly - needing to force exit as it locked up. If it helps with the debug… i also noticed high cpu usage when last playing.
– currently running a verify to see if the ‘forced exits’ had corrupted something

I have the same issue; the actual gameplay is fine, it’s the launcher quitting that causes an issue. I have to force quit it every time. I hope this gets some attention from support.

Tried everything, still not working :confused: Haven’t been able to play since 2015 when I switched to Mac, just never worked for me. I’m not going back to Windows because I hate 10… I think it’s the worst OS I’ve ever used and Windows 7 isn’t supported any more.

I cannot even update to Catalina Mac OS cause that sucks, so I’m stuck on Mac OS Mojave.

My Mac is a AMD 395X 4GB 16GB Ram 4ghrz 6770K 1TB NVME. It’s from 2015 but I’m not going to upgrade it seeing as Apple put their prices up massively in recent years, like the equivalent of my PC is double the price now… I’m not paying it Apple to upgrade. This was £2500 which was a great price back then for a 5K Display and this spec, I didn’t feel like I was getting screwed, now they’ll charge you £5000.

A Mac is not a gaming machine. Never has been, never will be…

Well it is cause can play games.

1 Like

I have managed to log in … but High CPU usage and (non) quitting is still a problem.

Notes: Try validating the cache, quit/ force exit, allow any updates/ instals to be done … revalidate then restart/ force quit … If it helps I am on client 1678293 … launcher 1678945 and launcher UI 6.3.9. ( info bottom left of launcher) .

You may find a totally new download and install would be advantageous. A number of forum post show how to totally erase then reinstall

Gajy - if it helps use a 2011 iMac using Sierra… so you should be ok to play if i can…

I’m on those versions too, on Mac you just drag the icon to bin and it uninstalls it… so I dunno what else there is to do there? I’ve tried a few times.

Still says Client Assigned to has Closed Unexpectedly

Is this game still popular? Cause the forums don’t seem populated any more and the population on the launcher is half of what it was 10 years ago. I see on Google as I download the Client again, they’ve been bought by a Chinese company… usually that means the end, everyone bails when the Chinese buy a company.

Tried everything I give up, I’ll play something else.

It’s their end not mine, you cannot go wrong with Mac like Windows.

1 Like

Hi gajy
The uninstall is not as easy as just dumping the icon to trash … I thought that … check out the forums on this site to see how to fully delete…

– you could also have legacy code hanging around from the 32 bit version… so worth a full delete and reinstall from the current download. This article ( and others similar may assist) 64 bit install /delete. I also found getting a copy of the Quartz installer - again listed in the forums somewhere - may help.

1 Like

Ok tried deleting all the files that are hidden… still doesn’t work.

Any ways I’ll try again in a few years, maybe CCP will have put effort into the Mac version.

I’m using a late 2013 iMac running Catalina with 24GB RAM but only 1GB of video RAM and although I normally get no more than 30 FPS the game runs fine and I’ve never had a problem apart from the launcher crashing on exit occasionally. I think you should open a ticket with CCP. It can’t do any harm.

Why the problem with Catalina? It should run fine on your machine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.