Client Closed Unexpectedly - cannot launch the game on macOS High Siera 10.13.2 Beta 1


(Limyh Oteo) #1

I have the latest beta of macOS High Sierra 10.13.2 and I cannot launch the game anymore. On the previous High Sierra versions most things ran fine (I had issues where I could not launch multiple clients) but in this build the launcher starts fine but after hitting play for any of the accounts the launcher immediately displays a Client Closed Unexpectedly. Any ideas what could be causing that? I understand that it is a beta version of the OS however I expect it to come out pretty quickly.


(Arthur Aihaken) #2

Try quitting the launcher and restarting it. There was a glitch around downtime that was causing issues with the launcher (these seem to have since been resolved).


(Limyh Oteo) #3

I tried it many times. I restarted the Mac and did basic debugging. I turned on logging for the client but it does not register anything. It seems to me as if the OS stops the launch of the client - whether wine or some other things is denied the right to launch and hence it closed immediately.


(Daniel Tissant) #4

I have this issue! :fleur_de_lis:

I’m trying everything - tried running under Steam, no go
Tried running the Windows Version under Wine Bottler and wine, no go

I think it’s an issue with ALL wine software not just Eve.

:frowning:


(Daniel Tissant) #5

Okay - I’m monitoring, working on this at my blog www.eveblog.space - I have EVE running in Virtualbox but it’s dog slow :-(.

So my next plan tonight is to Create a “Boot up EVE USB Key” so basically I can pretty much plug it into anyone’s machine (including my MAC), boot the USB key and play Eve. Because it’s running on it’s own OS, it means I could go round to a friends house and just borrow their machine (although Linux might need a bit of configuring), and play Eve.


(Bardosh Thiesant) #6

FYI, I reported this issue to CCP yesterday.

Not sure how much traction it is getting or will get but they are at least aware.

I’m on the verge of trying to rollback to 10.13.1…


(Daniel Tissant) #7

Hi Bardosh

Yeah I’ve reported it as well, to be honest I think the more people report it the better, however, I’ve been testing other “Wine” things - like Play on Mac, Wine Bottler none of them work, so Apple have basically killed Wine.


(Bardosh Thiesant) #8

True but if it’s something they will be leaving in… CCP will have to deal with it sooner or later. I’m hoping it’s sooner. :slight_smile:


(Daniel Tissant) #9

Me too. Going to have to turn on the Windows Machine.

:frowning:


(Bardosh Thiesant) #10

Lucky you… it’s mac or bust for me.


(Gallente Citizen 1449435443) #11

I created a Wine bug report: https://bugs.winehq.org/show_bug.cgi?id=43966, and reported it to Apple as well.


(Arthur Aihaken) #12

Beta, EVE and Wine are three words which do not work well together. If you can, I would rollback to the latest 10.12.6 release. Best of luck.


(Bardosh Thiesant) #13

10.13.1 works perfectly fine.


(Daniel Tissant) #14

Yeah I’ll wait but thanks for the info. I’ll play it on my Pc. But i’m on the case trying to solve it.


(Jenne Wain) #15

This just bit me today. I’m “happy” to know it’s not just me :expressionless:

I reported it as well. Haven’t had any issues with the previous betas, and, of course the one time I don’t clone my drive before the update, something goes wonky.


(Daniel Tissant) #16

Yeah I think we’ll have it sorted soon. It is possible to install High Sierra from the App store and go back to the working version.

But I’m nervous about doing that even though I do have 2 backups of my system! :-):smiley:


(Pasher Diaguardi) #17

Just updated to 10.13.1 and got hit with the same thing. As soon as the account loads from the Launcher, I get a black and red screen and it hangs. Only option is to force-quit.


(Daniel Tissant) #18

I’m going to try installing Ubuntu Linux on Parallelis and Try and get it run under that - it’s FREE! (woohoo) on the app store.

https://wiki.eveuniversity.org/Installing_EVE_on_Linux

Going to use that - if I can export the virtual machine and it works I will upload it to my blog in the next few hours to at least give us a way to play eve (blog is www.eveblog.space)


(Jenne Wain) #19

That’s actually sounds like a DIFFERENT issue with the Mac client :joy: 10.13.1 has been OK for me on my machines.

I’ve reported that one as well, but I didn’t really get a helpful response other than “Yeah, we’ve seen that happening”. Oddly, it only seems to happen regularly on one of my machines. The theory from CCP is that it is related to your profile, but I have gotten around it by verifying the shared cache settings and restarting the launcher. Unfortunately, I have not found a completely reliable and repeatable way to resolve the “black screen of annoyance” issue, but it can be gotten around.

Sadly, the one we are talking about is pretty much fatal, and I haven’t found a workaround yet.


(Daniel Tissant) #20

Yeah this is getting more and more frustrating

Paralells although I’ve tried windows and linux virtual machines it installs them fine but won’t initialise the network.