Updates To Minimum OS Requirements For Mac Users


(CCP Falcon) #1

As part of ongoing work to keep New Eden up to date, the minimum specifications to play EVE Online are always under review.

This ensures that any changes we make to the EVE Client will perform as expected and that we have a solid understanding of how a release will affect the performance of your hardware.

We’ll be making changes tomorrow that require an update to the minimum system requirements for Mac users. This will mean that our minimum system requirements will change to reflect the following:

  • Formal support of 10.14, 10.13 and 10.12.
  • 10.11 will work, but will not be supported.
  • 10.10 and older will stop working.

This change will come into effect at downtime tomorrow, 2018/09/25.

If you’d like to discuss it, you can do so in this forum thread.


(Aurora Morgan) #2

I don’t think the change is strange in itself and probably quite uncontroversial, but can we get more than 24 hours advance warning next time?


(harvested soul) #3

okok, but the audio setting can work now on iMac?


(Kraxan) #4

Any information as to what this update addresses? Does this solve any of the intermittent crashing problems when jumping?


(Ilin Okoye) #5

Will any information be provided about the specific changed requirements or their purposes? Do they address any particular issues, bugs, etc.?

And I assume the “10.X” items are referring to macOS versions, correct? So these new minimum specs are strictly software related, then? Is this tied to any update or change in wine?

I guess I’m asking: will any additional information be provided?


(Risa Pappotte) #7

Why is it every time you patch for mac it screws up everything for the 99% of the population that doesn’t use crap boxes for gaming.


(Traace Barbek) #8

2x Quad Core | 32GB RAM | HD7950 3GB Mac Pro owner with OSX 10.11 over here.

CCP why do you need to increase minimum supported OS version? Your Client is running via wine, its not even native. You are not bound to xCode minimum OS version…

I just create my own wrapper pack for 10.8 and up!


(Govard Dallocort) #9

Прошу вас не делайте этого. У меня достаточно старый Mac и не хотелось бы покидать и эту игру. Из-за ПО мне пришлось отказаться от WOW


(CCP Explorer) #10

That is correct; Apple sent out the announcement email of macOS Mojave 10.14 tonight and this change in minimum requirements on one hand ties into that expected announcement and on the other hand relates to updates of libraries we are deploying that no longer support 10.10 and older.


(CCP Explorer) #11

Because libraries we use no longer support those older versions.


(Priscilla Williams) #12

So, I don’t get to play anymore? You’re booting me out, just like that? I was just starting to enjoy the game. This is a rotten thing to do.


(Sashimi Isu) #13

Well, what can I say? I started to play this game hardly two months ago and I really liked it. But because I have a Mid 2009 Mac Pro running OSX 10.10.5 (Yosemite), which cannot be updated to the latest OS without a hassle. Also, I use this machine for working, so deciding to update depends on how the mixture of hard- and software I use is supported by newer OSs. 24 hours of warning time is like just pulling the plug. I thought I would have time for the transition until the 64bit client will be relased (Dec '18/Jan '19 ?). And yes, I know it’s not only the client but also WINE related. So, I guess this is it for some time.
o7 and fly safe!


(Claire Ya) #14

updated itself in the evening by itself and all is broke :frowning:
clear screen… 5 10 20 min’s all I see - clear screen of EVE Launcher


  • macOS 10.13.6
  • Clear all caches
  • Clear all CPP data’s
  • Download manually current version client
  • try to turn another settings for english / french / russian languages

    client didnt start at all meet the all requirements macOS station…
    but back one of version … its ok:
  • if dont start Launcher by terminal with “./evelauncher -s” goto first steep

Dev guys, I clearly understand its not your fault, EVE is complex product with many dependent libraries and free libraries. Current time we feel luck, but we need another one issues, I guess…


(Bingham McSnuggles) #15

thanks for kicking me out of the game. you guys know its not that easy to update from yosemite without ■■■■■■■ up half my software installed. especially the 24h in advance notice…are u ■■■■■■■ serious? how about give people 1 week or so? 24h is a joke. well at least i won eve now…bye ccp.


(zluq zabaa) #16

The funny thing is that this is just about the Launcher, not the game itself.

I tested it on an old Hackintosh, version not even mentioned in the Announcement because it’s so old and the game runs like a charm. Just the Launcher can’t be started, because it relays on stuff that relays on libs.

Simple solution: don’t update the Launcher.


(Bingham McSnuggles) #17

too late. ive done that , and now nothing is working anymore…not to mention that my mac is slowed down now by the friggin high sierra OS i never wanted to use in the first place. im slightly pissed to say the least.


(zluq zabaa) #18

there are still old versions of the launcher around. :frowning:


(Bingham McSnuggles) #19

can u specify where please?


(zluq zabaa) #20

http://binaries.eveonline.com/EveLauncher-1225328.dmg

it’s not the last, but the one before that. change the version number to any known and maybe it is still there too.

also you should start the Launcher from a shell, otherwise it will auto-update on start.

so basically something like this

in /Applications/EVE Launcher.app/Contents/MacOS
./evelauncher -s
(the -s stands for --skip-version-check)


(Bingham McSnuggles) #21

i have no idea what you are talking about. what the heck is a shell? :frowning: