"Transparency" does not work without "Enable window blur"

“Transparency” does not work without “Enable window blur”.
Dear developers, isn’t this a bug?