Ubuntu 16.04 EVE process launcher fails "not ready to play"


(KirK Voeller) #1

Hello, first a shout out to CCP Snorlax for providing a pathway for Linux users to play EVO!
Followed this install exactly (not under root nor using sudo). Completed install without errors.

From command line, invoke "./evelauncher.sh"
Below is output of terminal window…

Blockquote
./evelauncher.sh
[0128/141256:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/[redacted]/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/[redacted]/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
[0128/141256:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Blockquote

EVO Launcher appears with no errors, looks exactly like it does under Win10Pro, logs in to my account properly, but when I click “Play” the Launcher shows “not ready to play” error.

I reread posts, and confirmed:

  • Not using a STEAM account (hence ignore STEAM error msgs)

  • Not sure what to make of the Qt error msgs…

  • Using correct version of openssl

Blockquote
[redacted]@[redacted]-XPS-15-9560:~/.eve/wineenv/drive_c$ openssl version
OpenSSL 1.0.2g 1 Mar 2016
Blockquote

  • deleted the following folder, and relaunched the Launcher - no success, same error msg.
    /home/[redacted]/.eve/wineenv/drive_c/tq

At this point open to suggestions.
thanks!


(Zoltan Irvam) #2

I think the qt and steam error messages are normal. Please have a look on my notes for 18.04 - I think the steps used there will be necessary too for 16.04 (32 bit libs if you use a 64 bit system and corefonts).


(KirK Voeller) #3

Hey Zoltan, thanks for the tips. One question. To be more self sufficient, where is the log file located that you used to note the error msgs?
I inspected /home/[redacted]/.local/share/CCP/EVE
but noted log files are not being generated at that path.

Thanks!


(KirK Voeller) #4

So, for all to benefit, I tried Zoltan’s suggestion but for my Ubuntu 16.04 configuration that didn’t resolve the “Not ready to play” issue. Hmm.
Not giving up.


(KirK Voeller) #5

An update.
Ran the ./evelauncher.sh script as sudo
Launcher ran as usual, then a new launcher patch was pushed and installed
Login as normal and…
Success!
EVO runs great on Ubuntu 16.04 through Wine.


(Zoltan Irvam) #6

Good to hear you solved it - I had problems myself sometime last week when trying again the 18.04 recipe on another box. It turned out that the launcher couldn’t get one archive from the CCP servers (it got an HTTP 403 Forbidden) and stopped downloading resulting into the “Not ready to play” meassage - we fixed it by copying over the installation dir from my box but if you don’t already have a running installation that’s not an option.

I don’t think the sudo was the reason (it shouldn’t) - rather some waiting time for CCP to fix the missing archive.


(system) #7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.