UI opacity - have to pin and unpin each login

Basically title. I have my window transparency set to 0 and my chat / people and places windows both unpinned so that the windows are fully opaque. I have trouble reading them against the background otherwise.

Each time I log in, the windows aren’t opaque anymore. I have to manually click pin and then click unpin again, then they stay opaque until the next time I log on. Is there any way I can avoid this?

I know it sounds minor, but it’s starting to really annoy me. If I were to make alts and log them in within any regularity I think it would make me nuts.

Thanks for any help.

1 Like

There’s an option in Esc menu to lock windows when pinned.

When logged into the game, press Esc key to open menu - select ‘General Settings’ tab - select ‘Lock windows when pinned’ in Windows section located in left side column.

1 Like

Thanks for the attempt at help, but you’ve misunderstood. I’m trying to make the window completely opaque (0% transparency). The window being locked in place isn’t important to me and is mutually exclusive (100% opacity seems to require the window to be in unpinned state).

Unpinning the window and setting the transparency slider to 0% works - until logging out and logging in again. Each login, the windows are transparent again. Pinning them and then unpinning them fixes the issue, but is annoying to do each time I log in.

1 Like

OK, guess I’ll have to check that on my settings.

I could have sworn each window that’s locked with pin will keep it’s parameter settings.

Maybe try setting the transparency slider to 1% and then lock it.

Interesting thought, I tried it but no luck. Also found I had that ‘lock window when pinned’ setting on. Can’t really see any material difference in behavior with it enabled or not.

From my admittedly limited reading on the subject, I don’t think it actually does anything anymore aside from preventing you from reordering your tabs. I’d read somewhere in the forums that at one time it’s purpose was to prevent windows from being moved when pinned, but I can move windows whether they’re pinned or not even with it enabled.

Settings for each window are saved and persist for me either way - except when logging in, having to toggle pinned and back to unpinned to get the window opaque again. This behavior really looks like a bug in the UI to me. It wasn’t happening at all, then I think I made a new character while playing around and ever since then it happens about 70% of the time when I log in.

Maybe I’ll try deleting all my settings files and starting from scratch. Thanks again for trying to help, and if you have known working settings for 100% opacity I’m all ears. I play on a big screen TV from my couch and transparency is pretty much a non-starter for reading anything at my age -.-

Well, almost all of the time the pin option works great for me.

I don’t know what else to say except maybe try clear all cache files in Esc menu - reset settings tab.

Also can verify integrity of downloaded files and delete corrupt files in the Launcher - click ‘E’ icon top right of launcher and select ‘Shared Cache’ in drop down menu to verify files.

Solved. For the benefit of future visitors who may stumble across this, the most recent content patch has finally resolved this issue after, I’m told by friends, 18 years of it being an issue. Thank you CCP for addressing this.

Here’s what you need to do for consistent 100% opacity:

  • Esc > General Settings > Window Appearance > Transparency 0 (as usual)
  • Right click the title bar of the window you want opaque and choose “Disable Light Background”
  • If you’re already set to use dark background (I was) it may be necessary to first enable and then disable light background for the window to become opaque.

The window settings in the upper right corner (always above fullscreen, lock window size/position) are now fully independent of opacity and all three settings persist across logins. Thanks to @CCP_Aurora for reminding us of the changes (via Reddit).

2 Likes

After some fiddling with it, I discovered that the new ‘Disable Light Background’ option resets itself the first time you open any tab you haven’t opened before (e.g. Fleet, Private message, etc) that is docked on your chat window. You must manually disable it again once each time this happens.

Once you have done that for each type of tab you’re using, it seems to correctly persist.