Unable to connect to tranquility server port 26000

From Australia, I am unable to connect. Have tried to different internet connections.

1 Like

Same issue East Coast Australia. Getting error connecting to Port 26000’ for past hour. Have tried different ports with no success.

Same for me
Australia east coast
I am using a VPN and its working fine

If it helps narrow down the problem for people. My friend and I are with Telstra and it doesnt work for either or us
so we’ll stick with a VPN until they work it out i suppose

1 Like

Same issue - tried connections via Sydney and Melbourne - all fail. Was connected about an hour ago but been unable to connect again after being disconnected :frowning:

Internet connections via FTTP with Launtel and Future Broadband.

1 Like

Same, thanks for the tip. Using VPN now and back on until they fix it.


Same issue, from Philippines. I don’t know how to connect to different ports.

I fixed the issue by getting a 1 year subscription to Nord VPN. From what I can tell, there’s some sort of fuckery going on with Cloudflare network? Whatever that is. The cloudflare location/node near me had some sort of issue.

Honestly… I’m frustrated. No other game seems to have this issue. I was playing Destiny 2 while waiting for EVE Online to be available again and eventually just ran out of patience and made the Nord VPN purchase. shrug I don’t know what the deal is but… kinda not a good feeling.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.