Wine 4.7 bad mouse handling

Hello. I just upgraded from ubuntu cosmic to disco

doing so moved my wine version from 4.6 to 4.7.

thus I was subject to a bug, that is : when keeping a mouse button clicked, the game believes the mouse has been moved , in many times by a distance corresponding to the distance between the wine window to the top left (0:0) of the screen.

Basically I can’t right click many things, not possible to get my insta undock, not possible to use radial (middle click for me) menu, when moving eg industry window or market window it’s just not possible on my second screen and there is always an offset on the one on my first screen.

I solved it by

  1. adding the dl.winehq repo for cosmic again
  2. apt autoremove --purge wine*
  3. force install winehq and subprojects at version 4.6~cosmic
    sudo apt install wine-staging-amd64=4.6~cosmic wine-staging-i386=4.6~cosmic wine-staging=4.6~cosmic winehq-staging=4.6~cosmic

So if you have the same life-threatening mouse issues, give it a try, don’t endanger yourself !

1 Like

another solution is to use winehq-devel

However it relies on the libfaudio0 which is not available in ubuntu.

That means you need to install a specific ppa for it.But this ppa does not have a correct GPG key (or I did not use it correctly ?)

SO we need to add GPG key, then add ppa, then upgrade(will take time), then remove the winehq-staging and purge it along all the data it brought, then add winehq-devel :

sudo apt-key adv --fetch-keys
sudo add-apt-repository "deb ./"
sudo apt update && sudo apt dist-upgrade
sudo apt autoremove --purge winehq-staging
sudo apt install winehq-devel

Of course if you don’t have the dl.winehq ppa it won’t work :stuck_out_tongue:

sudo apt-key adv --fetch-keys
sudo apt-add-repository "deb $(lsb_release -cs) main"

will fix it (then just rerun install winehq-devel )

I also had trouble with 4.7 on my system, where I build my own wine. The right click menus did not appear, and was unable to interact with anything not in a sub-window. I rolled back to 4.5 here (my last build), and cleared up the problem.

did you build the staging branch ? if yes, can you try the devel branch ?

Yes, I build staging, minus some patches which have been giving me headaches (mostly related to uxtheme). I will wait till Friday when 4.8 should be out before having another go at it, as its a bit of a pain compiling wine for multilib.

Ok so I built 4.8, staging I couldnt even launch eve, so I rebuilt it without the staging patches.
Everything seems to be working normally for now.

exactly the same issue :smiley:

actually I was able to launch, but when I undocked with my freighter in jita, I crashed before jumping perimeter.
There was a wine update but it did not fix the issue (actually just prevented me from starting eve, the launcher was ok but could not launch any account). So I switched to wineHQ-devel and it worked. And my freighter was still alive.

wine staging 4.8 fixed this for me.

1 Like

fixed typo in second post that led to invalid repository.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.