Disk related FPS drops


(Ic3bird) #1

Hello

I have a config
Asus z97-a
Intel i7-4790
2 x 8 GB kingston hyperx RAM
Samsung 850 EVO 128 GB SSD (Windows system)
2 x 500 GB WD Black (RAID0) ()
Gigabyet 1060 WFOC 6 GB
Chieftec 650W
Windows 10 1709 (atm but i tried other builds too).

I experience disk operation related FPS drops (drops to 0 FPS for a second). It occurs only when the game or windows try to read something from the RAID array. The maufacturer replaced the motherboard and the processor but with the new items i experience the same issue. I changed the HDD-s and cables (still RAID0), the power supply, the VGA too it didn’t help. I set graphic settings to minimum it didn’t solve the probelm.
(Yes i tried reinstall windows/game/drivers).
If i install and run the game from SSD it solve the problem, but i don’t want to run the game from system drive.

Please help me to solve this problem. I hope i am not the only who experience this.
Thank you in advance.


(GM Mechanic) #2

Hi, do you have any overlays? If you do try disabling them. If your running Windows 10 , try disabling Game mode and any kind of Video Streaming. Still an issue? Try disabling Windows Aero.


(Ic3bird) #3

Hi

I disabled them in the windows and in the nvidia experience too. I think it is related to disk operations maybe intel rapid storage drive what responsible for raid. When i experience fps drops i see the hdd indicator active (try to read or write something). I tried dx9 dx 11 mode and minimum graphics settings too.

Video here
https://drive.google.com/drive/folders/1SwqEXLx1hIcQB98m9YhxCHp8yNIR8Jbo?usp=sharing


(Ic3bird) #4

New Info.

There are 2 billboards in the hangar. When the billboard changing clip i see fps drop.


(78 Alpha) #5

From what I have seen on my non-RAID HDD, when disk activity is high, like 100%, it will cause FPS drops or low FPS. The same can be said for high amounts of 4k Reads/writes, even if there is still head room (like 40%-20%). There is also the rare occurrence where file are cached to the page-file/swap even if there is enough free RAM, and since there are multiple disks in the system (as with mine) it tries to read/write to the other disk which is slower, even with the page-file/swap on the SSD.

The only suggestion to a solution I have is to minimize disk activity (this includes antivirus software, antimalware, etc).

Since you stated it ran fine from SSD, it is indeed an activity problem, something is demanding the disk and with it’s low 4k random speeds it freezes.

EDIT: The billboards are essentially GIFs that are loaded and unloaded, or video files, still small enough to be an issue for an HDD

[point based analysis, highest is most problematic]

2 Points for 4k read/write performance
2 point for high disk activity
1 point Page-File issues
0 point CPU
-1 point RAM
-2 point GPU

Illustrations

Viewing task manager and taking screenshots also caused FPS drops


(Ic3bird) #6

Hi

my task manager show different values.


FPS drops occur when those spikes appears.

Update: 2 more videos uploaded to share folder.

  1. game full screen mode
  2. fixed window mode and hdsentinel and windows task manager are running.

(78 Alpha) #7

I have been looking at a few forums and have a few solutions lined up, the first is from http://www.tomshardware.com/forum/id-3241102/mysterious-random-100-disk-usage-spikes.html

After watching the videos you made, I saw the FPS drop whenever a video changed or changed scenes, sadly CCP removed the ability to “remove station environment”, so there isn’t much of a fix to this… other than figuring out how to delete or block the videos, but that could get someone banned on account of “tampering with the client”.

After some synthetic analysis, I have found that it is indeed the videos (or how they are loaded). Played at both high and low settings, with resource caching both enabled and disabled in some tests. Something about the video are poorly optimized. It’s likely that they are simply read from disk instead of pre-injected into memory and read from there. I’d suggest making a RAM disk for station assets but that seems a bit hard… in the sense that it means splitting EVE’s resources between multiple places and figuring out how to link them without tampering with any data…

From a blog post, I guess, the details of the videos were:

  • .webm format
  • 1024x576 resolution @ 30fps
  • Maximum length is 15 secs
  • Maximum filesize is 3mb
  • No sound (In space, no one can hear you smacktalk).
  • Don’t add any holographic effects as seen on current billboard ads – We take care of this.

So the system has to randomly read 3 mb (I’ll assume this is actually 3 MB since a 3 mb video would be less than a second at that resolution) of data in an instant, I.E., the spikes that cause lag. At least on HDD systems anyways. An SSD was designed for this kind of sporadic loading and can do it without issue, or at least much issue.

There is no native way in which to turn these videos off at the moment.


(Ic3bird) #8

My friend has an reserve pc.

z170-k motherboard

4x4 GB kingston hyperx predator DDR 4

Intel G4600 Processor

An SSD i dont know the model/brand

2xhitachci HGST 500 GB RAID0

Intel HD graphics 630

Win 10 Prof x64 (1709) up to date

The problem appears with this config too. If i set the Shader quality to low and restart the game!!! there are no movies just THE SCOPE text and the FPS drops disappear.
If i change it to thigh after everything ok until i dock out and the billboards will start playin movies again.


(78 Alpha) #9

Actually, even on low they appear, just in certain stations over others, or citadels (though this may have been due to the fact they were already loaded).

I guess CCP’s implementation of the videos really are bad…

Just as a last analysis, I’ll run it on Linux to check some extra things, and hopefully find a way to block them


(78 Alpha) #10

Okay, didn’t find anything of use, other than it shows up more drastically in Linux. So, it is not a hardware issue, but more of an implementation issue (if it still stutters on an SSD) but if it even takes an SSD to fix the issue then there must be something really wrong with it. At this moment, there is no way to deal with this. You can suggest it in the player features and ideas section but a few have done so already with no real turn over for it (2 or so years later).


(Ic3bird) #11

I made a bugreport from in-game. They have attached it to an actice defect. I hope itt will be fixed soon. Thank you for your time buddy and your kindness.


(Ic3bird) #12

I found a solution.
In Intel Rapid Storage Technology program i changed the cache mode to Read only on the Raid volume. It was off before.


(system) #13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.