Do we have a list of actual ways to install EVE that work today?

The new beta launcher was forced… and it stopped my working steam install… I no longer can play in it. I have a 2nd SSD, so I went with a more current Ubuntu 20.04 (my 120gig SSD is ubuntu 18.04, no longer has updates)… and I read the steam would be easier to do, so I did… and no, it doesnt work. The first try, with Steam’s launcher… it did the install, and I could add the accounts to the launcher (looked like the old one)… but when I tried running one client… it would give the green checkmark and inmediately I get that it didnt work.

Then the launcher updated… and now it doesnt even load… I get a error message related to… “Failed to create OpenGL context from format QSurfaceFormat…”, says something about my graphic drivers not installed… but I dont see how to work that out. I’ve always used the open source AMD driver for the RX480… are we back at having to download a driver as before 16.04?

I have to say… this is getting old. I’m not going to return to Windows… I chose this path away from it and Im happy with it. EVE being so hard to get to work… its getting old. I get it, is the new darn launcher they want to push… I downloaded both the regular evelauncher and the new one from CCP… I tried first the evelauncher with just wine, and even though gave me some error, I ignored some and went into the launcher… downloaded the 3.7ish GB of game data and then I tried to run just one alt… and it did show me the characters to choose.

But I also knew that upon exiting it will attempt to install the new launcher and thus gets me back to non-working status. So, decided to install also the new launcher, in a separate folder… only that it never got to that point of the install. I can see the terminal and it reads something about NTLM… which just found out is a new thing by Microsoft, a suite of protocols to autenticate user’s identity… and it basically stops there, I dont have it (I will try to research it next to see if we can get somewhere past this but Im not that seasoned in the linux arts :slight_smile: I admit it, Im just mediocre, I have to rely on our top guys here to get it to work, and without any of you giving some hints… I have no idea whats going wrong.

It does remind me why I originally decided to stick with ubuntu 18.04… I remember having tried 20.04 and 22.04 and running thru a host of problems, and 18.04 was really easy to setup. But now we have to deal with this new launcher… and 18.04 is out of support.

Lutris dxvk+esync didnt work. I didnt try the Lutris Steam Proton thing.
Steam I tried again, and no joy.
This last attempt was direct with wine, with both launchers. Prior to this I read the old wine-proton thing and lead me to do the amdgpu-install with vulkan=amdvlk and aside something about missing firmware (which I read theres no fix…) and after this is when I started wine evelauncherxxxx.exe and after that tried the new one with this NTLM error (“No NTLM support, expect problems”)…

I downloaded the install, created a prefix dir (mkdir -p $HOME/wineprefixes/eve/ )then executed the install ( WINEPREFIX=$HOME/wineprefixes/eve/ wine $HOME/Downloads/eveinstaller )

Then installed vulkan drivers ( I think) and dxvk from Release Version 2.2 · doitsujin/dxvk · GitHub

Then created a launcher on desktop containing
cat $HOME/Desktop/
cd $HOME/wineprefixes/eve
WINEDEBUG=-all WINEPREFIX=$HOME/wineprefixes/eve/ wine C:\\Eve\eve.exe

and it works fine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.