EVE Launcher doesn't launch, instead rundll32.exe spikes CPU

I can’t tell how long i have been experiencing this issue already, but must somewhere around a week or two.
I have Windows 7 running on my machine and EVE Client installed via Steam app. When doubleclicking the EVE Online desktop icon (or launching it through explorer, or via Steam UI), the launcher doesn’t open, but CPU consumption suddenly increases up to 100% for all 4 cores. It continues endlessly and i cannot launch EVE, as steam thinks that it’s already running. In task manager window i can see process called “rundll32.exe” at the top of CPU load. When looking at the command line column, it gets clear that process originates from EVE client:

I still can run EVE Launcher if kill process called “eve.exe” and run it again, but “rundll32.exe” keeps running and consuming whole laptop processor.

I looked for relevant info in old threads, and here a couple i’ve managed to find:
https://oldforums.eveonline.com/?a=topic&threadID=1221918
https://forums-archive.eveonline.com/topic/108722/

However steps suggested under those topics didn’t help me - i cleared out the cache, completely reinstalled the game, the issue persists. I’m not sure about Firewall, as i don’t use anything specific but Windows Firewall, and EVE Online is marked “allowed” for both public and home networks.

Signed up to EVE and downloaded the client for character creation just to answer this post after finding it through a Google search.

The issue is a decade-old literally game-breaking bug in Windows’ Games Explorer feature that Microsoft haven’t bothered to fix. The long and short of it seems to be that when Microsoft’s services related to this feature go offline, rundll32.dll (invoking gameux.dll) will get stuck in an infinite loop and never actually launch the game. They seem to be experiencing either an extended outage or Microsoft has pulled the plug without bothering to fix their mess.

There’s no good fix for this but you can try this:

Locate gameux.dll in your Windows\SysWOW64 folder and delete it. You’ll likely need to do this outside of Windows, or at least you’ll need to fiddle with permissions a bit.

Alternatively, launch regedit.exe (Start -> type regedit, run as admin) and follow this path:

  • HKEY_LOCAL_MACHINE
    • SOFTWARE
      • Microsoft
        • Windows
          • GameUX

See that GameUX key? Delete everything inside it but not the key itself. Now, do this:

  1. Right click -> Permissions > Advanced
  2. Uncheck “include inheritable permissions from this object’s parent”
  3. Click Apply/OK
  4. Under the list of groups/users, select “SYSTEM”
  5. Uncheck any ‘Allow’ boxes and check all ‘Deny’ boxes
  6. Repeat for “CREATOR OWNER”
  7. Click Apply/OK and exit regedit

With the game associations deleted and no way for it to read/write them back, Games Explorer shouldn’t interfere with game launches anymore.

2 Likes

Woah, man.
I’m extremely lucky that you come across this thread. Yes you were right, it was caused by the Windows Game Explorer. I opted to not remove it completely and followed your second suggestion, EVE works fine now.
I’m wondering though, how it understands that eve should be processed? Probably CCP may remove some signature from the launcher to prevent this from happening.

Yeah, I’m not entirely sure how the detection works. I haven’t had the time to look into it that deeply.

You good Sir are a godsend.

Had the same problem, followed your Instructions and it works fine.Only difference was my GameUX key was in a slightly different location in the Registry.

  • HKEY_LOCAL_MACHINE
    • SOFTWARE
      • Microsoft
        • Windows
          • CurrentVersion
            • GameUX

Thanks for your Post/Help.