Evelauncher.exe - System Error

Hi all, im currently getting an error on my launcher which prevents it from even loading up.
Searching the forum hasn’t been fruitful at all, with no info around. Does anyone know if there is a fix for this? other than copy+pasting the broken file from someones pc :confused:

‘‘The program can’t start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem’’

ive tried to update my ms runtime, but hasnt fixed anything.
tried to restart pc,

other than reinstalling the client ive ran out of ideas (i want the reinstalling to be a last resort) as steam client doesnt work at all.

thank you!!

screenshot of the error:- ss|690x387

Issue Fixed.

Had to download and reinstall MS Visual C++ redist, somehow become corrupt from the newest launcher update? :confused:

I did that reinstall new c++ 2017 and still the same

did you do the correct version, x86 or x64?

yea x64 and first unistall the old ones

i uninstalled the client first too then installed it again, then i tried to do the c++ package.
I never uinstalled the current c++ package i just applied the 2017 update, which i assume just updated it.

No, i tried everything nothing is working

The most useful option is just to scan the whole system immediately, which will scan and attempt to repair any files that are changed or corrupted.

Run this from a “Command Prompt (Admin)”:

sfc /scannow

Worked for me.

This is tied together (0xc000007b) - launcher error
First this DLL missing, then error.

CCP…!

Same issue here.
I am running windows 7.
I have booted another windows 7 machine and i get same issue on it as well.

Can confirm, update breaks on win7.
Managed to isolated now too (my old a#¤ inherrited laptop) with a system restore at the previous launcher version. Installing the missing dll (or by all means, adding e.g firefox dir to the path which also has the dll) leads to a memory write error on the launcher.exe after white window then stop.

Meanwhile is there a way to avoid updating (hate for it to default to automatically update the client after x seconds)…

I have reinstalled eve with and without steam! I reinstalled MS Visual C++ redist mentioned above! I then reinstalled eve with and without steam again! I ran windows chkdsk with and without fix disk permissions! I even ran 3 seperate disk checkers not owned or operated by windows! I reinstalled everything except Windows 7 itself! Despite all this I can’t get EVE to work! My conclusion is EVE won’t work with Windows 7 anymore or the last launcher update needs to be removed from the game!

Please Help Me I Can’t Get EVE To Work!

Found the Problem! It is indeed the launcher trying to install the new Windows 10 ONLY MS Visual C++ redist mentioned above! It breaks the launcher as it wont install on Windows 7! To FIX the problem for Windows 7 users you need to download and install both the x86 version then the x64 version of MS Visual C++ Redistributable for Visual Studio 2015 from this updated link! https://gist.github.com/mmozeiko/de5d9b756bd11b77db8bf4253bed8b3e Then you need to do what Trey-Gowdy said open windows menu type cmd right click run as admin! Then type as he said sfc /scannow and then hit enter! You then need to reboot your pc! Now you need to login manually unchecking the save login option! This will fix the problem for Windows 7 ONLY! Fixes both Steam Version and Non-Steam Version!

See you in-game!

I have the same error 0xc000007b. Launcher would not launch at all. Please fix this I have a 15 bil ISK citadel to defend from idiots and now this. Will file reimbursement tickets if I CANNOT log in the ■■■■■■■ game after your shitty update. Players like me pay you crazy money over the years, sub-based game are supposed to work 24/7. A lot of people play on Win7 and Win8 because EVE is a ■■■■■■■ old game and older people with older PC`s play it. Reinstalled game, c++ all the ■■■■■■■■ - still the same error. What The ■■■■! @@@

This Fix is for WINDOWS 7 ONLY!

Ah I found an easy fix for this one on the smartFTP forums ( Google-Fu me :stuck_out_tongue: )

EDIT: This worked on a Windows 7 sp. 1 freshly reinstalled.

Source and details

For Windows x64 (64-bit)
Visual C++ Redistributable for Visual Studio 2017 (64-bit)
For Windows x86 (32-bit)
Visual C++ Redistributable for Visual Studio 2017 (32-bit)

Worked for me, hopefully it can help someone. Of course, after that I got the white launcher crash so I still can’t EVE. Looking forward the missing fonts bug as well \o/

Hey CCP, that’s a lot of showstoppers in such small launcher, don’t you think ?

This does not cut it for me, scf fails immediately even as admin and the redist can’t be installed properly because of some msu error here :frowning:
Would just be better if CCPlease gets their act together and revert the update and/or hotfix it without the win10 redist debacle and let us know when done. At least then I can restore and get back to business. Meanwhile I’m remoting into my desktop win10 for great success and well doing anything other than combat related stuff…

@ [Selar Delazure]

Didn’t work for me either… What about Windows 8.1 Pro? If I uninstall Visual C++ shouldn’t launcher prompt me or EVE installation? Nothing works for me I guess.

@CikaBrka
Sorry it didn’t help.
I’ll edit my post to add my OS (Windows 7), maybe it doesn’t work on 8 / 10 ?
We really need CCP to communicate about this.

1 Like

They will communicate as usual after few days … so NO WORRIES :–)