[WORKAROUND] Launcher not starting after update

Hello CCP,

I hope this will get your attention, as apparently support tickets just get happily ignored!

Since monday 2018-08-27 (!) my EVE launcher is not starting after it updated itself.

System:
Windows 10
AMD CPU and Graphics

Symptoms:

  • after starting the launcher.exe or eve.exe the explorer window briefly goes to the background and a launcher process appears for 3 seconds
  • the process disappears and no window ever appears
  • no logs are written by the launcher

The update has broken it because the following workaround did nothing to fix the problem:

  • deleting caches
  • setting the QT_OPENGL environmental variable to either “angle” or “software” or “desktop”
  • reinstalling the launcher
  • running the launcher as administrator
  • installing an older launcher version:
    • first time the launcher starts normally (so my system is not to blame!)
    • after cancelling the update the launcher stays open for about a minute
    • after that it crashes and won’t start again
  • and other minor fixes floating around this forum

If you cannot fix the issue ROLL BACK, that means deactivate the (hidden) self update of the launcher until the issues are resolved for EVERYBODY.

If nothing will be done about this I will have to demand a refund.
Compensation for the lost playtime goes without question.

1 Like

After the patch I could not launch the game. I am running Vista and things worked great before the update.
To resolve the issue I had to remove EvE and reinstall using the last launch patch and copy over files to the server I use.
When I launch EvE now the update pops up and I cancel it then log in. If I allow the update to proceed I have to start all over again. lol so yes there is a problem with this patch in my opinion.

Hi Fn -see another post re launcer on this forum. An update of a few days back stopped the launcer making it difficult to fix

Got the same problem like Vash…

Same Symptoms

Nvidia Graphics and Win10 64-bit
I tried several reinstalls of Launcher package clear from Page and with ResFiles
i ended up in refresh windows 10 to get sure it isnt a problem of my system -.-*

Launcher starts in Taskmanager and close after 3 seconds itself.

Ticket was sent yesterday. i am still in hope to get an answer. :slight_smile:

Same Problem here. Also resetting my Password does not work!
The last launcher update was a mistake!

I have had a launcher issue since the Monday 2018-08-27 patch. I submitted a ticket the same day that the issue started. I received 2 responses to the ticket asking for log files and a windows event report. I provided this information, but have not received any further communication.

I have tried all the workarounds listed here, still no solution for me…

Out of interest, what are your system specs?

windows 7, intel i5 and an Radeon R7 graphics card. It is not the newest system, but has been able to run EVE without problems until the patch last Monday.

have had launcher troubles sine update tried all sugested fixes but no luck
I am suspending my Omega accounts till it is fixed hope everyone does as well then lets see how quick they fix it with no income form omega accounts

Same issue for me >4 days now. No response on support ticket, tried 4 different launcher versions.

System: Win10 (completely updated), GeForce GTX 1070 (Updated Drivers), i7-7820HK

Old laptop also running Win10 with same Antivirus setup runs with no problem.

Installed the Update for Universal C Runtime, tried the OPEN_GL variable.

CCPlease let us know what to do.

So I found a workaround that works for me.
I’m sharing it in the hope that it helps some people:
(the first steps might not be necessary, but I did it that way to be sure)

  • uninstall every instance of eve online
  • remove all ccp registries (for some reason they sometimes stay?):
    • type ‘regedit’ in any windows search bar
    • navigate to HKEY_CURRENT_USER\SOFTWARE
    • right click CCP -> delete
      (now the important bits)
  • download some version of the old launcher (https://binaries.eveonline.com/EveLauncher-1225328.exe)
  • install it
  • IMPORTANT:
    • when you first start the launcher it will want to update itself
    • LET it download the new binary
    • afterwards there appears a dialog with a 30s timer asking to do the actual update
    • click cancel

This dialog will appear every time you start the launcher and every time you need to click cancel to prevent the launcher from breaking its own legs.
Yes your options and accounts will be reset, but at least you can play the game again.

Now @CCP

This is me doing YOUR work here, finding workarounds and communicating it to people.
This is a temporary workaround, the issue is NOT resolved and it will not be, until the launcher wil not start working 100%!
My demands for compensation still stand.

4 Likes

For me he want to update directly to new version that not work…

grafik

but thats new now… missing zlib1.dll

tried again,

seems working… fingerscrossed

Thank you Vash DeStamp

So I did everything, now when I type my account name and password, the logging box closes itself and reappear as if I typed Nothing…. WTF, it has been 2 weeks now!

Do you have errors in Windows Event Viewer? The exception code from possible evelauncher.exe Application Error might give us some hints.

I am having the same problem, I am getting really annoyed.

the event viewer really shows NO info only that there was an application Error

Log Name: Application
Source: Application Error
Date: 9/4/2018 5:59:12 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: JoshA
Description:
Faulting application name: evelauncher.exe, version: 5.0.137.6132, time stamp: 0x5b8832f1
Faulting module name: evelauncher.exe, version: 5.0.137.6132, time stamp: 0x5b8832f1
Exception code: 0xc0000005
Fault offset: 0x0006793b
Faulting process id: 0x2ee4
Faulting application start time: 0x01d44435ee5eaf35
Faulting application path: D:\EVE\Launcher\evelauncher.exe
Faulting module path: D:\EVE\Launcher\evelauncher.exe
Report Id: 2c11a94b-b029-11e8-8354-5c93a2956636
Faulting package full name:
Faulting package-relative application ID:

Having the same exact problem as the OP, my ticket is open now for a week, and no reply after the initial question for dxtool logs from CCP socket closed, I have 4 accounts plexed to Omega status, and it just baffles me how little do CCP care about their customers.

New launcher update was deployed to day that should hopefully resolve most of the issues in this thread. If the launcher does not self update then I suggest you reinstall it.

For login issue with authentication key, there is a possible fix on the beta version we are working on. Try changing your launcher version to beta.

  • Start the launcher
  • Click on the EVE icon in the top right corner of the launcher.
  • Select Settings from the drop down list.
  • Change version type from Release to Beta.
  • Click on OK.
  • Exit the launcher.
  • Press and hold the Windows key on your keyboard while pressing R
  • Copy and paste the following into the text box and press Enter: %LocalAppData%\CCP\EVE\
  • Right click on the folder cache and select delete.
  • Close the File Explorer and restart the launcher and you should be all set.
2 Likes

Thanks for the reply @GM_Mechanic but unfortunatelly it did not fix the non responsive launcher issue for me.
Directly after the update the launcher threw some popups of missing .dll files like zlib1.dll, so i did a wipe and reinstall a fresh launcher installation from the site, and we are back to square one. Process starts and then dies after a few seconds, doesnt even produce a launcher log.

Log viewer :

Faulting application name: evelauncher.exe, version: 5.0.137.6509, time stamp: 0x5b892acb
Faulting module name: evelauncher.exe, version: 5.0.137.6509, time stamp: 0x5b892acb
Exception code: 0xc0000005
Fault offset: 0x00066498
Faulting process ID: 0x1854
Faulting application start time: 0x01d444a77e79bb20
Faulting application path: C:\GRY\EVE\Launcher\evelauncher.exe
Faulting module path: C:\GRY\EVE\Launcher\evelauncher.exe
Report ID: c74e6d72-e9ef-4542-9ecb-9fc401dfb2f8
Faulting package full name:
Faulting package-relative application ID:

I have already ran the latest version of Eve launcher. now he is downloading resources. I ran it windows 7 x32bit personal computer. removed the antivirus 1 created virtual memory on disk d 2 in the local server enabled all services in auto mode 3 downloaded all Microsoft Visual Studio 4 deleted the game and downloaded again 5 updated and downloaded libraries 6 and the beginning is fine as before the system crashes. :wink: you all ccp made me dig into internet systems… this violence1,<<< this is a joke :wink: and I do not even know English I use Google Translate. if such an ignorant how could I come in. will be able to go all !!! I wish you all the best of luck…