EveOProfileTool - Managing your EVE profiles without becoming depressed

Hello fellow nerds!

As one does, I recently reinstalled my pc… and then proceeded to buy a new one. As we all know, setting up your client to your liking is a pain in the posterior, especially when you have several accounts. Krypted Gaming already offered us a trick to spread one profile to several characters, but with 3 characters per account, that can still be a ■■■■■. Besides, having to copy and rename a bunch of files is annoying as hell. (And imagine if you forgot a few settings and you have to do it all over again.) I say: no more. I just reinstalled my pc and did not feel like going through it again, so I made a quick tool to do it for me. Setting up my dozens of accounts now became very simple; I just made one template profile and instantly copied it to everything else. More detailed instructions are included, of course.

I know I’m not the only one annoyed by this, so I’m sharing it with you fine people! Download available here. It’s all very safe, as it only moves your old files and copies some new ones in, but just in case anyone is worried, I have uploaded the source as well.

Hi ItsmeHcK1

I tried using the app, it keeps telling me to download and install “.NET Desktop Runtime 6.03 (x64)”

I’ve done this, still popping up the same message. I even installed the latest version that is 6.04, didn’t work either.

I even went as far as installing the SDK, still can’t get it to work :frowning:

Below is the link I used to get the runtime from

You can also publish self-contained applications for easier deploying, see here Application publishing - .NET | Microsoft Docs and Single file application - .NET | Microsoft Docs

Also your site is not using TLS so many browsers are prioritising TLS site connections and warning/blocking non-TLS.

Have you added DOTNET_ROOT to your PATH environment variable? See .NET environment variables - .NET CLI | Microsoft Docs though this is usually only required for manual installs (notably on Linux).

oh man, this seems like too much effort.

I did not setup ENV Variables, didn’t think I had to go that far. (Even though I know for sure I have to do that for Java most of the time.)

I’m not that clued up with .NET stuff. I don’t really wanna mess around with it.

I might try what you suggested about setting up the PATH later, right now though, I used the Java app, its old, but still seems to work, I think.

If you’re using the Windows installer it should set it up for you I think. I’m using manual install on Linux so I set it up myself.

Yeah, used the windows installers.

Command line test with

dotnet --info

See dotnet command - .NET CLI | Microsoft Docs since you installed the SDK.

Hmm, that’s really odd. I tried it on my laptop, which worked fine. I’ll be honest: it has been a while since I did any proper development. Not sure what changed since, and I’m too old for that ■■■■ now. I’ll see if I can make one without the dependencies.

(edit)
Self-contained file available at the original location. It’s quite a bit larger, but I guess it’ll be worth it if it works!