Evesetup - How to install and run EVE using the Linux Launcher [deprecated]

For some years i have start to write this setup script package because i was to lazy to install EVE Online the UniWiki way which is ofc a possibility to install EVE but handels only the launcher itself without some supporting tasks (like creating desktop launcher and so on). Other reasons for this project are

  • Download the actual version of the linux launcher and the DXVK package during installation

  • Setup the launcher itself following FHS compliance (so far as possible)

  • Perform additional tasks (create desktop launcher for launcher, backup, usefull wine utilities for EVE)

  • Create a environment to run EVE Online using external WINE

  • Integrate DXVK into this environment without user interaction

  • Import game data (Shared Cache files) from other installations, if they exists (Linux Only)

Prerequisites for using evesetup (some of these will be checked by installation) are

  • A decent linux installation, using 64bit architecture

  • Driver for graphics hardware with vulkan support

  • Installed Wine with 64bit support

  • 7z for backup and restore utility

  • Curl or wget download utility

On ARCH based distributions just install the package with an AUR helper or build the package with makepkg in the extracted source directory which can be downloaded from AUR

All other distributions like DEBIAN or REDHAT based ones can use the sources from AUR too after building an installer from these with following commands

Download and extract the sources

curl -O https://aur.archlinux.org/cgit/aur.git/snapshot/evesetup.tar.gz 
tar xvf evesetup.tar.gz
cd evesetup

If you have downloaded evelauncher and dxvk before just copy these archives in the evesetup folder to integrate them into the setup package (optional)

Build the selfextracting setup package with the integrated QT-Runtime using makeself with

./build_installer.sh

If you want to use the QT-Runtime installed by your distribution make sure, she are version 5.12 or newer with

./build_lite_installer.sh

In this case will the build script download all needed archives (launcher and dxvk) to strip not necessary files from the setup package

Based on what setup package you have build before use one of the following commands to install evesetup

sudo ./evesetup-<LAUNCHER_VERSION>-X-x86_64.run
sudo ./evesetup-lite-<LAUNCHER_VERSION>-X-x86_64.run

During the setup process the setup will test and warn about missing dependencies which must be installed before running the setup again.

For uninstall evesetup just run the setup package again to remove it from your system (except user settings which can removed with

rm -rf $HOME/.cache/CCP
rm -rf $HOME/.config/CCP
rm -rf $HOME/.local/share/CCP
rm -rf $HOME/.local/lib/EVE

I hope, this package will be usefull to some one.

– fly safe o7

3 Likes

@Gharim_Turen

Currently your evesetup package is crashing right after CCP logo but before Luancher window.

Do you happen to know why? Please see console output

Settings path:  "/home/xxx/.config/CCP/EVE.conf"
Language selected based on stored settings:  "en"
QObject::startTimer: Timers can only be used with threads started with QThread
[491417:491435:0427/180253.754011:ERROR:broker_posix.cc(40)] Recvmsg error: Connection reset by peer (104)
/home/xxx/.local/lib/EVE/Launcher/evelauncher.sh: line 25: 491375 Aborted                 (core dumped) "$dirname/$appname" "$@"
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]

I doubt that my package are the reason for the crash on your installation. Have it just tried on a live system of Fedora 34 (only the launcher itself without eve client). All flavours of the package works after i have installed the necessary dependencies with dnf.

Your error looks for me, that are something wrong with your secure connections to the ccp servers. Maybe the installed openssl libs have changed on your system but its only a guess.

The feedback from the kill command happens only, when kill has nothing to do, because evelauncher is crashed before, so it shows only his usage.

Another day, another update. :slight_smile: Based on a solution which i have found in the MangoHud project where she handels missing dependencies for different distributions, i have this function adapted for the needs of evelauncher. The ‘Arch | Manjaro’ tree are only there for testing purposes but works too, if you want to use the installer instead the AUR package on Arch compatible distributions.

For build and using the package look at the first post in this thread, there has nothing changed except that the lite package try to install all needed packages using the distribution based package manager.

Following distributions have i tested with the new lite installer

  • Manjaro Linux 21.0.4

  • Fedora 34

  • Ubuntu 20.4 LTS

  • Linux Mint 20.1

  • Pop!_OS 20.4 LTS

  • KDE Neon

  • openSUSE Tumbleweed

On Ubuntu based distributions made sure that you have the universe repo enabled before you use the installler (most needed packages are in this repo).

Debian should work too but only testing and unstable versions, so i have skip it at this time.

Older distributions should use the full installer because the qt-runtime are the same or newer than the version delivered by this distributions.

– fly safe o7

2 Likes

Cool that somebody is writing an EVE install script for Linux manually :slight_smile:

I personally use Lutris to run Windows games in Linux

You can add on to the existing EVE installer there with suggestions I guess, if stuff stops working there too :wink: (its working at the moment)

Based on a post from @CCP_Bartender and @CCP_Cemetery in this Thread New launcher… new Linux error? where both have made clear, that sooner or later the linux launcher will not be functional anymore, is this (probably) my last update for the Evesetup package.

– fly safe o7

I am not that pessimistic @Gharim_Turen, as we had a similar issue like a few month ago and WINE fixed it for us.

At the moment someone created a WINE ticket for this:
https://bugs.winehq.org/show_bug.cgi?id=51465

My hope is that, if we and especially those more development experienced provide proper information into this ticket, WINE will get us a fix before CCP run’s into the necessity to disable backward-compatibility with the old launcher.

I know this is not the silver bullet, but Linux is still not officially supported so at least it gives some hope and hope dies last, right :wink:

wait, that was literally the fix in Wine? source.winehq.org Git - wine.git/commitdiff

This commit on WineHQ are only for the windows-based launcher of EVE, the linux-based launcher version from EVE are not affected by this bug, which prevent the login and so the start of the game client.

– fly safe