Framerate lag spikes


(elitatwo) #21

That is really weird and I heard some people complaining about it in the M-O local channel on SiSi too last weekend.

I myself did have some weird lag but it was short while I was docked and I think more related to the 6000 trillion keepstars in that system.

This happens to me after many hours when I am on SiSi and doing docking and undocking procedures a lot.

However, my AMD Radeon does work fine on Linux Mint 19 (Ubuntu 18.4 LTS) and Vulkan™ for many hours. At least 7 hours must have passed before it happens.


(Damassys Kadesh) #22

@Ravvzor I just did a “clean install” of the new nVidia driver (released yesterday) and my initial testing looks good so far… I’m not going to say it’s fixed until I’ve had a few fully smooth play-sessions (since the issue came and went in the past). Can you try the new driver and let me know what happens? It would make me more confident if I heard that it fixed your problem too. Do you have a 1080? or a 10-series nVidia card?


(Ravvzor) #23

@Damassys_Kadesh
Sorry for taking time.
I’m on a 1060 and when doing the update to version: 417.01, it’s not working like before.
I see no lag during combat anylonger.

You seen any more lag spikes?


(Damassys Kadesh) #24

@Ravvzor @GM_Mechanic I finally had some time to log in and try some PvP, but despite my initially good results with the 417.01 driver (as stated in my previous post) I’m sad to report that the stuttering has not been resolved… which now proves that it’s somewhat intermittent. Here is a clip from tonight when I attempted to PvP… I’d like to think I would have gotten the kill if I wasn’t distracted by the hiccups :frowning:


(Damassys Kadesh) #25

@Ravvzor What’s your status? Is your issue fixed? Because mine is not and I just received an in-game mail from someone telling me that they saw my forum post and have the exact same problem… here is a screenshot:

Capture2

@GM_Mechanic I’m about to send you another follow-up to my support ticket and include the character’s name in case you want to reach out to them for more info… I asked them for their system specs to see if there is anything in common with mine… I’ll also mention that I just updated to the newest nVidia driver today. So that makes 3 driver versions with no change to my problem (including a “clean install”) so I’m doubtful it’s a driver problem.

My specs:
i7 6700
GTX 1080
16GB DDR4 2400MHz (2x8GB)
250GB M.2 SSD (Samsung 970 EVO) [EVE installed here]
Fatal1ty Z170 Gaming-ITX/ac (motherboard)


(Endrin Barukh) #26

Hello everybody!

I am the person from the above post and ingame email. It is probably better I write here as well.

I am experiencing exactly the same issue as Damassys recorded in his video. The graphical stuttering happens only in combat (NPC or player). Stutter is the best description I have. The game continuously micropauses and then catches up / speeds up. I have a decent laptop with Nvidia 1060M and lowering graphics / sounds brings no difference. I have a feeling it somehow links to dmg calculations, or something else under the hood, not the graphical output. I am willing to provide more info if you need. :slight_smile:

Endrin

edit: i5-7300HQ, Nvidia 1060M with 398.36 drivers, 120GB SSD - Lenovo Legion Y720 laptop connected to external monitor


(Damassys Kadesh) #27

@Endrin_Barukh Thanks for sharing! I’m really hoping more samples of this can help find a solution. Maybe it will turn out to be something really silly, but everything seems to point to the source being inside the client, since it only occurs during a particular process that the client runs (calculating/sending/receiving damage/combat information).
At the suggestion of @GM_Mechanic in my support ticket, I have just submitted an in-game bug-report, and referenced this forum thread as the best source of detailed description of the issue, as well as video. Speaking of video, here is the footage captured right before I submitted the bug-report: https://youtu.be/KgCjJMglRL4
I also had my task-manager open during this session and saw nothing unusual (was checking for memory problems as the suggestion of @GM_Mechanic):


(Damassys Kadesh) #28

@GM_Mechanic Alright… I have very interesting new information. @Endrin_Barukh and @Ravvzor can you watch this and tell me if you can reproduce the same behaviour?


Note: I cleared my game cache and mail cache already during troubleshooting.

(Anderson Geten) #29

I tested and spamming xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx in the jita local from the station ended up in the same effect.

However this happened while my chat box was very small, so maybe not linked to rendering the text (I guess however than parsing it to check hypertext may be the issue)


(Endrin Barukh) #30

@Damassys_Kadesh @Anderson_Geten @GM_Mechanic Alright, I had some time to test the email system. I can confirm everything you mentioned in the video.

  • My game went to a massive stutter when I tried to reply to the email with already lots of text.
  • New fresh email started to stutter a bit around 250 characters, and noticeably more around 800 mark.

Here is my CPU usage graph I had running during the replying to the email:

I had a key pressed down and stuttered during the beginning and the end phase on the graph. The middle part of the graph is just idling in the station with no actions. You can clearly see quite a big increase in CPU usage, only due to the writing text in game! Also notice the GPU usage on the left panel. The beginning and end parts have these weird spikes in usage, and they correlate somehow with the CPU usage.

My suspicion is the same, that it is the actual combat text (damage, who, corp…) that stutters the client. I have a bigger stutter when I fight 5 enemies, compared to 1. The amount of dmg text generated is much higher.

I will try to make some field test again when I have some time this week.


(Marie Kaster) #31

I’ve also noticed this issue, but mainly whenever i was trying to move the camera around my ship. Running a GTX1070TI. I think it has to be something to do with the drivers and the client because I only noticed it starting after the client updated a few files. It was a smaller patch for me, like less than 60MB, but after that I was getting hit with all kinds of lag issues, and still am. Before this problem cropped up I could run 3 clients simultaneously with very few issues (there’d be a small framerate drop on background clients, but that would clear as soon as I went into that window). Now all 3 are showing this framerate bug.

EDIT: So I have my ship docked in station right now, currently running 2 clients, 1 per monitor, and when I just moused over one of my windows I saw massive framerate lag spikes. The faster I moved the mouse, the harder the spike.


(GM Mechanic) #32

Thank you guys for submitting all the information. And thank you for the video. Very interesting information.


(CCP karkur) #34

If you can reproduce this, it would be great if you could file a bugreport on it, from within the client (from F12 window). What window was this?

Some of you have been describing issue with the mail. While that is an issue (and has been fixed internally), it most likely has nothing to do with the other spikes you guys are experiencing. The mail lag has to do with the character counter (that’s at least by far the biggest factor), and you should not be running into that unless you are typing in one of those fields. That being said, I’m not ruling out that something might be wrong with the damage text, but probably something different from the mail issue.

If you guys can easily repro this, could you try to turn off the combat message ( E > Accessories > Logs and message and click on “combat settings” and try to toggle off the combat message) and check if makes a difference?
Another thing to try is to try to repro while in potato mode. Depending on the results of those tests, hopefully we can narrow down what is causing your issues.

Some in the thread have suggested that it’s related to visiting many systems, is that the case for everyone or can you repro without changing systems at all?
(when undocking, there might be some slight pauses when you are loading the space, so it’s probably best to not count that with).


(Damassys Kadesh) #35

@Endrin_Barukh @Ravvzor @Anderson_Geten I was able to eliminate my in-combat issue by disabling all combat notifications. I have a lengthy testing video here, but if you watch shortly before the 8min mark, you’ll see definitive absence and presence of the issue depending on the notifications being on or off. Can you test and report your own findings?
@CCP_karkur visiting many systems has not been a factor for me. All of my videos were produced in the system to which I logged in.
I did not test anything in potato mode, but can if needed.


(Endrin Barukh) #36

@Damassys_Kadesh @CCP_karkur @GM_Mechanic I can 100% reproduce and confirm what Damassys found out in the video. Disabling combat notifications in Log & Messages removes the issue and stuttering completely.


(CCP karkur) #37

@Damassys_Kadesh and I figured out that his problem (and then yours too) has to do with logging of the damage messages to the file in the Gamelogs folder. I’ll talk with my co-workers after the weekend to figure out if they know what’s up with that.


(Endrin Barukh) #38

Great! Damassys contacted me ingame and asked few questions, so I am going to repost my reply here as well with few more details.

I am using Windows 10 and my laptop has 1x SSD and 1x HDD disks. I am using only SSD - model NVMe SAMSUNG MZVLW256. I was also asked whether I have Intel Rapid Storage Technology installed. I really can’t find it. It doesn’t show up in the app panel, but I found few mentions in the regedit. I had it on my previous device, but can’t recall if I ever installed it on the current laptop. It was also recommended to me to go to logs/CombatLogs/ and do some security tweaks to bypass the logging. I don’t have such a folder there… I only have ChatLogs, FleetLogs, GameLogs, MarketLogs. Hope this helps, and thanks for the work! o7


(Damassys Kadesh) #39

@Endrin_Barukh Sorry I wrote “Combatlogs” by mistake! It’s “Gamelogs” as @CCP_karkur said.
It also looks like we both have M.2 Samsung NVMe SSDs, of the same capacity (but not the exact same model)… both SHOULD be fast, mine is fairly new (but proven over many months without any issues) but maybe there is some rare conflict with the way that the EVE client is writing to the log file… I will look into Samsung’s driver/controller and see if there is an update.


(Endrin Barukh) #40

Current workaround is to deny all security access to the logs/gamelogs folder. As @Damassys_Kadesh suggested to me, the game will stop to log into the file and all combat notifications will NOT stutter the game anymore.