Full Screen on Second Monitor

Greetings,

Trying to run Eve on my secondary Monitor in fullscreen. In windowed mode it stays there, but when I click Fullscreen it pops back to my main monitor. (Im already playing another game there)

Basically while waiting for the Clan to get their act together in Destiny 2 on the main monitor, I run Distribution missions. Fuillscreen works a lot better.

Tried everything, is there a setting I am missing in game (or in Windows 10)?

Thanks!

Q-Ball

Try mode “fixed window”.

I did, same result. It returns to the main monitor. Only Windowed stays on the secondary monitor. Easiest solution is to move Destiny to the smaller monitor and just play Eve :smile:

Or swap monitors. Declare Monitor2 as main monitor.

1 Like

Not sure if this is the best way, but the way I got a client to display on my secondary monitor is to fiddle with the adapter settings.

For some reason picking my Intel Graphics rather than my main graphics card puts the client on my second monitor. I made a second client profile in the launcher for when I want to play on my second monitor (attached to the account I occasionally multibox with) while my main account shows on my main monitor. The only downside is that I’m playing in potato mode on my second monitor due to the lack of a decent graphics card, but it works.

1 Like

You can specify which monitor the client is locked to via the graphics settings. Just choose the appropriate adaptor. There should be a listing for each of your displays.

I would also suggest using ‘Fixed Window’ anyway, else you’ll run into other problems like applications on your other monitor taking precedence and minimizing Eve on the other monitor when clicked (Maybe that’s just a me thing - but Fixed window solved that)