Gaming bug?

Hi guys

I am doing the agent mission and trying to complete the mission. I have the thing needed for the complete mission and I just can’t complete it.

Do I need to repackage it or buy this one from the market instead of getting it from space?

or it just a little bug.


Try putting it into the station item box. If it’s already there, try putting it in your cargo hold.

Thanks but I tryied this already, even tried to active another ship to compelet it but nothing make it work

The only other obvious possibility, is that it’s the wrong item…relic? I dunno…I would file a ticket.

1 Like

Are you in the right station? Even in the same system, if you are in the wrong station, it wont work.

1 Like

Right click on the proof of discovery in your item hangar and show info so you can see the full name of the one you have. I am betting it is the wrong proof of discovery. There are three or four different ones.


It’s not a “bug” - the career missions work. If you actually scanned down the data site, warped to it and hacked the can to get the proof of discovery it should work. You can try clearing your cache in case something is stuck there, if that doesn’t work, submit a help ticket asking the GM’s to reset the mission for you.

If you got the proof of discovery by any other means the mission objectives are not complete.


Haha i found that i got the wrong proof lol, thanks!

Thanks, problem solved :smile: )

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.