Getting BSOD

Was there an update to the game client today? This morning everything worked fine, but after Downtime my client crashes constantly to BSOD with various GPU related errors (VIDEO_TDR_FAILURE, KERNEL_MODE_HEAP_CORRUPTION, SYSTEM_SERVICE_EXCEPTION). In the time that it runs, usually a minute or so before it crashes, the client seems to be using more memory than before. I’ve updated my video drivers (Nvidia GeForce GTX 1050) but no change. I have yet to test another game to eliminate hardware failure, but running fullHD video works perfectly. Am I the only one?

Any chance you were running DX9 before?

On 30 November, we will be moving all existing players to DirectX 11 if it is supported by the GPU.

This change may have caused a conflict if your GPU doesn’t properly handle DX11 (or you have special settings configured for your GPU, like a game profile, that conflict with the change from DX9 to DX11 and need to be reset). You can still revert it manually for now, but long-term DX9 is going poof in January.

Full article: Improving the Foundation

Good question, I forgot about that change (and it answers the question whether there was a change at least, I guess). I’ll check that out tomorrow. My system is 3,5 years old so I doubt it, but who knows.

in linux after today u[date i’ve got crash when i see myself

Ubuntu 20.04
lenovo ideapad 310-15ISK
core i3-6006
12gb ddr4 so-dimm
linux steam client, proton 5.10, ingame shows on minimal settings 25fps space, up to 45 in hangar, “dx11, intelHD-520, SM_3_0_LO”

Ok, the issue seems to have been resolved, no crashes so far today. What I did:

  • Ran another game with the highest video settings; no crashes

  • Checked if DX9 was ticked like Mkikaden Tiragen mentioned; it wasn’t

  • Did a Verify of the Shared Cache; no corrupt files found

  • Went back to the Launcher settings and noticed that Enable hardware rendering and Enable high DPI scaling were ticked off. I ticked those to on and tried again. Now I don’t have crashes.

I can’t say if these setting were like that before but I doubt it. CCP, could they have been mistakenly turned off when you forced the DX11 setting to clients yesterday?

Suggest driver issues. Uninstall drivers using DDU in safe mode then reinstall it from nvidia website

Other than that. I suggest downloading some benchmark and stres test hardware. Memory leak can also be caused by issues with driver. Either ram leak or graphic car memory. Since you didn’t specify what you meant.

My enthusiasm was premature. Turned out Windows had disabled my Nvidia card because of the crashes, so EVE switched to the Intel graphics card (it’s a Lenovo Legion laptop).

I tried what you said before I read your post; completely removed all Nvidia drivers, in Safe Mode, made sure they were gone with DDU and rebooted. Device manager indicated no other graphics adapter than Intel, and an unrecognized device. Installed the latest Nvidia driver, again.

But no success, the crashes keep happening. It may just be a hardware failure, but I only have it when running EVE. I’ll try a stress test like you mentioned.

The CCP devs stated that there is some problems with Eve running on certain Intel GPU’s after the v19.09 update a couple of months back. I’m just mentioning it to give you more information. I don’t know how to overcome it and there has been no further word/details from the devs about it. Not sure if your problem is related, or not, because you have a Nvidia GPU along with the Intel one. But I hope it gets solved for you soon.

1 Like

Oh, it’s a laptop! I thought it’s PC. Did you tried installing drivers from your laptop producer website?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.