Insane CPU usage

I have 2 machines both with dual boot windows and linux (Ubuntu/Slackware). For a while now on both linux machines each eve client uses about 30-40% of CPU which only decreases when I minimize or close the client (whether I’m docked or not makes no difference). I’ve tried running custom wine and various wine dev versions but it seems to make no difference. Is this the new normal or is it just me? If its just me at least I can try to fix it. Needless to say on windows the cpu usage is a fraction of that.


ps. Both are amd fx-6200 cpus with 16 gigs of ramScreenshot_19081212

I see the same. There was a time when running 3 clients wouldn’t stretch the machine, but nowadays 2 is all it can manage. (Linux Mint 17.3)

What wine setup did you try? The FX-6200 is a quite low end 3 cores CPU by current standard.

If you have an AMD video card, I recommend you to use open source drivers with Gallium nine and the corresponding patch on Wine (I think you can wine tricks that now). That will add a native version of DX9 to your drivers and the Wine patch will allow it to use that Native DX9 instead of doing the normal wine d3d9 to OpenGL transcoding.

That would help a lot to get more FPS or less CPU usage.

The other solution if you are using DX11 or and don’t want to switch to Native DX9, is to use DXVK. Converting D3D11 to Vulkan seam to use less resources than using the normal Wine D3D11 -> OpenGL path. Again, Will provide more FPS or less CPU usage.

I think Gallium nine is the most efficient setup.

I’m not sure how your system activity app works, but with the top command, sometimes you will see values like this:

This makes it appear as if each instance of winemenubuilder is using 100% of my cpu.

If I press the I key, however, and toggle solaris mode in top, you can see that the program is actually using 100% of a single cpu, not all four.

I think it’s possible that these eve clients are using 30% of a single cpu core, not 30% total. If this is true, the two eve clients are using 15% cpu as opposed to an apparent 60% in the system activity app which possibly works just like the top command.

Try running these two eve clients, open the terminal and run “top”, then press the I key on your keyboard. This will show you whether this is true or not. If so, your PC can probably run 10 eve clients at once since you are only at 15% with two clients , about 7.5% cpu usage per client. Of course, that is not considering anything like big fleet fights where the numbers probably change drastically.

Yes top is per core.
You can see a multithreaded application eat up 350% or 450% of your cpu. This means it is keeping 3.5 or 4.5 cores busy.
If you have a modest 8 core cpu with 2 threads each, your top may indicate a total of 1600% cpu usage.

I think it was mentioned that some of the high CPU % was related to Spectre/Meltdown. I myself used to run 4 clients for mining (at around 20fps each, so not perfect, but would work), or 3 running easily in active combat sites, but ever since at some point (that coincided with the ‘enforcing’ of the 64bit release, if memory serves well) my machine barely can handle 2 clients. GPU usage % its surprisingly low, and also VRAM use… its very low.

But, recently, a client of mine that is using the same hardware I use (same mobo, same apu, different ram) gave me the computer to check, and decided to run memtest on both, and it was surprising to see that the CPU section of the test, showed that her computer’s numbers on L1 and L2 cache were double than mine, and that got me thinking that maybe that Spectre/Meltdown patch reduced my system performance (and didnt on hers because she’s using Windows XP so I guess that microcode patch is not available there? I can only guess).

But this could explain why I could run barely 4 clients before and now barely 2.

(Memtest also showed my ram was at fault, so untill new memory arrives (hopefully the coronavirus doesnt affect much mail delivery) I can’t run any more tests on my PC.

If you are using wine staging, uncheck CSM in winecfg.

This has definitely something to do with the 64 bit client. I used the 32 bit client until they forced us to use 64 bit and as soon as I started using 64 bit the performance dropped significantly.

Previously I could run up to 13 clients with 3 of them on max graphics in 32 bit mode while battery hitting 20% CPU usage. Now in 64 bit mode my computer with no hardware changes CPU is completely maxed out with 4 clients on lowest graphic settings. I can only run a single client on max settings (and no other clients at the same time no matter the settings) or the frame rate is unplayable.

If I minimize a client it’s CPU usage drops to almost nothing so if I need more than one open at a time now I try to keep them minimized. Doesn’t work in practice as you kind of need to see your characters to use them. Likely this will burn out my CPU eventually.

I saw much the same when 64-bit arrived, on my (fairly ancient) Linux system. I used to be able to run 4 clients with ease, now I can only have 2 active on my dual monitors with, depending on which way the wind is blowing, a 3rd one minimised to the task-bar. The cause in my case is very definitely the memory utilisation - using the System Monitor I can actually see it going into virtual-memory thrashing, and FPS drops from 50 to less than 3. I do wonder if some generic tool was used to produce the 64-bit version from the 32-bit, and memory utilisation was not one of its optimisations.

is anyone else having trouble with the launcher not launching the client im using ubuntu 18 and wine and its worked fine for so long and since this new patch it wont open the client ???

In my case I have 64 gigs of ram so the memory use of EVE doesn’t even scratch that total. The CPU use is still insane though compared to the 32 bit version.

Looks like I hit the VM issue just before the CPU issue would show, from this :

That’s with 3 Eve clients running, 2 minimised and 1 active.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.