Invisible NPCs

I keep getting 1 shotted by invisible NPCs. 1st time I was using Z-S overview and apparently it isn’t updated.

https://zkillboard.com/kill/79582408/

2nd time I went back to default and still couldn’t see them.

https://zkillboard.com/kill/79621693/

I have submitted a bug report 2 days ago and I haven’t gotten a response yet. I’m sure someone else has experienced this. I can’t find any posts about it. Why is it taking so long for a response about my ticket? I think that this is a game breaking bug and if there isn’t a response and solution soon this will drive me away from the game permanently. The devs need to look into this and not try to sweep it under the rug. I don’t like the game cheating against me.

1 Like

It’s not necessarily a bug. Z-S is not something that is developed or maintained by CCP and the default overview does not contain everything unless you load those settings.

Looks like Triglavians are getting you, but you will probably need to add them manually or set your overview to show All.

1 Like

Sorry about your loss but, this isn’t a bug. You just need to go into your overview settings and enable the Triglavian NPCs. Whenever CCP introduces new NPCs or player ships they’re disabled by default on the overview. You need to manually enable them in the overview.

4 Likes

Look, I have already added the Trigs into the overview settings and they are still invisible. This is not an overview setting problem. This is a bug because they aren’t being displayed in the overview or in space. My ship just takes damage from nowhere and I get blow up from cheating NPCs.

1 Like

Not a bug. Update your overview settings and don’t rely on a random third party person to update things for you.

You took on the risk that an overview pack that isn’t maintained by CCP does/doesn’t have the latest info. Sucks, but it’s not a bug.

1 Like

U can not listen to me and blame me all u want. I won’t listen to any more comments about it being my overview settings. You weren’t there when it happened. You don’t know. This community doesn’t listen and just blames the victim. I am trying to address a serious problem and I am just being blamed for something that isn’t my fault. This is not a setting problem on my end. This is a much deeper problem on their end and it needs to be addressed. Does anybody actually have something to contribute to this conversation rather than just pointing fingers at me? I already said I went to defaults after the first kill. I already checked to make sure that the overview settings were set to show the Trigs but they are still invisible anyway. If I set the overview back to default and the settings were messed up, then that is a bug and CCP is at fault. That isn’t the case here. The settings are correct and the issue persists. That is the problem. This is still a bug.

1 Like

2 Likes

Then report it as a bug. Ideally from in game.

Posting on the forums won’t get you a particularly positive result.

3 Likes

I already did that. I stated that earlier. I just wanted to try another avenue of support.

2 Likes

I’m still waiting on a response. Thanks for the advice and telling the truth. This is why I don’t regularly post on forums. I was hoping someone else ran into this and knew something.

1 Like

If only CCP would implement a UI feature that allows you to add new things they introduced to your available overview settings as you please. They already bombard us with new huge popups with ads for events. It cannot really be that hard to implement a popup that lists all your overview settings and all new overview items and the options to show them, leave them out, show their brackets.

This way they would create more awareness for these new things and people would have an easy way to add these new entities to respective overview settings without having to fiddle too much with the Overview Settings window.

1 Like

If you lost a ship, the kill report will be in your combat log and it would be interesting to learn who the involved parties were.

A bug should be affecting more than 1 player so it’s reasonable to assume an entity that isn’t enabled in your overview or possibly a corrupt cache.

2 Likes

Maybe Diamond NPC’s or FOB rats?

Usually this type of thread gets posted after visiting exploration Hacking Ghost Site.

This.

We are not trying to blame you with our comments, OP- missing things in your overview due to them not being added is a relatively common issue and we are trying to give you some guidance on how to resolve that. As others do not seem to be seeing this issue, it’s reasonable to assume that it’s something on your end. Triple check that the entity that @Wanda_Fayne posted above is selected. Also, as @Do_Little suggests, clearing your cache might help to make sure that something isn’t honked up in there.

Also, as mentioned, CCP has nothing to do with Z-S, so there is nothing they can do to fix that.

1 Like

Still not the overview settings. I have eliminated that possibility. I’ll just wait for the ticket response.

I started this thread with 2 kills from zkillboard. The overview settings are correct. The problem persists. I also tried clearing the cache and no luck.

I’ve only explored the career site exploration sites so far.

1 Like

I’ve already made sure the settings are correct. That’s not the problem. I cleared the cache and still not working. I also stated after the first death I went back to default overview, so Z-S overview isn’t a factor.

1 Like

You were killed by Raznaborg Damaviks which are Invading Precursor Entities. If you have selected them in overview settings, have cleared your cache and they still don’t appear in your overview it sounds like a corrupt profile. Try creating a new profile and see if that fixes it. Also try on Singularity (which doesn’t copy the profile settings from TQ). Raznaborgs shouldn’t be hard to find - most systems have some!

They show up fine for me and most other players - so unlikely to be a bug in the client…

2 Likes

We all wish you luck. It may in fact be a bug. I can say in my 10 or so years playing every time this has occurred it was an overview settings issue.

Unfortunately it happens often as CCP doesn’t seem to have a way to update default overview settings when introducing new NPC’s

I had the same issue when updating my overview using Z-S Overview and still had to manually add them

1 Like