Unresponsive UI

So I started playing today ( at least I tried to ) and wanted to explore and see what this game has to offer.
I travelled some but the UI isn’t responsive. Have to hit the buttons half a dozen times before anything happens.
I got blown up by NPCs because I kept clicking to get away but nothing happened.
I will stop playing until the UI is fixed.

You guys need to fix this game if you want more players.

Take care and good luck!

1 Like

Why do I have the suspicion that this chap was a victim of the “blue flashing highlighting” that plagues the NPE and Career Agents and completely kills performance? It has been raised several times on these fora but CCP just ignores it.

I didn’t experience a “blue flashing highlighting” anywhere in the UI, dear sir. Although I tried to do the tutorial but it froze. I had to kill EVE process and start the game again.
What I experienced was simply a lagging/unresponsive UI. Had to click at least half a dozen times before the ship got the message.

My computer can play Red Dead Redemption 2 and other high-end games like Middle-Earth Shadow of War. Does EVE demand more resources than the latest games? Am I going to have to buy more RAM or a new processor just to play EVE?

Also, I was in Null and tried to converse with the locals but I think the cat got their tongue cause they were mum for the most part. One only suggested I was liar. Is that what I’m to expect from the EVE community, a big ignore?

What’s going on with this game?

Just wanted to point out that all of the kills listed on your killboard are actually PvP kills (in nullsec as you mentioned).

Those are other players, they are not NPC’s, and according to the zkill on this impairor you were caught by warp disruptor probes. The other 2 kills listed for you were pod kills, also by other players, it doesn’t list that they had you disrupted, or scrambled, but pods are fragile, and don’t take very much damage to destroy.

All that being said you may be attributing “unresponsive UI” to the fact that your warp was being disrupted, you would have had to get out of range of the effects of warp disruption to be able to escape (honestly pretty unlikely in a corvette).

That isn’t to say that the UI doesn’t have issues with not responding to clicks, I’ve certainly had my fair share of times I’ve needed to click an extra time to make something work, i just wanted to point out that your issue might have been game mechanics at play which you wouldn’t understand being brand new, as opposed to mis-functioning UI.


That’s correct. I remember now, thank you.
I almost got destroyed by NPCs but did manage to get away that time.
I did get caught in a bubble and got destroyed by players, I think twice, I don’t remember so well, I’m on medication.

I did get caught and I don’t know if my warp was being prevented or not. It happened too fast for me to know.

But the UI issue remains true. I did have to click half a dozen times before my ship got the message, and that wasn’t during combat but during everything else: traveling, jumping, turning…

PS: I will give it another try today, going to say hi to my friends in D61A-G and see if the issue persists.

1 Like


So I logged in a couple of hours ago and paid a little visit to my friends in D61A-G. The good people in Y-MPWL were very supportive, especially @Jef_Patato who private-convoed me to explain a couple things, like: if I’m in a shuttle I have better chances to escape the bubble that my good friend @Jaw_Breaker set up in D61A-G.
I did manage to get exploded twice today but in the end I won and earned safe passage. Probably because Jaw Breaker figured I wasn’t worth the ammo, lol. I gone all the way to the dead-end system S1-189 YaY!
So far my exploration is a big success. I learned that there isn’t any asteroid belts Nulls, just Anomalies with asteroids guarded by NPCs - not that I want to mine. I find everything very interesting so far.
Maybe I get me a shuttle next and see how good it is at escaping bubbles.

The UI seems to be a little more responsive today. I didn’t have to hit buttons more than twice.
But there are still issues.
Yesterday the game didn’t seem to catch my mouse clicks, today it doesn’t seem to want to acknowledge my keyboard. My sentences in chat looked like a 5-yo writing: lag caused half of my words to be cut or outright didn’t register in chat. But that’s not a major issue. I’d rather the chat messes up than my navigation abilities.

All in all a much better experience than yesterday.

A BIG thanks to my good friend Jef Patato who took the time to explain a few things. I’m happy now.

'Til next update, I wish all capsuleers success and fun.



So today the UI is very responsive!
I switched my wireless mouse to another USB port on my PC and that could very well make a difference. I didn’t switch my keyboard but the game seems to acknowledge it just fine.
Maybe there are some issues with my ISP that slow down my connection as well, but also I have my brother constantly on his phone playing Avakin Life :roll_eyes: ( I could slap him silly but I’d be in trouble but omg I want to so bad )

I also just bought me a Shuttle as suggested by my good friend @Jef_Patato. It cost me 14k isk but it is worth it! That little vessel is nervously fast! It is still decloaking after entering warp, inertial stability is simply fantastic! If I’m going to break through bubbles I believe this little ship will do it standing on its head.
I am going to test it now and go say ‘hello’ to my good friends in D61A-G on my way to a new constellation. I hope they have a bubble set up so I can test my latest acquisition.

Just look at this little jewel of a ship
Isn’t it just so cute?
I think it may just become my favorite ship in the game.

I would like to take this opportunity to thank all the devs for their hard work and commitment to the game. It is beautiful and fun.
Hat’s off to you gentlemen :partying_face:

Until the next update, I wish all capsuleers have the opportunity to try this little Shuttle and be amazed by its capabilities.


I got invited in a Null corporation! But since Discord is a piece of sh- app and wouldn’t let me verify my account, which means I can’t participate in corporation fleet without it, I decided to not bother continuing with EVE since there is no point without Discord.

This is the last update. It’s been fun exploring Null.
I wish all Capsuleers better luck with Discord than I had.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.