Issue with new Nvidia drivers?

Got a message yesturday while trying to start the game, saying the Nvidia driver was too old (been playing ok for 6 months+). Have a Gigabyte Geforce 1660 super card, Windows10.

Installed new driver v3.23.0.74 (appears to have been released mid June, became manditory from start of Sept). Still not loading, get the CCP watermark, then nothing. When I try to start a second time, says the game is already running.

Any idea on this problem would be appechiated.

Might want to check the NVidia website again, for my card, they JUST RELEASED a new driver yesterday! (For Windows 10, 64 bit and Windows 11 only) and it’s improved my graphics quality so much that I may not have to upgrade for another year or so. And I have an OLD card - GeForce 750 TI. I can now run Eve on all high settings except post-processing. It’s like a whole new game to me now. Other games have improved as well. Very happy with NVidia.

Dray

Thanks Dray.

I did find an even newer driver, dated 31/8/2021. Installed it, but no change, still hanging after the CCP watermark. I’m running it from Stream. Interestingly No Man’s Sky is still working fine. The ‘GeForce Experience’ utility that installs with both the June and 31 August driver versions can find NMS, but not Eve.

Cheers,
Mort

Looks similar to other person issue. While it might not be same program that is causing problems I’m quite confident that culprit is some sort of other software.

You can also download launcher for CCP website and try to see if it starts when you bypass steam.

With similar issues for my machine, a “fresh” install of the Nvidia software and drivers have worked.

I know somewhere on the Nvidia site they have instructions on how to do it.