Issue with Updating Character Portrait

Hello everyone,

I’ve encountered a peculiar issue when trying to customize my character’s portrait in-game. Here’s what happens: while inside a station, I navigate to the appropriate module for character customization and set up the framing for my new portrait exactly how I want it. Initially, upon exiting the module, my character sheet seems to reflect the changes correctly with the updated portrait.

However, after a few minutes, the game invariably reverts my character’s portrait back to the previous version, prior to the modification. This happens without fail, leaving me with the old portrait again.

Has anyone else experienced this? More importantly, could anyone guide me on how to ensure the new portrait is permanently applied? Any advice or steps I might be missing would be greatly appreciated!

Thank you in advance for your help!

2 Likes

You can try a couple things to hopefully fix the issue.

When you’re in-game, open ESC menu, select ‘Reset Settings’ tab and select ‘Clear All Cache Files’. That usually helps clear out little annoying bugs.

In the Launcher before entering the game, check the little icons in the upper right corner to make sure you’ve downloaded the current game update. It’s located left of the little bug icon and will look like an arrow pointing down and probably be green in color. Click it to update the Launcher. If it’s not showing, then you already have the most current update installed.

On the right side of the little bug icon is a gear icon, click that to open settings window. On the left side select ‘Tools/Cache’. On the right side select ‘Verify Game Files’. It will take a bit of time to complete.

When done, enter the game and update your portrait. After selecting a picture in the portrait room, save it and after exiting Character Customization, exit the game, then open Launcher and re-enter the game. Hopefully your new portrait will be active.

Lastly you can file a bug report about it while in-game, I think it’s F12 key. Can also contact Customer Support about it here…

https://support.eveonline.com/hc/en-us/requests/new

1 Like

First of all, I want to thank you for your swift response and advice. Unfortunately, the issue still persists even after following the suggested steps. To elaborate, the problem is not limited to just one character but affects all characters I’ve tried. I even went a step further by creating a new character on a different account, but even then, the portrait remains empty.

Given this recurring issue, I am considering a clean install of the game to see if that resolves the problem. I realize this is quite a drastic measure, but it seems the issue might be deeper than expected.

I will keep you all updated on the situation after the reinstallation. Hoping this might finally resolve the portrait issue. Once again, thank you for your support and advice so far.

1 Like

Sounds like a bug, probably should report it. Guess I could check my characters and see if their portraits will update to new ones.

Also on a side note, if I recall correctly years ago CCP implemented a 30 day waiting time after an account is created before the character portrait can be customized.

1 Like

I’ve been having the same thing happen. I’ve tried to update the portrait twice, and it looks like it’s worked both times but resets when I log back in.

External tools and forum avatars are still the old portrait, and it’s been several hours since I first changed the portrait.

1 Like

Forums need to be logged out and back in for the avatar to take effect

1 Like

I logged in several hours after changing the portrait, but it’s still the old one. I’ve raised a bug.

2 Likes

I’ve reported the bug with as much detail as possible.

2 Likes

Personally, I’ve found updating my character portraits may take anywhere from, at the very least, 24 hours to three days.

I do not know if this is a bug or not; but, as this has, to the best of my remembrance, always been my experience, I simply assumed updating a character portrait was done not instantly but on an infrequent basis, so as to save “resources”.

I do hope you report any replies you receive here, as I am very interested in knowing if this is a bug.

Thanks.

2 Likes

I understand. Interestingly, when I tested this by creating a new character and leaving its initial portrait unchanged, the default portrait was swapped out with a blank one within 15/20 minutes.

Update : It seems to affect a large portion of new players who did not have an “existing portrait” in memory, as evidenced by the starting areas.

I have noticed this before, usually it can take up to a day before your new portrait becomes permanent.

There has once been a bug that all new character portraits that were made never became permanent, which lasted for about a week.

May be the case now too, so see how long it lasts, make a bug report and wait until CCP notices.

1 Like

I am having the same issue. Nothing suggested in this thread has fixed it so far.

Yes bro, this is definitely bugged, I customized 10 differentes characters, spent like 6 minutes in each one to make them all look the same just to found a hour later all the changes to all accounts didn’t take effect :cry:

pvp’s made it to character customization

I have recently endeavored to update my portrait, and from my perspective, it has been executed successfully. Nonetheless, I observe that there continue to be new players devoid of portraits.

However, I have received no response to my request for assistance or my report to the developers.

I can only suggest to new players to attempt changing their portrait if it appears empty.

I hope one day my toon’s portrait will be available.

17 hours later… better late than eve(r).