Launcher Issue - Keeps updating the same version over and over


(DrysonBennington) #1

This will be the third time that I have downloaded the new launcher version 1423047. The first time the download went smoothly and then closed out. The second time the download went above 100% to around 125% of loading the new launcher binaries. This is the third time that the launcher has downloaded the same version.

When I cancel the download nothing appears on the status bar at the bottom.


(DrysonBennington) #2

Downloading new version 1423047 - 100%

Downloading new launcher binaries - 130% and rising.


(GM Mechanic) #3

Try deleting the launcher cache, it’s saved in the appdata folder and even if you uninstall the cache will still be there. Old cache files may be affecting your launcher, try removing them and then see if the issue persists.

  • Please press the windows key + R to open a run window.
  • Copy and paste the following into the run window and press enter.

%LOCALAPPDATA%\CCP\EVE\cache\QtWebEngine

  • Right click on the folder named ‘default’ and delete it.
  • Start the launcher and see if the issue persists.

If the issue still persists after doing this then I would love to see your launcher log file. It may contain information as to why the launcher download bar is giving you bogus information.


(DrysonBennington) #4

Last night after waiting until the launcher downloaded to 158% of the binaries I closed the launcher window out and could then log in and play.

I got up this morning fired the launcher and the same thing. I had to download the new version.

I deleted the ‘default’ file and started the launcher up again.

I got an Eve Launcher Update for version 1423047.

It’s almost as if there is a file ‘griefer’ file siphoning off the binaries that makes me have to reload them everyday. Once I get in the system is stable and nothing dramatic play wise takes place. You would think that catastrophic game play would take place with a persistent error like this occurring.

Maybe there is an error involving the number of players logged in. This morning it was 36,000 when I had to reload the new version 14230347 again.


(DrysonBennington) #5

Cleaning out the ‘default’ appears to have worked this time. After downloading the new version the launcher closed out and I had to restart another launcher session like I did yesterday. That is when I started having the persistent launcher download issues. Today after the downloading the new launcher version the launcher worked and I was able to enter the game.

I did come across for five errors however which I have taken an Snip of and is seen below.


(DrysonBennington) #6

Two more errors have shown up in the Shared Cache\tq\bin\exefile.exe
Both are the same.

Module: Client Channel: Localization Message: Localization module: No label with name ‘None’.


(DrysonBennington) #7

Then the catastrophe took place resulting in a Socket Closure.


(DrysonBennington) #8

I started the launcher up again after the Socket Closure without any problems with the launcher.

Must be something involving the Activity Tracker because there is an error message that reads: Failed at storing client achievement events, e = User error, msg+GPSTransportClosed, dict={‘what’:'The Transport has not yet been connected, or authentication was not successful."}

If you need the Log Lite let me know.


(elitatwo) #9

Did you check your anti-virus software for quarantined files? It sound like an anti-virus software or whatever “safety-software” you may have running in the mysterious background of windoze™ may cause this siphoning you describe.

If possible you may need to exclude the eve launcher folder from the scans or put the eve launcher folder into a sandbox mode or whatever that software does provide.


(Maud) #10

I’ve been experiencing a problem on all of my computers, where the launcher will update, request a restart and then proceed to re-download the same update.

If I don’t cancel the update window, the launcher will just loop endlessly.

I tried following GM Mechanic’s solution which sadly didn’t make any difference.

The only solution I’ve found to this problem is to uninstall the launcher and install it again, however, this seems a bit of an extreme solution to have to apply every time this happens.

I can understand the potential benefits of using a launcher but I as a player much preferred it when you just launched the .exe file, let it update and then you logged in and it worked …

Prior to the .exe client been locked, I used to repair tool to “update” the client and then fired up the .exe file to avoid the launcher.

Any thoughts on how to resolve this annoying problem @GM_Mechanic?


(GM Mechanic) #11

What launcher version do you have? Have you made sure your using the latest release version. If the launcher keeps downloading the same thing over and over it usually means there are permission issues and the launcher is unable to modify files.

Current launcher version as of typing this is 1423047.

There were huge security risks with the client login which is why the launcher route was taken. Our players security has to come before convenience.


(Maud) #12

Thank you for your quick response @GM_Mechanic

On the bottom right-hand side of the launcher, it suggests that I’m running version 1381807.3104

For the past couple of weeks, the launcher appears to have been working fine i.e. updating the game client each day a patch is released and not generating any error messages.

Two or three days ago I started getting a message on all my PC’s with Eve installed “The Eve Launcher has downloaded an update (version 1423047). Press OK to apply the update or Cancel to stay on the current version. Update will be applied automatically in X seconds.”

Unless I Cancel the update, it will keep looping.

This has happened quite a few times in the past and the only solution I’ve found works is to re-install the launcher from scratch.

I’ve tried running the “fixpermissions” tool which didn’t make any difference and I’ve also tried disabling my anti-virus/firewall to no effect.

As I said, I understand the potential benefits of the launcher but I just wish that it would work.


(Maud) #13

@GM_Mechanic

I seem to think that this problem is being caused by something I’ve done, because I’m not seeing many other people report the same problem.

Does the Eve Launcher rely on any specific Windows services that I may have disabled without realizing the effect on the launcher?

Thanks :thinking:


(Nelliver Cadigal) #14

Hello there,

@GM_Mechanic, what is the procedure to delete the cache for Macs as this problem is occurring for me on a mac as well but that Windows command obviously will not help here.
Thanks in a advance!


(GM Mechanic) #15
  • Open the Finder and press the Cmd key + L-Shift + G key to open Go To Folder.
  • Copy and paste the following into the Go To Folder text box and press enter.

~/Library/Application Support/CCP/EVE/Qt/WebEngine

  • Right click on the folder named ‘default’ and select move to trash.
  • Start the launcher and see if the issue persists.

(GM Mechanic) #16

Nothing that comes to mind, I would just try reinstalling the launcher. Move the shared cache folder to a different location on your hard drive. Then uninstall the launcher and then reinstall with the latest version. Then copy the shared cache folder back so you do not need to download the game again. Then see if the issue persists.


(DrysonBennington) #17

Issue has been solved. I think the reason for the problems with the download was the rate at which my WiFi was transmitting the data.


(Nelliver Cadigal) #18

Hello @GM_Mechanic,

unfortunately that did not help. I deleted the folder as described opened the launcher again. I got the download window again for new version 1423047. I clicked OK and logged into the game. Then logged off again, closed and re-opened the launcher and the upgrade pop-up was there again. Any alternative way to install the launcher on a Mac?