Launcher Settings Change – DirectX 9 Metrics Gathering

(Sarmatiko) #21

Good initiative, but I think devs need to address some issues first that draw some players to DX9 mode.
For example dust clouds. Switching to DX9 is the only way to disable them completely (without disabling “Effects” and crippling visuals) and for years no one implemented proper “Disable Dust clouds” switch in the settings to overcome this.

(Rain6637) #22

my laptop is fine with this, I wasn’t using DX9. But I know my desktop would have a hissy fit over this.

(Ptraci) #23

Going forward - with Directx 12 and Windows 10 - I hope CCP is taking into consideration Windows 10’s stunning 27 percent market share and NOT making this any sort of priority for the moment.

I for one will give up EVE before installing that crapware on my system.

(Scipio Artelius) #24

The enterprise market is pretty irrelevant when it comes to games though; and has always been slow to move to new versions of operating systems.

Private use though is much higher (I’ll grab stats and link them if I can find them).

(Cameron Lytle) #25

ccp dis ganna help alot FOR ME SINCE MY GAME KEEPS CRASHING ';D

(Amarisen Gream) #26

Anyone on macOS abl to get the game to run DX11. I have unticked the run in DX9. I tried both latest dev (CCP and WineHQ)

(Kasuko) #27

Ah, nothing like getting an update in my RSS feed about this little feature. After reading it thinking “Well here is a little thing, that just changes a check box but allows you to continue to use the application as desired while allowing CCP to gather useful data to make the game better. No one could be angry at this, let’s go check the forums” and sure enough you did (not?) disappoint!

(elitatwo) #28


does mac os even download the needed wineHQ releases? Here on Linux I can just add the repositories and untick DX9 but in client it still shows dx9 rendering. Better you leave it on for the time being.

@CCP_Snorlax, this is something you may want to look at whenever you can.

(Amarisen Gream) #29

I have been trying to get a response from CCP on the whole topic for at least a month in the Mac forums. Not luck at all. It is like they are just ignoring us.

(elitatwo) #30

I am sorry to hear that, dear!

Can you imagine that Linux and max os have been using the same wrapper for Windo$$e programs for quite some time now? Though some say Linux is not important enough (yet) to put some force into developing, strong arming them into put some effort into making it work, max os has been getting the preferred treatment since mac users are paying a premium for their very, very, very expensive pc.

I do know for a fact that my hardware is more than capable of running all of the new EVE and then some and twice on Sundays.

(Amarisen Gream) #31

As it is hard to always understand the tone of a written message, I will assume you mean well.

As both Mac and Linux fall into the same or similar boat, it t new to be sad when you @CCP_dev for a few months and get no reply. The most recent reply was from @CCP_Goliath who was kind enough to say they know that the mac client can and/or does have issues with ram. As this thread is about getting DX9 metrics, I was wondering how DX11 support was coming along for macOS! Yet to see a reply.

(Mike North) #32

Sorry if this has already been mentioned, I didn’t look through all the comments. The overlay for Mumble uses DX9. If you use anything besides DX nine, the overlay will not appear. I know this is not CCP problem, but given how many people use Mumble, it’s something you should take into consideration before phasing out.

(elitatwo) #33

I did mean well. What I can tell you is that the wine wrapper went a long way and is very close to feature all of the dx11 things and since both Linux and mac os use the same one, it shouldn’t take too long now.

(Amarisen Gream) #34

Okay. Awesome. Text isn’t always the best platform for information. And I don’t always read things the way intended.

I was thinking it was close, but everything I have googled or tried to read or changed settings for didn’t do anything to change the control-f box in eve from saying it was running DX9

(guigui lechat) #36

I’m using latest wine staging and it works fine. and it’s nicer :slight_smile:

(Amarisen Gream) #37

DX9 or 11 when you are in game?

(Deligent Beeman) #38

Hope they will include it in unofficial launcher when DX9 support will be phased out

(guigui lechat) #39

well last time I tried (two month ago) I had random crashes on dx11.
I gave another try one month ago, and since that have not had any other crash.

The wine staging is available in some repos. if you want to give it a try

here is my program to make wine prefixes for eve. it allows me to create as many eve prefix as I need, in 32 or 64 bits.




EVEINSTALER="$(source ~/.config/user-dirs.dirs; echo $XDG_DOWNLOAD_DIR)/evelauncher.exe"
while test $# -gt 0
	case "$1" in
			shared=$(echo "$1" | sed s/--shared=//g)
			prefixroot=$(echo "$1" | sed s/--proot=//g)
			echo "create a wine prefixe. options are :
--32 to create a 32-bit wine prefix [default]
--64 to create a 64-bit wine prefix
--delete an existing eve prefix instead of creating it
--help show this and exit
--print print variables then exit, do not modify existing prefixes
--proot=X specify the wineprefix root. default is $prefixroot
--shared=X to specify your shared Eve folder (for settings). default is none, meaning settings are not shared"
			exit 0

launcher=$(source ~/.config/user-dirs.dirs; echo $XDG_DESKTOP_DIR)/"$name"

if [ "$print" = true ]
	echo shared = "$shared"
	echo prefix = "$prefix"
	echo prefixroot= "$prefixroot"
	echo name = "$name"
	echo arch = "$arch"
	echo eveinstaller = "$EVEINSTALER"
	exit 0

if [ ! -z "$shared" ]
then mkdir -p "$shared" ; fi

if [ -d "$prefix" ]
	if [ "$del" = true ]
		rm -rf "$prefix"
		rm "$launcher"
		echo "prefix $prefix already present and not requested to delete with --delete. Exiting."
		exit 0
	if [ "$del" = true ]
		echo "requested to delete a folder tha does not exist"
		exit 0
	mkdir -p prefix
	WINEPREFIX="$prefix" WINEARCH="$arch" wine wineboot
	WINEPREFIX="$prefix" WINEARCH="$arch" winetricks corefonts
	#create symlinks to shared and configs
	if [ ! -z "$shared" ]
		mkdir -p "$prefix/drive_c/users/$USER/Local Settings"
		mkdir -p "$shared/Application Data"
		rm "$prefix/drive_c/users/$USER/Local Settings/Application Data" -r
		ln -s "$shared/Application Data" "$prefix/drive_c/users/$USER/Local Settings/"
		mkdir -p "$shared/SharedCache"
		mkdir -p "$prefix/drive_c/EVE/"
		ln -s "$shared/SharedCache" "$prefix/drive_c/EVE/"
	# make launcher exec on desktop
	echo '#!/bin/bash'$'\n'"cd $prefix"$'\n'"WINEDEBUG=-all WINEPREFIX=$prefix wine "'C:\\\\Eve\\eve.exe' >"$launcher"
	chmod +x "$launcher"
	# dl and start the Eve launcher
	if [ ! -f "$EVEINSTALER" ] ; then wget "$EVEBINARYURL" -O "$EVEINSTALER"; fi
	WINEPREFIX="$prefix" WINEARCH="$arch" wine "$EVEINSTALER"

(Benje en Divalone) #40

Mumble’s dev snapshots support DX11 (and has reached 2010 feature parity with other VOIP chats by implementing per user volume)

(Ravow) #41

On Linux (if your Linux install support Native DX9), it mean :slight_smile:

  • 50W more from the wall
  • 1/4 of the FPS
  • no more playable in 4K!

Note that I did nor run with DX11 to test personally as it just do not work and use DX9 even if the DX9 box is not ticked and RadeonSI is certified OpenGL 4.5 and have most of the OpenGL 4.6 bits… Do you need yet another special Wine for that?

Edit : I was able to run EVE in DX11 mode with wine on Linux, GFX are perfect except defunct anti aliasing.

my estimation was about right, but it’s about 1/5 instead of 1/4 of the perf of Linux native D3d9 (dx9 = 125fps, DX11 = 25fps), tested in 3840x2160 will all setting to high, in a combat anomalies.