March 2018 Release - Known Issues & Reporting

The Structures Browser is non-functional.

Stuck in “Launch Process Started”

The dramiel skin isn’t in the NES.

Edit: Also I have a bunch of channels, and none of them are loading.

Edit 2: A server process i was using went offline and I was disconnected.

Same here

WTB: Stargate Blueprint, we seem to be missing ours :frowning:


Well, these are the situations where I thank god for also having a real life as backup.


The game launcher is frozen at the loading part.

Had to quit/force quit the first time I launched as the loading took many minutes.

Clicking on the character did not allow log in.

Ive crashed logging out…so cant log out…

1 Like

Both god, and “real life” is a myth!!


Same lot of lag , couldnt even up cargo and now server disconnect in middle of a warp

Launcher is froze at loading

Markets don’t process orders. Mails cannot be sent.

FUBAR. That is all.

1 Like

Game freezed and now I can’t even login to the launcher atm, error code: 0A2F201A-AEED-49FB-8518-2DEA18A5E301

I got a lot of notes in the Notepad. Tried to open it and it showed blank. Then tried to close it and it finally showed the notes. After I managed to close it. I clicked again to open it. It showed up blank again. Can’t close it. I guess it is some sort of lag…

1 Like

Character Sheet does not open - not by Alt-A, click on the picture or via Neocom-Entry.

  • Edit: “Connection lost - A server process you were using has gone offline.”

Copied from my posts in incorrect thread:

Hideous lag in much of the UI, channel settings doesn’t work, Local takes ages to refresh upon system entry.

EDIT: Lag affecting changing hangar view, eg. look into container.

Change of channel notification message is now not overwriting itself, but listing sequentially - and because the channel settings doesn’t work, this spam can’t even be cleared.

And now I’ve been waiting on arrival side of a gate - my ship: not rendered. Other nearby objects: none to see. Overview: nothing shown. Actions: none possible. This has been going on for a few minutes now, after a long gate jump, after a “traffic system can’t process your etc.” (~160secs)

server is down dudes

Did it die?

Error refreshing token when trying to log any accounts in. Ah well, guess I should do some work today anyway.