Mission space inaccessible

Unable to reach mission sites via rightclick menu or the blue button. The mission bookmarks don’t initiate warp. The mission bookmarks on sensor overlay are visible but also not usable.
Bug report sent

1 Like

Polite bump, missions still inaccessible on Sisi.
EBR-216427 March 17th, 2021

Another polite bump. April 28th, 2021 and mission sites are still inaccessible.

same old EBR-216427 of March 17th, 2021, “open”, no comments

Any reply from a dev would be greatly appreciated. Thank you.

2 months after sending bug report, no reply. Missions still not working on Sisi. Bug or simply switched off for the unforeseeable future ?

Out of curiosity, is this on just one character and account or all of them?

1 Like

Tested another account just now (that one was never on sisi before), seems to work fine on at least one character.
Main account is affected on one character, other characters on that account work fine.

I remember at the time the system with the agent still had to load on the server (the usual traffic message for a long time, etc), maybe some settings got corrupted on that specific character ?
But thanks to your question the problem now seems to be more character based than anything else. Possible fix (besides the dreaded clear cache) ? Better a support than a bug ticket, I suppose.

1 Like

Next question: all mission agents, or just one, are having this issue?

I am curious about whether it might be related to having a mission in progress for a given agent during the mirror execution, which I can totally see breaking it if the snapshot is taken before the mission times out, but by the time the mirror is actually fully executed the timer has expired, and the mission gets stuck in a funky limbo state that breaks the agent for the character in question.

1 Like

all agents for that character, tried at least 5 different ones, at different times, with and without quitting the missions. The problem started well after the last mirror (March as opposed to February). I think some glitch occured on the first mission, when the system where the mission took place was slow to generate. But that’s 100% guessing. No idea how those bookmarks are generated, nor how that affects the ability of a character to run a mission. I can accept new missions from the same or an other agent, as long as they have no failed mission entries in the journal. The UI responds normally (blue button, rclick menu etc, bm’s in space), just warping to them is impossible.
Failed missions also stay in the journal. They require my pilot to go back to the agent and click the Quit Mission button to delete the entry from the journal (something I’ve never seen before but I’m not in the habit of quitting missions).

Great additional detail.

Running through ideas on ways to try and force the first agent that had problems to reset whatever is corrupted…

Hmm, have you tried forcibly abandoning a mission early, not just expired ones?

I’m assuming you can cycle through mission offers as normal (decline and get a new one, decline again and take the sec status penalty, etc.)?

Aside from that, the character may be stuck unable to mission until the next mirror when whatever gets fixed. Sadly support tickets aren’t available for Sisi, only bug reports, so unless a dev gets around to poking at it there isn’t much to be done, and a single-user non-recurring (as far as we can tell) issue is going to be looooow priority.

Oh, have you tried doing non-site missions to see if getting a good completion on, say, a courier mission takes care of things and resets whatever goofy bit is off?

Good suggestions, going to try them all. Like now :smiley:

1 Like

Good luck!

Yep, more than once, on several agents, doesn’t help or reset anything.

Yep, I get the standing hit. The problem is with the mission bookmarks not being active. The very first agent I had problems with still gives new missions every time, they just don’t work, after declining another one, or even quitting one.

Yep, courier mission works normally (including the blue button, which is responsive to “set destination”), couple of jumps out, normal hand-in for mission. After this successful completion, went back to first agent that started the problem. Got a new level 4 security mission, didn’t work.

Out of curiosity I tried a mining mission (lvl 1), which also requires an “on-site” mission with bookmark. That too was inactive.
I also tried an RnD agent (another type not requiring bookmarks), got the courier type mission, worked.
On closer inspection, also the bookmarks generated visibly (overlay) and in the rclick menu for this type of missions are all inactive. Only the fact that these can be bypassed by traveling to the station involved allows my pilot to carry out the mission.

Conclusion: all mission bookmarks, regardless level of mission, type of agent, affiliation of agent, are inoperative, making any mission space inaccessible.

Can you access non-mission bookmarks/pins as usual?

Can you access non-mission beacons (like moon mining fields and asteroid belts) normally?

Yes, personal bookmarks (old ones and new ones made a few minutes ago) all work, either via rclick, local bm menu or visual bracket (overlay).

Yes, other brackets in space, rclick menu entries and overview elements all work as warpable locations

Only the ones generated by the server for missions are affected.

I am fresh out of ideas :frowning:

No worries, we narrowed it down a great deal. And it was fun chasing this thing, well, sorta :smiley:

At least it allows me to update the EBR with more specifics, like single character issue, and generalize to all mission related bookmarks regardless mission type and agent. If someone is willing and able to pick it up, great. If not, like you suggested, let’s wait for the next mirror. Apart from testing “new changes”, and upsetting perhaps a csm member afterwards, I’m not often on the test server these days…

Thanks again !!

1 Like

Oh, I thought of a thing to try: can the afflicted character use fleet warp, where individual warping fails?

1 Like

Off hand I would say “probably not”, but never tested it.
UPDATE: no, at least not with myself as FC in a one-person fleet. The bm’s are as dead as a dodo :grimacing:
p.s. also verified file integrity in the cache, nothing found/fixed/removed. Updated the EBR, for what it’s worth. If you think of more sticks to poke the beast I will try them.

1 Like

Bringing finality to the mystery.

“Clear all settings” in the esc > reset settings window did the trick

1 Like

… weirdest thing to have fix it. I mean, seriously, what could possibly have been connected between settings and warping to deadspace??

1 Like