New development wine build available: winehq-binary-226/Wine 4.11

Hey all,

I’ve just released a new version of wine into the dev versions branch, it’ll be listed as “winehq-binary-226”.

Under the hood it’s wine 4.11, specifically this one: https://sourceforge.net/projects/wine/files/Slackware%20Packages/4.11/x86_64/

I don’t have any plans to push this to release wine any time soon, it’s well upstream of where the mac wine version is at. I’ve put it in dev because I want to play around with it and see if it’s got any fixes for the black gas cloud cubes etc.

Give it a spin if you want and let me know what your experience is. Don’t forget to include your distro and bitness!

1 Like

Any idea if with this build we will see an improvement to the cpu usage increase the last change left us with? :slight_smile:

Isnt that black cloud problem something related to dx11 and the 64bit client?

Ubuntu Mate 18.04.2, 8GB RAM, RX460 4GB Padoka drivers
Tested in 64bit Dx11

AA: Disabled
PostProcessing: none
Shader: MED
Texture: MED
LOD: MED
Shadow: Disabled

I was doing L4 mission “Silence the informant”, while warping there I was greeted by a black gas cloud box, which is visible on the left side of the view (using HUD). FPS with the npc’s went to 15-20fps (also without, while looting (also in HUD view))

On 32bit dx9 I dont have black gas cloud box problems :wink: (FPS is on the 30-50 on this machine).

CPU usage still about the same as after the ‘nerf’ (alas too high for one client)

PS: I can see little traffic lights in the NPC stations, I guess its a dx11 only feature, never before had seen them, nice touch, but FPS are horrid, and the scene doenst seem that complex, specially at the noted graphic settings.

I actually don’t know the answer to either of these questions. As far as I know the black cubes show up on both the 32 and 64 bit clients in dx11 mode (I might check when I get home), so I think it’s just a DX11 thing.

I’m not suuuper-concerned about the CPU usage as long as it’s still functional. I have to pick my battles on linux patches since it’s not officially supported so I work on it in my spare time. I’ll keep an eye on the situation but I won’t be putting any time into investigations unless CPU usage makes it impossible to play. I am however always open to people who know what’s up telling me what’s wrong and giving me clear info on how to fix it, so if you know why it’s happening please clue me in :smiley:

Well, it started happening the moment u guys deployed the pre64 update, to be more compliant… since then I cant play with more than 1 client, 2 clients I get bad FPS, and before that this same hardware could run 4 clients easily.

What did you guys do, I have no clue. To me it feels on purpouse, to combat the botters, but hurting the ones that play by the rules. Theres no way I can see what changed in the code, I do know that this machine was able to handle it well and now it cant.

Functional and FUN are two separate things, and I dont play a game to be functional…

PS: By the way, not that we arent appreciative of your efforts, we do, but a big problem like this being addressed as slight when its actually huge… and ignore it as long as its functional… well, potato mode is functional. (Still cant use 4 clients as before in potato).

PS2: Something in the code changed, that affected most older but capable computers. It even affects windows computers, as I had switched to WIndows for a week… and I couldnt get the 4 clients to work neither. But it’s you guys who don’t know what changed. If you dont want older hardware, just let it be publicly known.

Adara, is it possible that the performance degradation with regards to CPU is related to the spectre “work-arounds” placed in all the OSes now, which cost performance as CPUs can’t do as much predictive stuff any more as they did in the past?

It’s not, I don’t think so. I did not change my mitigation setup since about 8 months and also I do have an AMD CPU.

If you look, at lease in custom Wine, both EVE threads and GPU pipe are under 100% load. one of them should be at 100% load. something is weird.

Even if it were related to Spectre, explain why it would happen exactly the moment they did the pre64bit update… before that was working fine, after that fatidic update, is not.

My CPU temp readings used to be pretty idiotic cold before the pre-64bit change, now, Im lucky if I dont hit 50C with just one client.

I can‘t tell you the answer. It is just so that on my machine I haven’t noticed any performance Hit with regards to 64 bits. And my CPU is really old (i3-3220 @ 3.3 GHz x 4) as it wasn‘t upgraded over the years like Main Memory and 3D Card.

I run a 2011 APU (A8-5600K) :slight_smile: the GPU needed to be upgraded cause in 16.04 my APU wasnt supported (as GPU, the CPU part works fine) anymore, so to continue using it, I installed my RX460, which has been working since 2016.

As it was, connected to a 60hz 32in TV… I was able to run 4 clients. After the pre64bit update, then, only upgrade since… a new Dell monitor, Freesync 27in 1080p. Nothing else changed.

I read this eariler and I wanted to contribute to this, but I didnt know where to look for this. But I do remember running the FPS counter on 2 clients as a test, and I couldnt help but notice that my alt, being out of focus was getting 43fps, while the main, Adara, was on focus and was doing 35fps, and I couldnt understand why.

Normally, out of focus should get less attention from the CPU, but I guess whats happening is that they somehow all of them are getting attention at all times, no matter if they are minimized or alt tabbed behind the one active client.

Now, how to help CCP notice it too and then fix it… how do we do that?

well, out of focus gets 32fps, and focus client 20fps :wink: So, how we explain that?

@Adara_Starkiss
Could be ui clutter?

Your in focus client have more stuff in it.

That being said, the focus / out of focus work properly here. I get abysmal fps while in focus and half of that when out of focus.

That also happens when I have ran the 2 clients in space, but in theory, the active client should be the one with the main focus, and assign better resources to the active (on focus) client. Its something I heard happens in Windows, the minimized client (or off focus) eats less resources than the active client. Theres no way I could show the FPS on both clients if they were maximized… one on top of the other.

And being that Alt tabbing is harder with full screen clients, I went with windowed, which still gives me sticky keys, which is not yet resolved. BTW, the radeon profile window, while playing, shows me the GPU% usage, and its usually below 10%, which makes me think that somehow the GPU though recognized correctly, is being under utilized, and instead it seems that the game is reliant more on the CPU than the GPU, when it used to be less CPU intensive.

As documented in another thread, I’m getting a lot of sub-1 FPS experiences on recent builds. I’m relatively certain had no local changes associated for one of the day. Whatever daily minor patch came out sent me back into the sub-1 FPS dungeon. I tried a lot of combinations. Really feels like a client change occurred, was rolled back, then reoccurred.

I decided to check info on this Spectre thing, and I found a site that suggested a script download to check for these problems (Spectre and variants, Meltdown and others as well), and it reported my system as not vulnerable, it was interesting to find and I feel more at ease after the results.

I suppose this is why you mentioned it, and its interesting that Windows 7 doesnt suffer from the problem. What I do not know/understand is if we can determine the O/S is doing something alas Win10 that is mitigating the spectre/meltdown problem by increasing CPU usage? I really dont understand why that would be a fix for a problem, since instead of letting the system run fine… its making it work awfully, but I guess this is a out of the reach of everyday users.

Dont understand why @Ravow with newer hardware compared to my system… is also experiencing a similar problem with the EVE clients going at 100%, as the above thread link reports happening also on Windows 10, and its also interesting that perhaps thats also the reason why I was getting the same horrible performance in Windows 10 (Though they did mention something about the 1903 update, which I think is the latest big 32gb patch, which I did not do, so why did that happened to me before 1903 I dont know).

If its on the O/S level, what I still dont understand is when it was introduced as a patch in 16.04, as it was working fine and the ‘update’ I dont remember reading about it, and coincided with the pre64 update. So, it would seem that I could go back to 16.04 and pay attention to which update does that and tentatively not install it?

Was good to know that eventually, when Im able to fuel the budget for a Ryzen 5 2600… (or better)… that the problem is fixed.

This would also explain why some other systems dont suffer from the problem. Light at the end of the tunnel…

So, Im backing up everything and I will go after 16.04 and hopefully report good CPU % :slight_smile:

Back to 16.04.2… APU temps at 13C, GPU at 45C, but I havent been able yet to install the Radeon Profile software. CPU usage is not as I remember, but the temps are as cool as they used to be (crazily and as a friend said on the linux channel… theoritecally impossible temps)

I’ll report soon trying the multi clients…