New Singularity mirror 2021-08-10


A new mirror has been deployed to Singularity!

The server is currently still in VIP mode, while we finalize the market seeding. - I’ll update as soon as it is fully available.

Update: Singularity is back online, market is seeded and skill points from previous mass tests are applied as well.

Steam users: Please let me know, if the login problems are sorted or if we need to investigate further? (I’ll also run further tests later on it myself…)


Now I am even more powerful!!!



Will this also fix the issue with steam users not able to log in?

Im exactly like that

Hopefully this should be sorted, if not, then we’ll need to investigate further.


Hi, I am one of the people who was having Steam login issues. It appears the issue persists as of ~0000 on the 11th. The error that used to be unspecified yellow text has been replaced with:


Thanks for your work on this issue!

I’ve had another person in another thread, which for some odd reason they wouldn’t post here, couldn’t log in either on SiSi via steam @CCP_Habakuk

still unable to log in with steam account image

I am struggling to authorise my steam account after the recent update to singularity

I realised that there was a new thread for the mirror, just tried again and no luck still. thank you for your patience. I have posted in this thread.

I could add my steam account but at this point i used the name/password i created the previous mirror when it stopped working.

Today I tried joining singularity. Yesterday it worked without issues. But recently every time I was launching my accounts, I had a message: ,game client assigned to [playername] closed unexpectedly’’. I sent ticket and was redirected to test server feedback as the staff provides support only on tq. Anyone else has this problem? It happened after my launcher was downloading new update, maybe this broke something?

Edit: I didnt manually change any settings of launcher, didnt move any files, nothing. I noticed it started happening after the last download of data for game launcher on singularity. My alt account also doesnt open.

Can you check if you might be affected by the crash, which I wrote about here: Known Windows client crash in latest Singularity build

I didnt start with fresh settings today. I entered singularity yesterday with intro movie played and skipped perfectly without problems. Everything was fine until my launcher downloaded latest patch on singularity and now opening the game there is impossible. I suppose this patch changed something to my disadvantage, I have no other ideas.

Edit: Today I still cant enter. I dont know much about programming, but reading my loglite I noticed it starts reporting error when trying to load python extension ‘_trinity_dx11’ with flavor ‘’ or sth like that and then the session is terminated and client fails to launch.
Edit2: I see this error on tq loglite too, but it doesnt lead to ever-lasting closing my client before it launches, unlike singularity.

I guess I wont enter this mass test.

Is there anyone in CCP staff who could investigate my loglites from singularity launching attempts and help somehow? Please, I wasnt able to enter mass testing due to this really odd issue that no one else reported. 3 previous months of being unable to enter singularity meanwhile first time finding out about it, after 1 day of playing, I am now unable to enter because of launcher complex error. Nothing helps, changing profiles, adjusting settings, trying all possible launcher/game client settings configurations.

Edit: ok, nvm, I will just reinstall evth, if this doesnt help, then I am totally screwed. I know singularity has very limited up to no technical support.

i have this EXACT same issue, on windows though, since the update yesterday, done everything including uninstall and reinstall, did you ever find a fix? @GerwazyPL777

I uninstalled just now. Hoping it will fix after next install.

i tried that already, no go for me :frowning:

Guess we will get another break from singularity. Who knows how long this time.