Not able to login with linux launcher


(Havis 911) #21

I was able to use Windows Launcher with wine-vanilla-3.15.
I had it the Windows version set to Windows 7, in winecfg.
If I tried to start the client, it started but crashed on login screen.
it looked like this error: https://bugs.winehq.org/show_bug.cgi?id=38960

After setting windows version to Windows XP, I was able to launch the client and play for a few minutes without crashing.
I hope this helps to a lot of Linux users.

o7


(Levi Vance) #22

I run Ubuntu 18.04 and was not pleased to encounter an error message this morning. After reading this thread and the above reply, I went into WINE configuration and changed to Windows XP. Instant magic. Thanks all for their input.


(swire) #23

I can confirm this. I was getting a wine error this morning, and have replicated it on another machine also. Switching over to Windows XP also removed the error.

Windows XP was the best windows, in my opinion…


(Ima Wreckyou) #24

I use the Linux native launcher, but configured to use the system wine for launching the game because the wine CCP ships has stopped working a while back. Wine version is 3.15 and I just checked, it is still working.


(Ima Wreckyou) #25

Man you should just use Gentoo where the package manager actually supports such things in a sane way without much scripting or much effort :wink:


(NikkerdudeLearned) #26

i managed to get in with linux launcher just now by selecting- development-
in the launcher’s settings. After starting this version , i canceled the update attempt and it worked with the version called
1330184.3092

hope this helped


(Rivil Avaltras) #27

It worked for me also. Thank you


(Alyx Graff) #28

Tried, but no any luck :persevere:


(Gharim Turen) #29

True, it works and after i have changed my evelaucher.sh script it works with the developer version from the linux launcher too. But the question is, how long does it work. Dont forget that you use a developer version which maybe have other errors or glitches from them you nothing knows.


(Whitehound) #30

You find such scripts and tools for all distros. I just like to have my own. Gentoo is too mainstream in my opinion.


(Ima Wreckyou) #31

Heh, that is a pretty strange criteria to chose a distro if you ask me. :slightly_smiling_face:


(Whitehound) #32

What I mean is that you sometimes have to compile your own stuff, but Gentoo has made it into mainstream. It allows for everything to be compiled, but nobody really needs this. It then doesn’t really offer the flexibility of a self-made script, which performs only very specific tasks and steps. So you’ll only end up making your own scripts again with Gentoo.
I then prefer a normal distro where I can get the binaries, but also the source if I want to compile them myself. However, I pull my sources from git and sometimes choose not the master branch, but some other branch. I then apply my own patches to them in some cases.
Gentoo just doesn’t have that, hence I call it mainstream.


(Ima Wreckyou) #33

Gentoo’s ebuilds can build/install directly from a git branch. An ebuild is nothing else than a build script with a library of useful helper functions called by the package manager which handles dependencies, sandboxed compilation, and tracking of installed files so you don’t pollute the system.

But by all means if you like custom scripts then use them :smile:


(Whitehound) #34

Thank you! :wink:


(Tom Schlong) #35

Version 1330184 worked for me as well.


(Alyx Graff) #36

I found the way to bring all to work.
At first I wondered that after switching to development version and restarting the launcher it switches back to beta. Then I’ve saw that after switching to development it restarts first time and the version is correct 1330184, but for some kind of reason it switches back to beta and asking to restart again, after I agreed to restart the version was 122XXXX.

So the true way is:

  • Start the launcher
  • Switch to the development version
  • Say yes to warning about using development version
  • Say OK when the first restart is required
  • After restart - say cancel to restart request
  • And here we go, logging in successful

White screen after "Log in" press
Blank screen after trying to log on
(delihla Badasaz) #37

Thank you, this worked for me as well


(Terminal Corpse) #38

workaround form Alyx works like a charm…


(CCP Bartender) #39

It would be nice from CCP that she give a clear statement about the linux launcher and when she are not willing to support them, then a statement, that the linux launcher are no longer usable.

Hey all, just to helicopter in and let you all know what’s going on:
a) the linux launcher is, and always has been, an unofficial side project that a few linux-using devs have run during their spare time. It is not supported by CCP, which means it’s not guaranteed to be up to date, and the GM’s can’t help you much if you have issues.

b) I’m taking up the torch from CCP Snorlax, but I will literally be working on this in my spare time, kicking off builds at like 9pm. That means I won’t be working on it every day or even every week, but I’ll put in what I can, partly because I use it as well and partly because I believe linux support is worthwhile.

c) I’m working on an updated build now, but I can’t give any timeline at all. I’m porting the whole shebang forward 5 minor revisions of QT and moving the build chain to base on 16.04 at the same time. If I understand the situation correctly this will fix the ssl symlinking issue, but to be honest I’m re-learning skills I haven’t used in about 4 years so we’ll see.


(Alyx Graff) #40

Thank you for having at least an opportunity to run eve on Linux. And it’s great that at least somebody does it.
I would buy you a beer at a meeting for what you are doing :slight_smile:
Waiting for fixes.
Thanks!