Omega state not showing?

I just tried logging into my accounts for daily maintenance.

5 of the 6 accounts are on year subs for Omega.

All of them showed as Alpha. Anybody else having this issue?

Same problem

Same issue.

same problem here. my two accounts have omega time on them, which shows in launcher, but when logged in, alpha clones with my skills queue stopped.

Same problem.

Same to my account.

Same problem

Cloudflare has been having problems. May be related, as CCP use Cloudflare.

I’m mostly annoyed by CCP not communicating. Give us a status update & tell what is happening.

Looks the problem has already solved.

but I still can’t use ships that required omega status. they are unavailable like as for alpha.

it is ok now

Still doesn’t work for me. Can’t use T2 ships, nor do any manufacturing of T3 components

Or is this the promissed “great new game experience” which also requires 2 more MCTs??

1 Like

Cloudflare has just posted a blog on this morning’s outage:

1 Like

Cloudflare should give us all free stuff :rofl: :rofl: :rofl:

1 Like

Ok. In the past, when EVE online was unavailable, the people with paid accounts were compensated for outages.

So… Where is our stuff?

Get over it, its their discretion to give free stuff.

Entitled kids in every game I guess, I thought eve’s avg age was higher than normal.

1 Like