OpenSUSE Leap 15.2 installation success

Here is my recipe I used today to install EVE Online in OpenSUSE Leap 15.2
It worked flawless for me™, no workarounds, and all through winetricks!

I did a fresh install today of OpenSUSE Leap 15.2 and added some extra software including EVE Online.

Used Yast to add openSUSE repository: Emulators

got wine (v6.23) and dependencies
it installed about 80 packages:

  • wine 6.23
  • wine-32bit 6.23
  • wine-mono 7.0
  • winetricks 20210825
  • wine-gecko 2.47.2
  • dosbox(???) 0.74.3
  • dxvk 1.9.2 (Yes D3D to Vulkan)
  • dxvk-32bit 1.9.2
  • fontconfig-32bit 2.12.6
    and a bunch of alsa/pulse/gstreamer32/libs

system was updated, NVidia drivers 470.86 x86_64, wine is a fresh clean install.
(I don’t know if this can be reproduced by removing old prefixes to have a ‘clean’ wine.)

Used a webbrowser, go got and downloaded to my ~/Downloads to pick up later:

  • MS Visual C++ 2015-2022 redist.(x64) 14.30.30704 aka msvc-170 (VC_redist.x64.exe)
  • EVE Online Launcher (EveLauncher-1972288.kwVW2QGjTYijO0DyO8c98A.exe)

Then started winetricks and got used to a warning about 64bit that a lot of wine is drunk in 32bit
I hadn’t run or configured anything wine before running the 1st time using winetricks.


  • Create new prefix, arch 64bit, YOURPREFIX name

  • select YOURPREFIX in the main winetrick menu, be sure to stay within YOURPREFIX

  • Install a font > corefonts (a lot of same 64bit warning with every other font)

  • Change settings > videomemorysize=2048 (or as large your GPU has room for)

  • Change settings > win10

  • Install a DLL or component > d9vk Vulkan D3D9/10/11latest (43 as of this day of writing)

  • Run explorer (from winetricks within YOURPREFIX) to install MS Visual C++ 2015-2022 redist.(x64) 14.30.30704
    typically C:\users\YourUserName\Downloads\VC_redist.x64.exe (not a big install)

  • Run explorer (from winetricks within YOURPREFIX) to install the EVE Launcher
    typically C:\users\YourUserName\Downloads\EveLauncher-1972288.kwVW2QGjTYijO0DyO8c98A.exe

From here my launcher was ok and I didn’t log in before the big EVE-client downloads were finished.
Launcher unpacking files OK, Launcher purging files OK,
Copy/Paste verification code into Launcher OK, Log in OK,
Immediately launched full screen, no windowed mode needed!
Client authentication OK, claim rewards OK, music OK
Redeem items OK, Station loaded OK, Models loaded OK, Ambient sounds OK
Chat and openening closing channels OK, Info OK, Market OK,
Undocking and ratting in high quality settings OK, All visual and sound effects OK,
Switching characters in client OK, Quits and restarts OK

I’ve made EVE work in linux a couple of times with workarounds,
but I never had such an easy and flawless install before :stuck_out_tongue:

Rock on. Nice to hear some good news around here for once.

:lizard: :+1:

After succesfullyinstalling EVE in a clean wine I’ve been through a couple full clean OS installs for comparison purposes, sigh… …and concluded that MSVC does not need to be installed in wine v6.23 in order to run EVE! :slight_smile:

Every full OS install was from the OpenSUSE Leap 15.2 DVD and added:

  • Main repo, Non-OSS repo and their respective update repos enabled during the installation.
  • selected Generic Desktop with XFCE and Office functions in the installation process, no Mesa-driver-nouveau (have NVidia)
  • set network, keyboard, time… lalala
  • add a normal user other than root, sit out installer, automatic reboot upon completion
  • installed NVidia drivers through adding community repo in YaST Software and Accept, install and reboot
  • YaST Software search for wine shows that OpenSUSE Leap15.2 comes with wine 5
  • get wine 6.23 by adding the OpenSUSE Emulators repo in YaST Software by specific url:
  • YaST Software search wine after adding the Emulators repo now finds wine version 6.23
  • select wine package and Accept and install it and its dependencies including winetricks
  • Downloaded EveLauncher*.exe in ~/Downloads
  • don’t touch anything wine, no need to reboot again

This is the basic desktop user install that I’ve tried a couple times over:
Every attempt is a clean new OS install.
My best attempt is the last one, attempt 3.

Attempt 1 (straight for EVE):

  • start winetricks
  • Select the default wineprefix, no to statistics
  • Run explorer to navigate
  • My Computer c:\users\username\Downloads\Eve-Launcher*.exe
  • open Launcher it also says (Update for Universal C Runtime in Windows will be installed)
  • error KB3118401-x64.msu > retry? ignore? cancel? > retry same error > ignore
  • Launcher starts, downloads, unpacks don’t click or type anything
  • click Already have an account, Log In, lucky I din’t click early…
  • program error QtWebEngineProcess.exe needs to close > open Launcher again > click, same error persists
  • winetricks>default prefix>change setting>win10, no effect
  • winetricks>default prefix>run explorer>install MSVC, no effect
  • winetricks>default prefix>install fonts>corefonts, Launcher OK client OK in high settings
    Apparently the Launcher needs corefonts for QtWebEngineProcess.exe to work
  • winetricks>default prefix>change setting>videomem=2048, (plan to do nothing next attempt)
  • winetricks>default prefix>WinDLL/component>d9vk(latest), graphics improved, smoother and better effects

Attempt 2 (it start adding up):

  • start winetricks, no stats
  • winetricks>default prefix>install fonts>corefonts
  • winetricks>default prefix>run explorer
  • My Computer c:\users\username\Downloads\Eve-Launcher*.exe
  • open Launcher it also says (Update for Universal C Runtime in Windows will be installed)
  • again error KB3118401-x64.msu > retry? ignore? cancel? > retry same error > ignore
  • The Launcher starts, this time I can click log in, even during downloading
    Confirmed corefonts are needed for the EVE Launcher
  • a previous ignorable error was reproduced, try install MSVC…
  • winetricks>default prefix>run explorer
  • My Computer c:\users\username\Downloads\VC_redist.x64.exe, opens installs
  • Launch EVE again, ignorable error persists, MSVC has no effect
  • winetricks>default prefix>change setting>win10, ignorable error is gone
    Didn’t try win10 setting after installing the corefonts in Run 1 eh…
  • no videomem change this time, launcher and client still ok, high settings
  • winetricks>default prefix>WinDLL/component>d9vk, improved graphics again

Attempt 3 (Yes… 3 full new OS installs)

  • start winetricks and select the default wineprefix (everytime)
  • Change settings > win10 and OK
  • Install a font > corefonts and OK
  • Run explorer from winetricks navigate to My Computer C:\users\username\Downloads and open EveLauncher*.exe
  • No errors, installed, logged in, client OK, ratting and technically done.
  • winetricks>default prefix>WinDLL/component>d9vk(latest) bonus graphics for me

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.