phpBB 3.2 EVE SSO / ESI extension [beta]

Ok there’s a couple of things:

First of all in the current version, all founder or admin level users are not even touched by the mod. Second, there might be some changes in the API I had missed so far.
Third problem is the checking cron job. Theres two ways how to execute it, one is ajax calls whenever your site is visited which is not very reliable. The scond option is to let the system run the job, which can be done in you case and is definetely the better choice.

Ok heres a new version:
https://bitbucket.org/snitchashor/php-ext-authevesso/get/v1.2.5b.zip

This one handles also admins and founders but only updates their groups, which are handled by the mod. They will not be deactivated by the mod, even if the API access is revoked.
This one has a completely new interface to ESI.
This one also handles default groups (Will set corp group as default, alliance if no corp group is found)

Next would be to figure out if the cron is working, this can be done by running the following from a shell:

/<path to your phpbb install>/bin/phpbbcli.php cron:run cron.task.groups_check

If that works I recommend to setup a real system cron job:

Go to ACP->general->server config->server settings and select “Run periodic tasks from system cron”
afterwards add the folowing to your cron_table (this example would execute every 15 minutes):

*/15 * * * * /<path to your phpbb install>/bin/phpbbcli.php cron:run >/dev/null 2>&1

Don’t worry to much about the 15 minutes, the individual tasks have their own timings.

Bests,
Snitch

The account I had issues with is an admin/founder, that may be the issue.
I’m trying 1.2.5 asap.

Will corp and alliance displayed under user be updated too ?


Installed and tested.
The said account still display it’s old corp/alliance
I cannot run the cron from CLI :

image


I got the system cron set up and the phpBB setting to system from now on


Cron ran once lock was over, the corporation has been updated !
Looks like everything is fine now, once again :slight_smile:

Thanks for your help !

Glad it works now. The info below user names is using the same information. The cron lock may be due to the job already running or a previous error, which blocks for a certain amount of time. This may happen if the cron is executed during downtime but as long as the cron interval in the ACP is a multiple of an hour this will happen just once.

Roger that.

If you need some help to test things at some point, let me know I’ll be happy to help

Hello Snitch,

Found after the update to 1.2.5b new users are being added to the phpbb_user_group twice…
Any ideas?

Hi,

probably something I introduced with the default group handling, I knew I shouldn’t have touched it. Any chance the users for which you see this are the ones which don’t get a corp or alliance group assigned?

Apologies for the late reply, was on a weeks leave. They actually do get a corporation and group assigned (which should be the default group as well)

Registration is only for the specific corp, registered members are then placed into a corpnamegroup. (Which I would then manually set to default). It appears it does set it automatically to default now, so that is working but also creates the 2nd duplicate in de dB

So they are added to the default ‘registered members’ group twice or the corp group?

The corp group that is, “registered users” is just fine

Running the latest version. Installed great and works awesome! Thanks for the extension.

Can’t wait to figure out how to implement the other Scope items.

Hello everyone, I’m looking for help with the installation of this extension as I don’t speak English, it would be nice if someone could explain it to me in German, the pre-installation is already done (module is installed, but not activated yet), but unfortunately I don’t know what I have to adjust (groups) etc…, as I said it would be great if someone could explain it to me, ingame Seriph Null, or Schnullibulli. Thanks a lot!

Hello, i have installed a new clean version with 1.2.5b with phpbb 3.2.7 and php 7.1 and MySQL(i) 5.7.27

I have some problem with auth :

Informations

Error: Invalid auth state.

Can you help me please

Any chance you can PM me your board url?

Will you be updating the extension to support the latest ESI updates and phpbb updates, including the new feature update 3.3?

Latest master on bitbucket works for phpbb 3.3 but is not yet tested a lot.

SNITCH! First, thanks for all your work, @Snitch_Ashor !

I just updated to PHPBB 3.3, PHP 7.1 and EVESSO 1.2.6. I am getting the error:

**[phpBB Debug] PHP Warning** : in file **[ROOT]/ext/snitch/authevesso/login.php** on line **125** : **array_flip() expects parameter 1 to be array, null given**

It seems this $this->config['snitch_authevesso_scopes'] is empty. I’m not sure where it should find that so I can’t confirm it is getting set. I know that I do have all the scopes listed configured in my EVE Application setup.

Do you know what’s happening here? Or can you point me to how that config parameter is set up so I can see why it’s not loading?

Thanks!
-DC

Can you access the config page of the mod? Thats where the scopes are set.

Im getting this odd thing whenever i try to enable this thing ? phpbb 3.3. php 7.2.30

phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.

Exception: The file “/home/dh_698vcz/dab-online.net/board/ext/snitch/authevesso/config/auth.yml” does not contain valid YAML: The reserved indicator “@” cannot start a plain scalar; you need to quote the scalar at line 5 (near “- @dbal.conn”) in /home/dh_698vcz/dab-online.net/board/ext/snitch/authevesso/config/auth.yml (which is being imported from “/home/dh_698vcz/dab-online.net/board/ext/snitch/authevesso/config/services.yml”).

#0 /home/dh_698vcz/dab-online.net/board/vendor/symfony/config/Loader/FileLoader.php(90): Symfony\Component\Config\Loader\FileLoader->doImport(’/home/dh_698vcz…’, NULL, false, ‘/home/dh_698vcz…’) #1 /home/dh_698vcz/dab-online.net/board/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(195): Symfony\Component\Config\Loader\FileLoader->import(‘auth.yml’, NULL, false, ‘/home/dh_698vcz…’) #2 /home/dh_698vcz/dab-online.net/board/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(127): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->parseImports(Array, ‘/home/dh_698vcz…’) #3 /home/dh_698vcz/dab-online.net/board/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load(‘services.yml’) #4 /home/dh_698vcz/dab-online.net/board/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder)) #5 /home/dh_698vcz/dab-online.net/board/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder)) #6 /home/dh_698vcz/dab-online.net/board/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder)) #7 /home/dh_698vcz/dab-online.net/board/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder)) #8 /home/dh_698vcz/dab-online.net/board/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder)) #9 /home/dh_698vcz/dab-online.net/board/phpbb/di/container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile() #10 /home/dh_698vcz/dab-online.net/board/common.php(115): phpbb\di\container_builder->get_container() #11 /home/dh_698vcz/dab-online.net/board/adm/index.php(23): require(’/home/dh_698vcz…’) #12 {main}

Hey,
I downloaded the zip via wget to my server and unzipped it. After this, I moved all files to phpbb root, but there is no folder /ext/snitch/authevesso…

When I check another folder, for example adm/style/, then I find files with evesso in it.

In admin interface there is no option to activate the plugin.

What am I doing wrong?

EDIT: I don’t find the folder /ext/snitch/authevesso/ in the .zip file on my windows pc.
EDIT2: I also tried cloning the latest files, but still no folder and no sign in acp.

Kind regards
eXeler0n

Testing this out, everything went smooth up until I hit “Test SSO login”. I get a 404, tried different browsers, deleting browsing data. Hmm,