PI Factory Bug? Lost products?

I’ve created a (beautiful) P2 creation setup that looks like this:

It creates 6 types of products, and I load it with exactly 2000 or 4000 of each item (4000 for items that are needed in two recipes).

It should pump out exactly the same amount of P2 products, but I’m getting output like this after a day or so:

(well, I guess I can only post one image per post, but this screenshot was showing my P2 items in inventory, but they’re all different quantities instead of exactly the same: 20, 53, 42, 33, 43, 48)

The factory setup has routes from all the factories TO the launchpad, and FROM the storage to the factories. I expedite transfer from the launchpad to the storage when I drop off. I do notice I get some weird behavior around that, though… Like error messages “the products don’t exist”, but then when I try again it works fine.

What gives? Am I losing products somehow/somewhere?

If you look at your advanced processors you’ll probably find the missing material - perhaps they have one ingredient but not the other. This is quite likely if you are using the same ingredient in multiple processes. I’ve never tried to produce 6 items but I have a couple of factory planets making P3 and they were unbalanced after the first production run but evened out after the second run.

My preference is to use multiple launch pads rather than a storage unit - for lower level PI up to P3, each processing stage reduces the volume so you can route your finished goods back to the same launchpad that provided the materials. Expedited transfers used to be a royal pain in the posterior - not sure if they changed that in the PI refresh a couple of years ago - it’s longer than that since I’ve had any reason to do one!

The issue is that they “shouldn’t” be able to. There’s exactly 4 advanced processor for each recipe, and there’s exactly the same ratio of input materials. To simplify - lmagine a planet with 4 factories producing the same P3 item. If I put in 1000 and 1000 of the ingredients, it should produce some amount of P3s. If I have a second identical planet, it should produce the same amount… In this case, it’s not, for some reason.

All of your factories are working so it doesn’t appear to be a routing error. The only other possibility I can think of is one or more of your links may be overloaded. If you have some leftover power you can add additional links - cross connecting to provide alternate routes. Your launchpad in particular needs to accept the output from 24 factories through a single link. I’d try linking the closest factories to it directly and maybe linking the ring of factories around the storage unit to each other if you have enough power.

The link between the launch pad and the factory is upgraded to level 10 (for fast expedited transfers if I want to load up the launchpad and storage unit.

All the links are at about 1% utilization… Even so, that shouldn’t explain product loss, just inefficiency. All of the input materials are consumed - but the outputs aren’t even as they should be. It appears random.

i’m having a similar problem. I’ve got one extractor set up routing 24,044 quantity ( units is suppose ) @ 480.9m3/hour ( upgraded trying to resolve this ).
The extractor is routed directly to a storage silo and confirmed its got incoming 24,044.
So, this should be enough to power 24,044 4 factories with excess but i’m getting ‘waiting or resources’ on my factories and no excess raw material.
I’ve deleted, recreated etc etc but still no joy.
Any ideas?

Don’t know. When PI throws away product it generally means it’s routed incorrectly or the destination doesn’t have room for it. I recall that I needed to track down a couple of routing errors when initially setting up my own factory planets but, once that was fixed, they’ve been working properly for years.

Ok… what am I doing wrong? Look at the following images, posted in order. I go to the station to pick up my Tier 2 (there’s a little bit of Tier 1 still in there en route to the factories). I try to put it in the POCO and then put it into my ship and it *(@#'ing DELETES half of it!

Also - Why did the spaceport just “fill up” with my initial load? (note the piles of 2000/4000 now filling it up) - Yesterday I expedited transferred those out of the spaceport.

The lower 3 images show the launchpad at capacity 9999/10000. My guess is something went wrong with your expedited transfer - leaving your launchpad way over capacity as you added your P2 product but the game didn’t notice until you tried to export them.

That’s probably enough of an edge case that it could escape notice for 2 years! I would submit a bug report with all this information.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.