Planetary Production broken, cannot make changes, can only reset extractors


(Jinn Esubria) #1

Planetary production seems to be broken. Tested on 3 characters (all in Perimeter if relevant). I can only reset extractors and successfully submit changes,. If I make any other changes, like trying to change the number of heads on an extractor then the changes cannot be submitted. You just get the “The planetary communications system is busy. Please wait x seconds” error message.


(Aby Stargaze) #2

Had the same bug for several days now


(Wraith Ormond) #3

My experience also. Logging helped. Would be nice to have it fixed properly though.


(Do Little) #4

I’ve also experienced this problem. Decommissioning and rebuilding an extractor allowed me to save. I’ve encountered the problem twice in about 40 planets over the past 2 days so it’s not consistent.


(Dirk Kajhone) #5

It’s been fairly consistent across my 4 PI characters that:

-If I just stop, start, and submit it works. (Resets the timers on my current extraction)
-If I stop, move extractor heads, restart and submit, it works 9/10 times.
-If I add or remove heads from an extractor, or change any facilities, so far on 4 out of 4 planets I got the “Planetary network busy, please try in 2-3 seconds” message, on 2 different days. I haven’t tested it on other planets.
-This is the same both on an Omega account and an Alpha one.

Someone pops into English help with this issue every couple hours, and at least one person trying out PI for the first time said he was doing everything as the video showed, but could not place a Command Centre on his (lava) planet. Unsure there if it is a related issue or something odd a first-timer was doing.


(Buoytender Bob) #6

Add me to the list where extraction modifications cause pop up of “planetary network…”. Have to trash extractor and reset…Not fun.


(Nuentiger) #7

I have the same problem on 2 accounts.


(erg cz) #8

“me too” :frowning:


(Tom Karanadon) #9

Same for me, resetting extractors still works but changing the extractors (i.e. adding and removing heads) leads to me unable to click through the submit button.


(Flack Keikira) #10

I have been having this problem most of the time on my Flack Keikira character since Saturday, whose planetary production is in A-ZLHX, but haven’t yet had problems on two characters who have planetary production in Centaur. Logging off and on hasn’t had any effect that I can tell.

Thanks to the OP for at least pointing out that I can just-reset and it’ll actually go through with submitting.


(Wraith Ormond) #11

Agreed. Subsequent to my earlier post, I haven’t been able to fix the problem via logging out and back in.

Currently, I can make it work most of the time if I remove a head from one extractor, then submit that change before applying the head to the other extractor and subsequently submitting that change. When all else fails, I’ve found stopping the running program on each extractor, submitting that and then setting my extractors back up also works. It is a right pain in the arse though.


(Kyliez Kyle) #12

It’s been 4 days and not even a reply from CCP that they even admit there is a problem and are looking into it.
Do they even read these comments


(Dirk Kajhone) #13

I’ve seen some people mention ‘workarounds’; such as just keep submitting, do it all once, cancel, do it again and submit, or simply delete anything you are going to change, submit that, then re-install from scratch.

I have tried each of these methods to some extent (short of deleting keys facilities and rebuilding from scratch). None of them have worked, I can’t save anything other than stop, move extractor heads, restart.

How many times/how long do you re-submit (if that worked for you) or what is your pattern of try/cancel/re-try? Does this work on all of your planets or only some?


(Nathaneal Prescott) #14

Same thing is happening to me. Steps to replicate the bug:

  1. Start extracting on an extractor by hitting submit
  2. Go back to the extractor, stop extraction and make changes to the number of extractors (I have not tried it with just moving the extractors around and not changing the number of extractors).
  3. Start extraction
    4.Press submit. Nothing will happen. If you press submit multiple times, it will give a message about the communications network being busy and retry in 1-4 seconds.

Previous to the changes in the expansion, this process was allowed. I am not decommissioning my extractor control units and rebuilding new ones–that is a waste of isk. Please correct this situation as soon as possible. Thank you in advance.


(miridio) #15

Same issue here.
Managed to move one extractor and have 2 heads working - not sure how…
But still cannot delete heads from the other extractor and attach them to the one smack down the center of a nice white area…
Besides the whole PI “update” is bad and PI now takes much more time than before :frowning:
Without reason focus shifts to the extractor information window and have several times stopped and started the extractor I just had completed.
getting trafic sick from the zoom in - and why have they not made a usefull update, where zoom is on the launch pad, which is 9/10 times closer to the extractors than the command, which quite often is situated on the other side of the planet, where the PI was initially started ?
Why do we need that graphic window taking up all the space? We know what is going on, on the planets…
Also tired of all that hovered information.

CCP, please reset to how it was before…!


(Jinn Esubria) #16

Basically once an extractor is created, you cannot change the number of heads and successfully submit. You have to delete the extractor, submit, then recreate the extractor with heads, then submit again.


(Helge Caldari) #17

I have made a bug report, not sure if anyone else done that. The more the better?

This is starting to be pretty annoying

Status on the bug report: Attached: This report has been linked to an active defect.


(Nunosh) #18

@CCP_Falcon do you have any news about this?


(Jinn Esubria) #19

So to add some addition information on this. I found out that if your extractors have completely timed out and finished their cycles, you can change the number of heads, but if you are trying to change it while the cycle is still ongoing, it give the communications error.

All my extractors timed out today and I could make changes, but then if I tried to edit them again after starting their cycles back up it wouldn’t work at all.


(Jinn Esubria) #20

Extractors seem to be fixed today. I was able to change the number of heads on any of my extractors. Whatever was wrong on the backend on the server seems to be corrected. Can anyone else confirm they are also working fine today?