Rocky Ridge Mine

Hey there, maybe this is a stupid question but it would appear I am missing something. I have an opportunity called “Rocky Ridge Mine”, the text of which is “Visit the Rocky Ridge Mine in The Forge”. I have accepted it, made it the 26 jumps there and found the beacon in the Ishisomo System. But when I get there, nothing happens. I can’t interact with the beacon, and there is nothing to do there. There are a couple of nearby asteroids but mining them does nothing (except give me some Veldspar).

Any ideas? I would just abandon it but it took a little while to make the 26 jumps ;). I’ve tried googling and searching in the forums but can find anything.

Is your overview working to show large collideable objects?

1 Like

You might have to approach one of the objects in the site, which is why Geo Eclipse mentioned switching on objects. Look for something called the ‘mine’, maybe.

Could you perhaps copy and paste the entire mission text here? (or do a screen capture) I have not done that particular mission yet, and it will help us see what is required to complete the mission.

I’ve not done opportunities either, but overview was my first thought on something not seen on grid

1 Like

These opportunities look like they’re buggy: I tried the “mine and reprocess 15k m3 Pyroxeres” opportunity in a new char recently, but nothing happened either, so I just switched the opoortunity part off.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.