Strange FPS drops when switching ammo types (and performance hit thereafter)

I’m getting this strange ‘bug’ that occurs mostly at random times when running Incursions. I can’t say I’ve noticed it when doing any other activities such as missions, exploring or just general day-to-day stuff, but it’s possibly not related to Incursions but rather related to fleet ops.

Anyway, basically what happens is after about 30 minutes to an hour of playing (sometimes it never happens), suddenly my FPS starts taking hits. It drops significantly from a relatively smooth performance, using max settings on an RX580 8GB with a Ryzen 3600 and 16GB of DDR4, installed on an Samsung 850 SSD. The FPS drops are at their worst when switching ammo types (from Null to Void, vice versa) in a Vindicator. It’s possible this happens with other ammo types, but I haven’t done any tests to see yet.

The whole client lags for about 2-3 seconds when switching ammo, dropping frames down to 20-30 fps and staggering back up afterwards. HOWEVER, after this starts to happen, the whole client becomes somewhat choppy thereafter. I have to literally restart the client to fix it, nothing else works. I’ve tried changing resolutions, changing to full screen, lowering graphic settings, turning off any and all effects, turning off brackets or just running in potato mode. Nothing fixes it, the frame drops still happen. So I’m guessing this is somekind of weird bug. It SEEMS to be triggered by switching ammo, but it’s possible that is just the most noticeable part of the bug. The performance hit is also noticeable even without switching ammo, such as when rats spawn or when dropping drones.

I’ve also tried switching intervals or other tinkering, but nothing seems to work. I’ve re-installed EVE and reset everything, but it started doing it again. The only time it seems to start happening is during fleets. When I’m just doing stuff by myself, it doesn’t happen. Maybe related to the broadcast window? I have no idea where to start with isolation of this bug.

What’s your operating suystem, and how much memory do you have ? I had a similar thing on my ancient Linux PC, which was cured by upping the memory from 8gb to 16gb (it was ‘thrashing’ virtual memory).

Yes it is Linux - but I’m not 100% sure this is a Linux issue. I’ve seen this mentioned before when searching for a similar problem.

And I’ve actually found a way that stops it - strangely, after it starts happening, all I have to do is open the fitting window and press ‘simulate’ then the problem magically goes away. Weird.

Does your linux build have a System Monitor ? That’s how I found out my problem was ‘thrashing’, and that I needed more memory.

Intriguing. :thinking: