Testing Result for Beta EVE Launcher

Patches are still in the review queue and Alexandre Julliard announced a code freeze in the next few weeks for the upcoming 7.0. I’m going to keep trying to get the patches upstreamed but I’m going to additionally request that they get included in wine-staging, which should hopefully be a faster process.

2 Likes

The patches were accepted in upstream wine!!!

https://source.winehq.org/git/wine.git/commit/ef26f7bd5cf36806f7b465dc1942ab6a2e0541b9

Wine 6.23 will have the fix for the launchdarkly BS :slight_smile:

6 Likes

What wine staging?
I’m using Wine 6.22, launcher version 1967440 installed using Steam and the launcher works fine but the game doesn’t start. The exefile.exe just sits there using 35% cpu and 400mb ram without opening the game.
I’m on Ubuntu 21.10

Sounds like the launchdarkly_client.pyd bug.

Locate launchdarkly_client.pyd in your EVE/SharedCache/tq/bin64 folder, copy it to the EVE/SharedCache/tq folder and set the copied file to read-only.

1 Like

It worked but the next issue is the game performance which is not there. In windows i get 40-50fps and in Linux 4-5fps.
I’m using a Radeon HD 7750 which is quite old but i don’t know. it feels like the game is not GPU accelerated.

Do you check your FPS ingame with CTRL-F? That should tell you what is used to render the game.

You have to install DXVK to get a decent framerate, I posted instructions somewhere on the forums here for how to do that. Alternatively I think Proton has it built in but I’m not sure

1 Like

Under directx9 the fps doubled, it’s 9-10fps. :smiley:
The ingame fps counter shows: dx9/ ATI Radeon HD 5600 Series / SM_3_0_HI

I’m kinda new to linux and i don’t know if i installed everything right. To start the Eve launcher i right click and chose open with wine program loader.

Here is some GPU info and i don’t know, i’m gonna look into it, maybe i don’t have the proper drivers or maybe the GPU is not supported.

VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] [1002:683f]
Subsystem: PC Partner Limited / Sapphire Technology Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] 
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

client glx vendor string: Mesa Project and SGI
OpenGL core profile version string: 4.5 (Core Profile) Mesa 22.0.0-devel (git-3b15fb3 2021-11-24 impish-oibaf-ppa)
OpenGL version string: 4.5 (Compatibility Profile) Mesa 22.0.0-devel (git-3b15fb3 2021-11-24 impish-oibaf-ppa)
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.0.0-devel (git-3b15fb3 2021-11-24 impish-oibaf-ppa)

See New launcher... new Linux error? - #375 by Renard_DuGaulle

I recommend not using steam as it complicates things somewhat and doesn’t gain you much. That guide should walk you through setting it up with the upstream installer. If you need features from steam it’s doable but since I don’t use steam I won’t be able to help you set it up

Proton should indeed have DXVK support built-in.
I am used to start my steam games through steam, so I am not sure if running EVE directly with wine is circumventing that somehow? Can you try starting EVE with steam?

Also for checking if you have vulkan installed run this in your console:

vulkaninfo

I couldn’t start Eve from Steam, it won’t launch the Eve launcher.
Didn’t have vulkan, now i have it.

Followed the guide to use it without steam but the performance is way worse. It’s using LLVMpipe which doesn’t seem right.
Screenshot from 2021-11-25 00-41-38

IIRC llvmpipe means it didn’t find a device it could use and fell back to CPU rendering. Do you have vulkan drivers installed for your video card?

This seems to be a Linux problem and not a Eve problem. My config is broken or the GPU is not supported, i don’t know for sure, need to look more into it.

Seems like vulkan doesn’t recognize my GPU and it’s only using software acceleration(LLVM).
I tried removing the lvp_icd.x86_64.json and lvp_icd.i686.json from /usr/share/vulkan/icd.d to force hardware acceleration but then the game won’t start, maybe because there is no physical GPU listed there to fall-back to.

Device Groups:
==============
Group 0:
	Properties:
		physicalDevices: count = 1
			llvmpipe (LLVM 13.0.0, 128 bits) (ID: 0)
		subsetAllocation = 0

WARNING: lavapipe is not a conformant vulkan implementation, testing use only.
	Present Capabilities:
		llvmpipe (LLVM 13.0.0, 128 bits) (ID: 0):
			Can present images from the following devices: count = 1
				llvmpipe (LLVM 13.0.0, 128 bits) (ID: 0)
		Present modes: count = 1
			DEVICE_GROUP_PRESENT_MODE_LOCAL_BIT_KHR

Full vulkaninfo: vulkaninfoERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_r - Pastebin.com

This may help. I think only fedora has default AMD, Ubuntu has default Nvidia if not mistaken.

I manage to fix it by editing grub and force amdgpu (newest linux drivers) instead of radeon (old drivers which may not have vulkan support)
(how can I use "amdgpu" instead of "radeon" drivers on 20.04? - Ask Ubuntu)

It’s working fine now, 15 less fps than in Windows and get a little static cracks. Graphics pipe is at 50% so might be more CPU bound.

2 Likes

amdgpu ftw.