"The socket was closed" fix


(Tar Jaynara) #1

In my case, I found solution.
Very simple.
First of all check if your case is the same to my.
Case:
1 - You must be disconnected from all chats.
2 - Your corporation must be consists only from your characters. It will prevent you from receiving messages from other people.
Effect:
After 2 min logging in to the game you get “The socket was closed”.
Solution:
Just connect to some Help chat to receive messages constantly.
Or
Make many waypoints in your router and use autopilot.
I hope I save some people nerves and time.

From my viewpoint, all characters must be connected to some “live” game chat by default to avoid problems like this. Like in WoT all characters are connected to General Chat.
So then why I don’t loss connection in WoW then I run some dungeon alone, without to be connected to any chat.
And I hope devs will stop posting what “The socket was closed” issue is only player side issue.
Nope guys it is your game issue.


(Linus Gorp) #2

Now if only you had the slightest clue about how networking works…

Found the problem.


(Sir Constantin) #3

I don’t know much about networking but you have some network problems or your router is timing out the connection too fast.


(Tar Jaynara) #4

Oh sry I fogot this game for sciensticks, any other knowledge I must have to play this game?
I am in doubt now what other clue I must have.
Can they (devs I mean) add all requested knowledges’ list befor ppl start download this game?
And what do you hate besides WOW?
Incidentally. I very fond of WOW :slight_smile:


(Tar Jaynara) #5

I don’t have any connection trouble in any other game except this one.
And like I posted before connection to any “live” chat solve my issue.
Hope this solution can help others guys.


(Rina Asanari) #6

Thing is, EvE may be the only game in your collection that works fine with long stretches of silence on your TCP connection to the server. That could happen when there’s absolutely nothing going on in space and on the station you’re on and you aren’t talking.

Maybe the TCP connection to the chat engine is handled separately, on top of it. So just by being silent it would mean nothing happens.

If your router or your ISP deems it okay to cut TCP connections when they’re idle, change the settings, if possible, or switch out the router or ISP if not. Because that clearly violates standard behavior.


(Tipa Riot) #7

My symptom is: if I’m AFK for a while or minimize the client, and then I come back later it eventually closed the socks. This so far doesn’t happen that regularly when I’m actively playing. Keeping the help channel open is not a reliable workaround.

This is a relatively new phenomenon, it started a couple of months ago, and as I’m not a cloaky camper this is not a show stopper for me, but forces me to keep docked when AFK. Is there any solution? A setting I can make?


(Sanych Sukarala) #8
  1. I have this issue with one internet provider and don’t have with two others. WIth the same hardware on my side.
  2. No any other game have this or similar issues

So, yes, it does depend on provider network, but also the way EVE client works results in this VERY annoing problem.


(Malidine) #9

I suffer from the same problem ,
I get almost precise every 60 minutes a “socket closed” error but only with 1 off my both account, even when it runs allone. It does not matter if i am flying active in space or if i am docked.

I even tried to join very active chat to prevent , and even made a clean install of eve and deleted all personal settings, i checked all my hardware drivers and they are all up to date.
To be sure, i conntacted even my ISP and my internet line is fine , but for be sure they did give me a new router and i stll have the issue with that one Account. i did send logs and internet connection tests.
My ticket got deleted/closed by a ISD telling me is my problem and have nothing to do with ccp.

When i use other account on the same Computer , all is fine , that makes me sure there is no hardware or connection problem on my part .
I am sure it have to doe maybe with a dumb old item in my assets that i own that tries to load and gets no respnonce and cause lag or something . even maybe the libary where my assets are saved is broken.
i have no clue its not my job to find that error i paid specialist of the games for that game , and hope to soon get a responce and a fix.
my Ticket number is EBR-129905: DISCONNECTS


(Darion Sisko) #10

I am having the EXACT same problem. It happens irregularly, and so frequent its making the game unplayable for me. I am two seconds away from giving up and uninstalling all together


(Hazzel nut) #11

I have the same problem, sometimes its really bad and my “in background and being cloaked characters” are getting socket closed pretty fast, sometimes even my main when i alt tab back to it, is like frozen and everything trys to catch up and runs in higher speed until it catched up. its not all the time like that, and sometimes everything runs fine and even the background characters are staying connected long, uninstalling and installing eve again didnt changed anything.

a friend of mine has even worse problems, he warps to a cita and gets socket closed
he is getting a new router soonish i will report back if anything did change

i dont have an issues with other games, maybe its a combination of the router and the eve client, but the eve client is for sure not completly innocent regarding to this issue


(Omar Alharazaad) #12

This has been happening to me since the latter parts of the summer.
It initially only struck on my second account when it had been idle for a few minutes.
As time goes by it’s gotten worse.
Today I had the ‘socket was closed’ thing happen in the middle of an active PVP fight. To the character that was fighting… clean undershorts were acquired and the lost drones will be mourned, but this happening makes content that involves other players unattractive, as in I don’t want to lose a 2+ billion isk pod to a network derp.
Thing is, my router has taken no issues with any other online game I play… idle time isn’t an issue there.
So, given that bit I can only assume that EVE has something wonky going on.


(Dreadchain) #13

Same problem here. I’m getting a good connection to tranq and I play tens of other games with zero issues. Seems to happen on both my routers, but as someone suggested this could be an incompatibility issue with some ISPs I might try hooking my mobile phone internet into this.


(Dreadchain) #14

It seems Rina_Asanari’s theory seems to apply to my problems at least. The connection is being severed after a short time of inactivity, but oddly this seems to only apply to downstream (tranq to my client). After the client sends a packet to the server, the connection apparently opens which prompts the server to send a bunch of previously failed packets to the client in kind of a TCP retransmission flood. This usually, if not always, results in a “socket closed” disconnect.

The quiet period seems to last even minutes sometimes, although occasionally there’s only a silence of about 10 seconds after which I immediately disconnect.

Oddly enough, when running under DMZ the problem is amplified. Half the time I don’t even make it through the login process without disconnecting. I wonder if my router is doing something to reduce the connection problems?

Unfortunately my ISP is the only one in my area, so I can’t switch. I’m going to talk to them and see if they know anything about that, but I’m not too hopeful. If this has been going on for years I doubt CCP will patch this problem either.


(Tex Walker) #15

at least you can login. I haven’t been able to get past the character selection screen login timing out since wednesday


(Niagara Femme) #16

NOT fixed! Still with the same problem… (huge LAG on gates, jump too)


(Arcin Hamir) #17

I have this issue as well. This used to be a problem years ago and then ‘got better’. For me it happens most often when a session is not active but it also happens on very active sessions. I can have 3 sessions running and all will have socket closed or only one (and not always the least active). I have been with the same Internet provides for the last 15+ years and nothing has changed at that end - so I strongly think something has happened on the Eve end (client or server)


(Buoytender Bob) #18

Just to add info for the issue:


(Seay Prime) #19

Wow! I thought I was the only one!

I had the same issue for a few months now. This is a CCP issue since I play a bunch of other games and use a bunch of net-apps and EVE is the only one with this problem. A while back I kept the help channel open and it seemed to work so I didn’t push the topic further but after the latest (March) patch where the chat system changed the issue amplified and nothing seems to work now. The socket closes after 3-4 mins if idleness on character log-in and same while in game and one of my clients randomly closes after a few mins of inactivity. Even while I was actively fitting a ship the other day, the account I was on oddly closed too! I have tried changing my router, re-installing, changing wifi settings, using all sorts of other software but nothing seems to work. All other games and apps are perfectly fine. The ISP I’m with is the best one in my area with best prices and best connectivity quality. If CCP doesn’t come up with a solution for this I guess my 7 year eve journey will come to an end as the game is completely unplayable under current circumstances.

PS: I have filed a petition and upload a bunch of tests etc… CCP claims the problem is on my side of the connection (where clearly it is not as everything else, including other MMOs work perfectly fine).


(Lumbis) #20

What solved it for me was to use a VPN what an exit in USA (I live in Sweden). Try Tunnelbear, they give 500MB/Month for free. EVE uses almost no bandwidth. Just make sure to download all game data first via launch menu > Settings > Download everything.