Very funny CCP, now, I want my loot

Text wall warning as you can see.

So I wake up at 8:00AM today like “today is a great day to explore!”. So I rush into EVE as the downtime
ends, and quickly complete my dailies, took 2 hours to complete the days Project discovery drawing peni-- I mean cytostome circumscription, because I was semi-AFK watching twitch.tv for today’s twitch drops (3000 EverMarks, yes I actually like those).

Then it was nearby mid-day so I felt hungry and went to buy a small mozzarella pizza in the pub I always go to. Came back, quickly devoured the tasty food, Then jumped into my computer and loaded my Vagabond. Got outta my station and checked nearby signatures; I traced a small lap of 3 systems with 3 signatures each, so I went for it.
The first system contained a wormhole and 2 DED 1/10 combat sites, which the cruiser size is not allowed, so I moved on.
Second system had a wormhole, a data site and a combat site DED 3/10 which I warped to with glee. Killed stuff, the faction boss only dropped a true Sansha copper tag, a faction laser crystal and a loose trash gun.
I moved into the 3rd system, it contained crap and a combat site too low for my T2 cruiser again.

I looked into my map, I was close to the Amarr trade hub, so I went to deposit my loot and replenish ammo.

Then I traced a new route for another 3 or 4 jump with some signatures in them. Barely got a couple decent combat sites outta them, which didn’t drop anything of value neither.

I tried luck with some Den anomalies, which didn’t spawn the faction ship. Decided to extend the route and went several jumps into where-ever to find more signatures. Nothing worth it.

I look at the clock, it’s around 4:00PM and I was a bit tired and stuffed so I decided to stop and go take a small nap.

I woke up at 6:00PM with new fresh air. Back in my home station, I decide to go into a new route to the opposing side of the previous ones. So I went in and BAM! lotsa combat sites, no valuable drop of any kind, by then I got 4 true Sansha copper tags but nothing worth over 1 million ISK.

In the while, I reached an unholy, fake god cathedral full of unbeliever who neutralized the heck out of my capacitor. Then I faced a mob of slavers who kept spamming tracking disruptors on my turrets to the point I had to manually walk to them and try to hit them at 2 kilometers range and still having issues hitting them; I spent over 3 thousand ammo in that site, and I run that site 3 times, (suddenly all rat types spam turret disruption…?). I crossed some rogue drones who were decimated, but in revenge, game me no loot at all…
Left with estimated price of my cargo actually going down due to the consumption of ammo, I’m starting to lose faith.

I did get escalations tho, actually many of them; so I decide to run a few of them that were in high-sec. I went in around 6 jumps for Raise of Nation one, jump into the site and the enemies are like 100km away; I wonder 'sup but see that faction boss there so I went for it. …I kinda miscalculated the thing over there, by the time I realize I wasn’t going to survive that, I manage to kill the interceptors that got me locked tho I lost a precious drone over there (they don’t grow in trees ya know…) and I barely made it out alive. Boss contained nothing of value.

Went for the second part of it, but this time I actually check in EVE university the stats of that escalation and it’s sites. None of them drop any loot unless you decide to fight the cruel mob of expected death, so I decide not to go for it anymore.

I turn around into a Blood Raiders escalation, jumped over 8 jumps, cleared the site, 2nd part of it popped in and it was literally 50 jump away. I checked the route: get into Amarr system, then go into Gallente region, pass nearby Jita, and end somewhere nearby the Minmatar region. By this point I’m starting to feel annoyed…

Chose another escalation, checked it’s resume in the web, and went for it. The resume said the fourth part granted a faction boss which is really likely to drop faction mods and maybe a Succubus blueprint. By now I’m pretty sure the drop rate is very by my side, so I take another 8 jumps into it.
Completed the 1st site, boss dropped crap.
Completed the 2nd site, boss dropped crap.
Completed the 3rd site, boss dropped crap.

So I’m reaching the 4th site in a bad mood, tired and around 10:00PM. Went in, shot the boss down, and I’m approaching the boss’ wreck with a feeling of retribution and hope. The boss actually only dropped 12 slaves… I’m like… wai wha?

Right now it’s past 11:00PM and I feel seriously scammed; got a total of 7 true Sansha copper tags, uselessly and not a single drop of anything worth over 1 million ISK.

In the first days of this week I got loot worth over 600 million ISK completing around 1/4 of the amount of sites I did today.

So, now, seriously CCP, where is my loot!? :rage:

Thanks to anyone who stayed to hear my story; please give me some strength to carry on.

w/<3-Vizk

No Loot for you

6 Likes

Part me wants to say “rng is rng”. But I do have empathy when rng is being being a pita.

1 Like

You must deposit this many PLEX to get access to loot.

1 Like

Welcome to RNG?

In the first days of this week I got loot worth over 600 million ISK

Sounds like its not that bad

Often times Ive noticed that CCP will hand out a lot of isk at first to get you hooked onto an activity and then drop it down, kinda like a decending exponential curve, to the baseline drop rates and then RNG around that. sometimes youll get days or weeks with nothing and then a good drop rate for a bit, sometimes its slow and steady for a while too and then nothing for a while again. In the end it always balances out to the supposed drop rate though.

So yeah no, expecting the same drop rates and isk/hr rates as the beginning is only setting urself up for misery in this game. CCP also does readjust drop rates periodically for things over a longer period of time. If somethings too popular theyll drop the rates so prices can recover etc.

1 Like