64-bit Mac Client, Wine, and YOU

Unable to initiate warp via any method without the 64-bit client crashing. Bug report submitted. Falling . back to 32-bit works around warp crashing issue.

1 Like

Same here. 64-bit client was working fine until today, but today’s patch broke it, making the game unplayable on an iMac with a Radeon Pro 580X running macOS 10.14.6.

Client freezes (rather than crashing) immediately after undocking and initiating warp or shortly afterwards in windowed mode (haven’t tried full screen).

Good thing I can still switch back to 32-bit and that seems to work fine.

EDIT: Actually, I take that back. 32-bit does definitely work better than 64-bit, but I just got a client freeze jumping gate running in 32-bit mode too.

1 Like

Second warp of the day and I crashed resulting in https://zkillboard.com/kill/78904469/

Total bust for me in either 32 or 64 bit mode. Haven’t been able to play at all.

I have not been able to use the normal key short cut for copy and paste. its a dan paine yes.

1 Like

me too.
seems like eve thinks command key is Alt key.

Oh another thing that’s been an issue for a while and I can’t remember if I raised it (feels like I have).

If I alt tab between two characters, randomly when I’m back on either of the characters and start to do anything like type in chat or search for a system, as I type loads of windows pop up (assets, character, ingame email, starmap etc) as if I have the Command key stuck down and I’ve just pressed a Cmd + [key] shortcut . It also invariably puts that character from full screen mode into windowed mode, assume depending on what I type.

I find individually pressing Command, Option, Control and Fn resolves it, but seemingly just pressing Command does not (might be observer error).

Only happens when I’ve alt tabbed (you know Command + Tab) … is there any way to resolve this … it makes it incredibly stressful during fights, to have multiple pop up windows and that character in the wrong window mode. Also, remembering to hit Command Option Control fn between each alt tab is a behaviour I don’t want to get into.

Anyone else get this ?

Hey All,

We’re looking into Mac issues with the September update now.

For this current release, please contribute feedback here: September Release - Known Issues & Feedback (Mac)

64 bit would not launch
-loaded XQuartz-2.7.7.dmg & winehq-stable-4.0.2.pkg

That fixed the launch issue, and then created game freeze at start of warp
-highlight launcher > Eve Launcher > preferences > do the following:
-Version type = Release
-Run clients with 64 bit (checked)
-Use system configuration for proxy (checked)
-Enable hardware rendering(checked)
-Use dev versions (checked under Wine options)
-Wine version = wine-4.4-Staging-winehq-binary-198
-Retina mode (checked)
-Video memory (4096)
-Singularity & Duality (checked)

#Note - You can probably uncheck Retina and leave video memory at Auto, but after hours of trying different versions of wine at various settings I needed a break…& if it ain’t broke don’t fix it

Totally agree with Attidack here. There have been native clients for “indie-esque” games like minecraft (since Alpha), it’s beyond me why CCP hasn’t recruited a team of dedicated Mac developers (or at least consultants) to port the game over to Mac yet.

I do- total PITA

I thought the default client was now 64bit but on my macs the wine process is 32 bit?
I’ve not purposefully chnaged to 64 bit as the time I did try was crap, disconnecting me from Eve for days. Even still on 32 bit I have the key binding issues and stupid dangerous carry over of modifiyer keys when switching between client windows.

So are most mac users now happily on 64bit or is my bad experience commonplace?

Guys, this is frustrating. 64-bit warp bug was present. Switched to 32-bit but it was hanging occasionally, so I followed the forum directions to ensure the 64-bit wine was deleted. Now, the client won’t even launch. Tried uninstalling and starting over, but it still won’t even launch. Nothing works anymore.

I did a different variation on the instructions.

  • Start launcher
  • Click on EVE launcher in the apple menu at the top of the screen
  • Select preferences.
  • Make sure Run clients with 64 bit is NOT ticked.
  • Make sure wine version is set to wine-1.9.17-143-g91037ca-ccp-master-72
  • Click ok
  • Close the launcher and the client if either is running.
  • Deleted Wine folder
  • Ran the launcher
  • Clicked on the Apple and set WINE version to “Most Recent” making sure 64b is unchecked
  • Waited for update-> Then launched the game
    Now 32 Bit mode “Warping” is back on my Macbook Pro Mojave 10.14.6 using Intel Iris Graphics 6100
1 Like

Following those instructions, the launcher will now run the 32-bit client.

I did the exact same thing. Took me 3 hours to get back to where I started.
32 bit will no longer work for me. It did initially.
This is what I did to get 64 bit running again.

EVE Launcher -> Preferences: uncheck “Use system configuration for proxy”
Launcher Window -> Launcher Settings: Run game as 64 bit client.
I also had to -> download full EVE game client.

This got me back to running 64 bit mode again, but now have the Warp Freeze bug again.
I am staying docked, until this is fixed.
I may even cancel my account AGAIN…getting too old and too tired of always waiting.

OK, I followed Luke Bizzy’s instructions and once again run 32 bit.

1 Like

Yep so I didn’t do any frigging around with deleting files or changing settings other than to untick 64bit box in preferences, close launcher and reopen.

For me it has been working fine in 32bit. It’s not quite as smooth as 64bit, but it doesn’t crash/freeze.

If it helps anyone I’m on Sierra 10.12.6 on a Mac Book Pro 2017. Using latest version in launcher settings.

One thing that happens now though, is that I can’t log my main and my alt on at the same time. One is fine, the other launches in a dramatically reduced size at the corner of he screen so is unplayable. I also can’t alt tab between the windows in one move. I have to alt tab to desktop then alt tab to the second character.