EVE-O Preview v5.1.0 "Fua Was Wrong" (multi-client preview / switcher) [ 2021-05-08 ]

Funny question considering you can’t post on the forums if you don’t have ingame character.

I am unsure if it is an alt he posts with.

I guess you can continue with your own life?

That’s my main char.

Odd little bug I found with Eve-O Preview and my weirdo setup:
I have two monitors. The main monitor is 2560 x 1440 and my second monitor is a 1920 x 1080 turned sideways and rotated 90 degrees in the Windows display settings so it is taller than it is wide (so effectively 1080 x 1920). The second monitor is also on the left side of the main monitor. If I create a preview and place it at the top of the second monitor (using negative values in the config file to get it up past 0) then everything works fine as long as I start Eve-O Preview before I start the clients. If I exit Eve-O Preview and restart it with the clients already running or start Eve-O Preview after I’ve started the clients then that first preview at the top of the second monitor will move itself to a lower spot that it wasn’t at previously. It is only the first preview and the others are not affected. Is this related to having to use negative values in the config file for preview coords?

Yes, most probably.
I’ll log this as bug for the next release

2 Likes

Phrynohyas,

Does Eve-O Preview differentiate between NumLock states on the number pad? I would like to be able to retain use of the numpad while also being able to toggle clients by switching numlock state.

Edit: I see that you have previously stated that the “NumPad” binds will only work when numlock is enabled, I don’t suppose the non-numlock keys have been mapped?

SECOND EDIT: Okay I found This Post in which you linked a document with all the key names, but the only numpad listings are for the aforementioned “NumPad” binds… Testing now whether or not End/Down/PgDn etc. work…

Edit the Third: Well that works but it also applies to all the other duplicates of those keys… looks like I’m going to have to break out the AutoHotKey “programming” again…

A FOURTH EDIT HAS HIT THE POST:
Simple enough in Autohotkey to just assign the non-numlock numpad keys to F13-F24, so I did it thataway. Even if I am getting pretty good at multiboxing I don’t think I’ll ever be running 12 clients simultaneously so I think this solution will work out just fine!

For anyone else that wants to do the same thing:

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
; #Warn  ; Enable warnings to assist with detecting common errors.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.

;NumpadIns::F20
NumpadEnd::F21
NumpadDown::F22
NumpadPgDn::F23
NumpadLeft::F24
NumpadClear::F15
NumpadRight::F16
NumpadHome::F17
NumpadUp::F18
NumpadPgUp::F19
;NumpadDel::NumpadDot

EVE-O Preview reads keyboard scan codes. not pressed key values. This means that if f.e. you have bound a client to key ‘M’ it will be activated even if the keyboard input language has been switched to smth else (f.e. to Russian which maps ‘M’ to ‘Ь’). In other words EVE-O Preview listens to a physical key. So it won’t differentiate between NulLock states

1 Like

Thanks, that explanation matches the behavior perfectly! I dunno if you saw the monster my post turned in to but I think I got it figured out now :stuck_out_tongue:

Appreciate the program, thanks again!

anyway to resize each client window separately?

Nope. This is one of the planned features

someone gave me this picture, and i was trying to figure out why i didnt have the option

You can do it with the older version (v1.18.3). Though the older version obviously has it’s own issues. Hopefully they add it to this version soon!

Is there any particular reason that thumbnails for unlogged clients aren’t hidden by default?

I went ahead and added "EVE": true to my "DisableThumbnail": { section so I’m not staring at a huge thumbnail while waiting out XDT, in case this is annoying anyone else.

2 Likes

Your program stopped lowering the CPU load when minimized to the tray. After 5-10 minutes, some windows start running at 100% CPU. Test — ImgBB
Also, it is noticed that when other processes are active (Browser, etc.), windows are very often reset and start to be active, which loads the processor by 100%.

This is an eve problem - lots of people are seeing it since todays update. Nothing to do with evo o, as normal multi boxers are seeing it.

This is EVE client issue: Version 19.02 - Known Issues - #2 by CCP_Dopamine

1 Like

I have gotten Eve-O preview to work well, if I keep the thumbnails on my main monitor. But when I try to move them to either of my other monitors they are just black rectangles with “EVE - The Witch Doctor” in the top left corner. Is this a known common mistake that I can easily correct?

Turn off HDR on your main display. There is a bug in the Windows 10 core that prevents streaming of window preview from HDR display to non-HDR display.

1 Like

Thank you.

Turn off HDR on your main display. There is a bug in the Windows 10 core that prevents streaming of window preview from HDR display to non-HDR display.

Any other display settings that could cause something similar when having ‘Previews always on top’ option unchecked?

I have a similar issue, with the ‘Previews always on top’ option. No HDR, and even with everything on the same monitor I get no preview and just the name overlay showing when ‘Previews always on top’ is not selected.

It works fine both across monitors and on a single monitor when the option is checked.

EDIT
Also wanted to add that by keeping it checked, I can set other windows on top of the previews, and get the preview back on top by clicking on them. So always on top and streaming video seems to be working fine in Win10 for me, it’s only when unchecking the option in EVE-O that the preview feed disappears.